summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-03-30 04:59:17 +0000
committerPeter Johanson <latexer@gentoo.org>2004-03-30 04:59:17 +0000
commit60adfa6c6b3aaac68666200cc362e45ef9090e83 (patch)
tree5c1396b37d458d2277705526e97f3caf7eb15306 /dev-dotnet/mono
parentChange x11-base/xfree dependency to virtual/x11. (diff)
downloadhistorical-60adfa6c6b3aaac68666200cc362e45ef9090e83.tar.gz
historical-60adfa6c6b3aaac68666200cc362e45ef9090e83.tar.bz2
historical-60adfa6c6b3aaac68666200cc362e45ef9090e83.zip
Added nptl support using nptl USE flag and have_NPTL from eutils. Blame tberman if breaks.
Diffstat (limited to 'dev-dotnet/mono')
-rw-r--r--dev-dotnet/mono/ChangeLog6
-rw-r--r--dev-dotnet/mono/Manifest14
-rw-r--r--dev-dotnet/mono/mono-0.31.ebuild16
3 files changed, 24 insertions, 12 deletions
diff --git a/dev-dotnet/mono/ChangeLog b/dev-dotnet/mono/ChangeLog
index 0d92c6047960..006be05b26d7 100644
--- a/dev-dotnet/mono/ChangeLog
+++ b/dev-dotnet/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-dotnet/mono
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.10 2004/03/21 04:11:12 tberman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.11 2004/03/30 04:59:17 latexer Exp $
+
+ 29 Mar 2004; Peter Johanson <latexer@gentoo.org> mono-0.31.ebuild:
+ Added nptl support behind a nptl USE flag and using have_NPTL from eutils.
+ Blame tberman if things break, he said he'd take the bugs.
20 Mar 2004; Todd Berman <tberman@gentoo.org> mono-0.31.ebuild:
adding --with-nptl=no
diff --git a/dev-dotnet/mono/Manifest b/dev-dotnet/mono/Manifest
index ba9615cd3827..ad4897abac0a 100644
--- a/dev-dotnet/mono/Manifest
+++ b/dev-dotnet/mono/Manifest
@@ -1,12 +1,12 @@
-MD5 c96c15671217217f1ce54c2566b23df1 mono-0.31.ebuild 2472
-MD5 ef5bcf687d27f8644590de7c97cc8991 ChangeLog 6428
-MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
+MD5 7bf46be8171632a2a6fc0a1ff31a207d mono-0.30.ebuild 2457
MD5 4ed40c8ac46ebc2bb8a70d1103c3dbbd mono-0.30.1.ebuild 2459
MD5 5c76a46e0d737e4d86f9ad2e7fa4fbf0 mono-0.28.ebuild 2160
-MD5 7bf46be8171632a2a6fc0a1ff31a207d mono-0.30.ebuild 2457
-MD5 b1d7d1f8b30cadd81ca257cfb0126f2b files/digest-mono-0.30 123
-MD5 33b073ed2746ffc3552b2c68a2215b56 files/digest-mono-0.30.1 127
-MD5 43da8709d0752a2ef9f9dfb050a05d9f files/digest-mono-0.28 123
+MD5 fdfb114ef0a55820e079f44c8db2f6ac mono-0.31.ebuild 2622
+MD5 2205b3c3c3350123e74d500717b1f834 ChangeLog 6636
+MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
MD5 518023a50bb285d0758ed7562a6af8a8 files/dotnet.conf 582
MD5 b3f7f4df1a4f76aa99c3f1e95c83fe4f files/dotnet.init 1043
+MD5 33b073ed2746ffc3552b2c68a2215b56 files/digest-mono-0.30.1 127
+MD5 43da8709d0752a2ef9f9dfb050a05d9f files/digest-mono-0.28 123
+MD5 b1d7d1f8b30cadd81ca257cfb0126f2b files/digest-mono-0.30 123
MD5 e7d95f62bf18430aa812b1a501c2e485 files/digest-mono-0.31 124
diff --git a/dev-dotnet/mono/mono-0.31.ebuild b/dev-dotnet/mono/mono-0.31.ebuild
index d89e703c360c..1455716d736e 100644
--- a/dev-dotnet/mono/mono-0.31.ebuild
+++ b/dev-dotnet/mono/mono-0.31.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.31.ebuild,v 1.2 2004/03/21 04:11:12 tberman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.31.ebuild,v 1.3 2004/03/30 04:59:17 latexer Exp $
-inherit mono flag-o-matic
+inherit eutils mono flag-o-matic
strip-flags
MCS_P="mcs-${PV}"
MCS_S=${WORKDIR}/${MCS_P}
-IUSE=""
+IUSE="nptl"
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
SRC_URI="http://www.go-mono.com/archive/${P}.tar.gz
http://www.go-mono.com/archive/${MCS_P}.tar.gz"
@@ -44,7 +44,15 @@ src_unpack() {
}
src_compile() {
- econf --with-nptl=no || die
+ local myconf=""
+ if [ -n "`use nptl`" ] && have_NPTL
+ then
+ myconf="${myconf} --with-nptl=yes"
+ else
+ myconf="${myconf} --with-nptl=no"
+ fi
+
+ econf ${myconf} || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die "MONO compilation failure"
ln -s ../runtime ${WORKDIR}/${P}/runtime/lib