summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-05-05 04:50:58 +0000
committerPeter Johanson <latexer@gentoo.org>2004-05-05 04:50:58 +0000
commit572e733ab6a68d1ce3f5e0aa8ac2a545539c57a9 (patch)
tree31676765749c7d2a9dafd3a0d22c9e5b26de3e8b /dev-dotnet
parentPatch for msn chat closing crash. Fixes bug #47388 (diff)
downloadhistorical-572e733ab6a68d1ce3f5e0aa8ac2a545539c57a9.tar.gz
historical-572e733ab6a68d1ce3f5e0aa8ac2a545539c57a9.tar.bz2
historical-572e733ab6a68d1ce3f5e0aa8ac2a545539c57a9.zip
Beta1 baby! Now with fun-filled GAC!
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/mono/ChangeLog7
-rw-r--r--dev-dotnet/mono/Manifest4
-rw-r--r--dev-dotnet/mono/files/digest-mono-0.911
-rw-r--r--dev-dotnet/mono/mono-0.91.ebuild73
4 files changed, 83 insertions, 2 deletions
diff --git a/dev-dotnet/mono/ChangeLog b/dev-dotnet/mono/ChangeLog
index 006be05b26d7..dc3f9e9fbccf 100644
--- a/dev-dotnet/mono/ChangeLog
+++ b/dev-dotnet/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/mono
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.11 2004/03/30 04:59:17 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.12 2004/05/05 04:50:56 latexer Exp $
+
+*mono-0.91 (05 May 2004)
+
+ 05 May 2004; Peter Johanson <latexer@gentoo.org> mono-0.91.ebuild:
+ Beta1 baby! Now with fun-filled GAC!
29 Mar 2004; Peter Johanson <latexer@gentoo.org> mono-0.31.ebuild:
Added nptl support behind a nptl USE flag and using have_NPTL from eutils.
diff --git a/dev-dotnet/mono/Manifest b/dev-dotnet/mono/Manifest
index ad4897abac0a..6135416abade 100644
--- a/dev-dotnet/mono/Manifest
+++ b/dev-dotnet/mono/Manifest
@@ -1,8 +1,9 @@
MD5 7bf46be8171632a2a6fc0a1ff31a207d mono-0.30.ebuild 2457
+MD5 3f924bfdbf2d12b3d88b4da79479f15d mono-0.91.ebuild 1650
MD5 4ed40c8ac46ebc2bb8a70d1103c3dbbd mono-0.30.1.ebuild 2459
MD5 5c76a46e0d737e4d86f9ad2e7fa4fbf0 mono-0.28.ebuild 2160
MD5 fdfb114ef0a55820e079f44c8db2f6ac mono-0.31.ebuild 2622
-MD5 2205b3c3c3350123e74d500717b1f834 ChangeLog 6636
+MD5 2a27013d796a40a69d01539ca81dfdc5 ChangeLog 6771
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
MD5 518023a50bb285d0758ed7562a6af8a8 files/dotnet.conf 582
MD5 b3f7f4df1a4f76aa99c3f1e95c83fe4f files/dotnet.init 1043
@@ -10,3 +11,4 @@ MD5 33b073ed2746ffc3552b2c68a2215b56 files/digest-mono-0.30.1 127
MD5 43da8709d0752a2ef9f9dfb050a05d9f files/digest-mono-0.28 123
MD5 b1d7d1f8b30cadd81ca257cfb0126f2b files/digest-mono-0.30 123
MD5 e7d95f62bf18430aa812b1a501c2e485 files/digest-mono-0.31 124
+MD5 0145cec2f8b351f3a72669bd6f7e4e0e files/digest-mono-0.91 63
diff --git a/dev-dotnet/mono/files/digest-mono-0.91 b/dev-dotnet/mono/files/digest-mono-0.91
new file mode 100644
index 000000000000..052513b5f064
--- /dev/null
+++ b/dev-dotnet/mono/files/digest-mono-0.91
@@ -0,0 +1 @@
+MD5 eea86524624bd0e02fb90cec71fd0673 mono-0.91.tar.gz 17324655
diff --git a/dev-dotnet/mono/mono-0.91.ebuild b/dev-dotnet/mono/mono-0.91.ebuild
new file mode 100644
index 000000000000..b2aa9f357c87
--- /dev/null
+++ b/dev-dotnet/mono/mono-0.91.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.91.ebuild,v 1.1 2004/05/05 04:50:56 latexer Exp $
+
+inherit eutils mono flag-o-matic
+
+strip-flags
+
+MCS_P="mcs-${PV}"
+MCS_S=${WORKDIR}/${MCS_P}
+
+IUSE="nptl"
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+SRC_URI="http://www.go-mono.com/archive/beta1/${P}.tar.gz"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="GPL-2 | LGPL-2 | X11"
+SLOT="0"
+
+KEYWORDS="~x86 -ppc"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-2.0
+ >=dev-libs/icu-2.6.1
+ !dev-dotnet/pnet"
+
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_compile() {
+ local myconf=""
+ if [ -n "`use nptl`" ] && have_NPTL
+ then
+ myconf="${myconf} --with-nptl=yes"
+ else
+ myconf="${myconf} --with-nptl=no"
+ fi
+
+ econf ${myconf} || die
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "MONO compilation failure"
+}
+
+src_install () {
+ cd ${S}
+ einstall || die
+
+ dodoc AUTHORS ChangeLog COPYING.LIB NEWS README
+ docinto docs
+ dodoc docs/*
+
+ # install mono's logo
+ insopts -m0644
+ insinto /usr/share/pixmaps/mono
+ doins MonoIcon.png ScalableMonoIcon.svg
+
+ docinto mcs
+ dodoc AUTHORS COPYING README* ChangeLog INSTALL.txt
+ docinto mcs/docs
+ dodoc docs/*.txt
+
+ # init script
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dotnet.init dotnet
+ insinto /etc/conf.d ; newins ${FILESDIR}/dotnet.conf dotnet
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you want to avoid typing '<runtime> program.exe'"
+ einfo "you can configure your runtime in /etc/conf.d/dotnet"
+ einfo "Use /etc/init.d/dotnet to register your runtime"
+ echo
+}