summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-08-04 21:03:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-08-04 21:03:17 +0000
commit063e8144d4aef74f19c05136427f3855618a2116 (patch)
tree737eb5366a71e39df3827f525bf47e5dc98f1c0b /dev-haskell/hashed-storage
parentAnd apparently now it turns out --without-network doesn't just disable the vi... (diff)
downloadhistorical-063e8144d4aef74f19c05136427f3855618a2116.tar.gz
historical-063e8144d4aef74f19c05136427f3855618a2116.tar.bz2
historical-063e8144d4aef74f19c05136427f3855618a2116.zip
dev-vcs/darcs: version bump (and it's minimal depends)
Package-Manager: portage-2.1.10.10/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/hashed-storage')
-rw-r--r--dev-haskell/hashed-storage/ChangeLog8
-rw-r--r--dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch20
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild46
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-haskell/hashed-storage/ChangeLog b/dev-haskell/hashed-storage/ChangeLog
index 0fd180724358..ab2821fcbea8 100644
--- a/dev-haskell/hashed-storage/ChangeLog
+++ b/dev-haskell/hashed-storage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hashed-storage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.12 2011/08/04 13:17:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.13 2011/08/04 21:03:16 slyfox Exp $
+
+*hashed-storage-0.5.7 (04 Aug 2011)
+
+ 04 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ +hashed-storage-0.5.7.ebuild, +files/hashed-storage-0.5.7-ghc-7.2.patch:
+ Version bump.
04 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org>
-hashed-storage-0.4.10.ebuild:
diff --git a/dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch b/dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch
new file mode 100644
index 000000000000..01940fe44596
--- /dev/null
+++ b/dev-haskell/hashed-storage/files/hashed-storage-0.5.7-ghc-7.2.patch
@@ -0,0 +1,20 @@
+diff --git a/Storage/Hashed/Monad.hs b/Storage/Hashed/Monad.hs
+index b86a702..5d96d4d 100644
+--- a/Storage/Hashed/Monad.hs
++++ b/Storage/Hashed/Monad.hs
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE ScopedTypeVariables, BangPatterns, TypeSynonymInstances, UndecidableInstances #-}
++{-# LANGUAGE FlexibleInstances #-}
+
+ -- | An experimental monadic interface to Tree mutation. The main idea is to
+ -- simulate IO-ish manipulation of real filesystem (that's the state part of
+diff --git a/Storage/Hashed/Tree.hs b/Storage/Hashed/Tree.hs
+index 0bef0e6..c4bb669 100644
+--- a/Storage/Hashed/Tree.hs
++++ b/Storage/Hashed/Tree.hs
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE ScopedTypeVariables, MultiParamTypeClasses, FlexibleInstances #-}
++{-# LANGUAGE BangPatterns #-}
+
+ -- | The abstract representation of a Tree and useful abstract utilities to
+ -- handle those.
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild
new file mode 100644
index 000000000000..205785bb504f
--- /dev/null
+++ b/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/hashed-storage-0.5.7.ebuild,v 1.1 2011/08/04 21:03:16 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Hashed file storage support code."
+HOMEPAGE="http://hackage.haskell.org/package/hashed-storage"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="dev-haskell/binary
+ dev-haskell/dataenc
+ =dev-haskell/mmap-0.5*
+ dev-haskell/mtl
+ dev-haskell/zlib
+ >=dev-lang/ghc-6.12"
+DEPEND=">=dev-haskell/cabal-1.6
+ test? (
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/zip-archive
+ )
+ ${RDEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.7-ghc-7.2.patch")
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test)
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${D}/usr/bin/hashed-storage-test"
+}