summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-06-07 18:05:53 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-06-07 18:05:53 +0000
commitae2bd66caf98351824a46895b4170747f796a1cf (patch)
treecfeb2d6e737307d32b238c1897d96c7e1325df95 /dev-java/commons-daemon
parentThanks to AZ for fixing this even better -- the tests should work, and we hav... (diff)
downloadhistorical-ae2bd66caf98351824a46895b4170747f796a1cf.tar.gz
historical-ae2bd66caf98351824a46895b4170747f796a1cf.tar.bz2
historical-ae2bd66caf98351824a46895b4170747f796a1cf.zip
New upstream release, fixes #95049. Introduced support for the examples and the source useflag.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/commons-daemon')
-rw-r--r--dev-java/commons-daemon/ChangeLog9
-rw-r--r--dev-java/commons-daemon/Manifest14
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.1.ebuild59
-rw-r--r--dev-java/commons-daemon/files/digest-commons-daemon-1.0.11
4 files changed, 81 insertions, 2 deletions
diff --git a/dev-java/commons-daemon/ChangeLog b/dev-java/commons-daemon/ChangeLog
index a33a3bdb94d7..d50290e345df 100644
--- a/dev-java/commons-daemon/ChangeLog
+++ b/dev-java/commons-daemon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/commons-daemon
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.13 2005/05/29 15:31:46 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.14 2005/06/07 18:05:53 luckyduck Exp $
+
+*commons-daemon-1.0.1 (07 Jun 2005)
+
+ 07 Jun 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +commons-daemon-1.0.1.ebuild:
+ New upstream release, fixes #95049. Introduced support for the examples and
+ the source useflag.
29 May 2005; Markus Rothe <corsair@gentoo.org> commons-daemon-1.0.ebuild:
Stable on ppc64
diff --git a/dev-java/commons-daemon/Manifest b/dev-java/commons-daemon/Manifest
index 1b6bd91bf1e3..230798b01906 100644
--- a/dev-java/commons-daemon/Manifest
+++ b/dev-java/commons-daemon/Manifest
@@ -1,4 +1,16 @@
-MD5 28f54101d4d290901132fc3a4e9308fd ChangeLog 1713
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 4672cdd8b146c32b155bea14dcae806b commons-daemon-1.0.1.ebuild 1597
MD5 3964aa3b04a20dea9de116ee4c192243 commons-daemon-1.0.ebuild 1295
+MD5 05a2811225c0064a602d150ed750ea94 ChangeLog 1937
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 33c2af11a1ef867c6f6667c9c015eda6 files/digest-commons-daemon-1.0.1 64
MD5 594ef90d87023327ed87ea6bad1ce322 files/digest-commons-daemon-1.0 68
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCpeIf06ebR+OMO78RAjmUAJ45QRjhsQT8Sa6pQks4Is8HLf1RTACglIa2
+DOM9r+hTWGdV41t0qn/iYwc=
+=R2KC
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.1.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.1.ebuild
new file mode 100644
index 000000000000..9a325ff03f08
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/commons-daemon-1.0.1.ebuild,v 1.1 2005/06/07 18:05:53 luckyduck Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="Tools to allow java programs to run as unix daemons"
+SRC_URI="mirror://apache/jakarta/commons/daemon/source/daemon-${PV}.tar.gz"
+HOMEPAGE="http://jakarta.apache.org/commons/daemon/"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples jikes source"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ virtual/libc
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/daemon-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/native/unix
+ sed -e "s/powerpc/powerpc|powerpc64/g" -i support/apsupport.m4
+ export WANT_AUTOCONF="2.5"
+ autoconf
+}
+
+src_compile() {
+ # compile native stuff
+ cd ${S}/src/native/unix
+ econf || die "configure failed"
+ emake || die "make failed"
+
+ # compile java stuff
+ cd ${S}
+ local antflags="jar"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compilation problem"
+}
+
+src_install () {
+ dobin src/native/unix/jsvc
+ java-pkg_dojar dist/${PN}.jar || die "Unable to install"
+
+ dodoc README RELEASE-NOTES.txt *.html
+ use doc && java-pkg_dohtml -r dist/docs/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -R src/samples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+ use source && java-pkg_dosrc src/java/* src/native/unix/native
+}
diff --git a/dev-java/commons-daemon/files/digest-commons-daemon-1.0.1 b/dev-java/commons-daemon/files/digest-commons-daemon-1.0.1
new file mode 100644
index 000000000000..1755e56d8f52
--- /dev/null
+++ b/dev-java/commons-daemon/files/digest-commons-daemon-1.0.1
@@ -0,0 +1 @@
+MD5 df3eb5aafa53ca530843a09d40b8a1c0 daemon-1.0.1.tar.gz 301023