summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-02-11 12:27:30 +0000
committerVlastimil Babka <caster@gentoo.org>2007-02-11 12:27:30 +0000
commit9fc17641328edfec92b101af360affe8c034f336 (patch)
tree58b8de1b970e98cb341fcfb88a300202874465bc /dev-java/commons-net
parentDisable extra autodetected optimizations (diff)
downloadhistorical-9fc17641328edfec92b101af360affe8c034f336.tar.gz
historical-9fc17641328edfec92b101af360affe8c034f336.tar.bz2
historical-9fc17641328edfec92b101af360affe8c034f336.zip
Cleanup.
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/ChangeLog7
-rw-r--r--dev-java/commons-net/commons-net-1.2.2-r1.ebuild43
-rw-r--r--dev-java/commons-net/commons-net-1.3.0-r1.ebuild58
-rw-r--r--dev-java/commons-net/commons-net-1.4.1.ebuild53
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.2.2-r13
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.3.0-r13
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.4.13
-rw-r--r--dev-java/commons-net/files/gentoo-1.2.diff77
-rw-r--r--dev-java/commons-net/files/gentoo.diff125
9 files changed, 6 insertions, 366 deletions
diff --git a/dev-java/commons-net/ChangeLog b/dev-java/commons-net/ChangeLog
index d059e6b1b422..576ed5fdce76 100644
--- a/dev-java/commons-net/ChangeLog
+++ b/dev-java/commons-net/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-net
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.41 2007/02/10 19:10:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.42 2007/02/11 12:25:20 caster Exp $
+
+ 11 Feb 2007; Vlastimil Babka <caster@gentoo.org> -files/gentoo-1.2.diff,
+ -files/gentoo.diff, -commons-net-1.2.2-r1.ebuild,
+ -commons-net-1.3.0-r1.ebuild, -commons-net-1.4.1.ebuild:
+ Cleanup.
10 Feb 2007; nixnut <nixnut@gentoo.org> commons-net-1.4.1-r1.ebuild:
Stable on ppc wrt bug 163955
diff --git a/dev-java/commons-net/commons-net-1.2.2-r1.ebuild b/dev-java/commons-net/commons-net-1.2.2-r1.ebuild
deleted file mode 100644
index 7b73f2f943b1..000000000000
--- a/dev-java/commons-net/commons-net-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.2-r1.ebuild,v 1.4 2006/10/05 15:31:31 gustavoz Exp $
-
-inherit eutils java-pkg
-
-DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
-HOMEPAGE="http://jakarta.apache.org/commons/net/"
-SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
-RDEPEND=">=virtual/jre-1.3
- =dev-java/jakarta-oro-2.0*"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-core-1.5.4
- jikes? ( dev-java/jikes )
- source? ( app-arch/zip )
- ${RDEPEND}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="x86 ppc amd64"
-IUSE="doc jikes source"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/gentoo-1.2.diff
- #for some reason 1.2.2 claims its 1.3
- sed "s/commons-net-1.3.0-dev/commons-net-1.2.2-dev/" -i build.xml || die "died on sed"
-}
-
-src_compile() {
- local antflags="-Doro.jar=$(java-pkg_getjars jakarta-oro-2.0) jar"
- use doc && antflags="${antflags} javadoc"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- ant ${antflags} || die "died on ant"
-}
-
-src_install() {
- java-pkg_newjar target/${P}-dev.jar ${PN}.jar
-
- use doc && java-pkg_dohtml -r dist/docs/
- use source && java-pkg_dosrc src/java/org
-}
diff --git a/dev-java/commons-net/commons-net-1.3.0-r1.ebuild b/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
deleted file mode 100644
index e32713761a7b..000000000000
--- a/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.3.0-r1.ebuild,v 1.6 2006/10/05 15:31:31 gustavoz Exp $
-
-inherit eutils java-pkg
-
-DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
-HOMEPAGE="http://jakarta.apache.org/commons/net/"
-SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/jakarta-oro-2.0"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-core-1.5.4
- junit? ( dev-java/junit )
- jikes? ( dev-java/jikes )
- source? ( app-arch/zip )
- ${RDEPEND}"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64 ppc64"
-IUSE="doc examples jikes junit source"
-
-S=${WORKDIR}/${P}-src
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- mkdir -p target/lib
- cd target/lib
- java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
-
- cd ${S}
- if ! use junit ; then
- sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
- else
- if ! has_version dev-java/ant-tasks; then
- sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
- fi
- fi
-}
-
-src_compile() {
- local antflags="jar -Dnoget=true"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- use doc && antflags="${antflags} javadoc"
- ant ${antflags} || die "died on ant"
-}
-
-src_install() {
- java-pkg_newjar target/${P}-dev.jar ${PN}.jar
-
- use doc && java-pkg_dohtml -r dist/docs/
- if use examples; then
- dodir /usr/share/doc/${PF}/examples
- cp -r src/java/examples/* ${D}/usr/share/doc/${PF}/examples
- fi
- use source && java-pkg_dosrc src/java/org
-}
diff --git a/dev-java/commons-net/commons-net-1.4.1.ebuild b/dev-java/commons-net/commons-net-1.4.1.ebuild
deleted file mode 100644
index ba7d229d6603..000000000000
--- a/dev-java/commons-net/commons-net-1.4.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.4.1.ebuild,v 1.3 2006/10/05 15:31:31 gustavoz Exp $
-
-inherit eutils java-pkg
-
-MY_P="${P}-src"
-DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
-HOMEPAGE="http://jakarta.apache.org/commons/net/"
-SRC_URI="mirror://apache/jakarta/commons/net/source/${MY_P}.tar.gz"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/jakarta-oro-2.0"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-core-1.5.4
- jikes? ( dev-java/jikes )
- source? ( app-arch/zip )
- ${RDEPEND}"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64 ~ppc64"
-# disabling unit tests:
-# http://issues.apache.org/bugzilla/show_bug.cgi?id=37985
-IUSE="doc examples jikes source" # junit
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- mkdir -p target/lib
- cd target/lib
- java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
-
- cd ${S}
- # always disable tests
- sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
-}
-
-src_compile() {
- local antflags="jar -Dnoget=true"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- use doc && antflags="${antflags} javadoc"
- ant ${antflags} || die "died on ant"
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar ${PN}.jar
-
- use doc && java-pkg_dohtml -r dist/docs/
- if use examples; then
- dodir /usr/share/doc/${PF}/examples
- cp -r src/java/examples/* ${D}/usr/share/doc/${PF}/examples
- fi
- use source && java-pkg_dosrc src/java/org
-}
diff --git a/dev-java/commons-net/files/digest-commons-net-1.2.2-r1 b/dev-java/commons-net/files/digest-commons-net-1.2.2-r1
deleted file mode 100644
index 1496ae8543a0..000000000000
--- a/dev-java/commons-net/files/digest-commons-net-1.2.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3856e8b3f50bdfffbf186e07c477f73b commons-net-1.2.2-src.tar.gz 178572
-RMD160 c0c802942db133d00b412489a685b13526a5e800 commons-net-1.2.2-src.tar.gz 178572
-SHA256 41039a2368f715549cb693a7b5cdf6922d9706ab95a6838531878516d609a588 commons-net-1.2.2-src.tar.gz 178572
diff --git a/dev-java/commons-net/files/digest-commons-net-1.3.0-r1 b/dev-java/commons-net/files/digest-commons-net-1.3.0-r1
deleted file mode 100644
index 1a9ffa70fa11..000000000000
--- a/dev-java/commons-net/files/digest-commons-net-1.3.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 1394cc644125c9cf69d23db5ac37295b commons-net-1.3.0-src.tar.gz 267046
-RMD160 05189b5ceb59a24fb115d69530dc0dd62445dc17 commons-net-1.3.0-src.tar.gz 267046
-SHA256 ed684e930984cb941b00062279654400b2dd415cc401e10283c9825d3a52a9c4 commons-net-1.3.0-src.tar.gz 267046
diff --git a/dev-java/commons-net/files/digest-commons-net-1.4.1 b/dev-java/commons-net/files/digest-commons-net-1.4.1
deleted file mode 100644
index ab55a78f9644..000000000000
--- a/dev-java/commons-net/files/digest-commons-net-1.4.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ccbb3f67b55e8a7a676499db4386673c commons-net-1.4.1-src.tar.gz 229198
-RMD160 31af13be8d1bac7d821c9d5618a9661197a4b42f commons-net-1.4.1-src.tar.gz 229198
-SHA256 fdea779f261f70b9bbec40121c830b11e3e63b6188f662f95505045ff8d44add commons-net-1.4.1-src.tar.gz 229198
diff --git a/dev-java/commons-net/files/gentoo-1.2.diff b/dev-java/commons-net/files/gentoo-1.2.diff
deleted file mode 100644
index b840b298b1d1..000000000000
--- a/dev-java/commons-net/files/gentoo-1.2.diff
+++ /dev/null
@@ -1,77 +0,0 @@
---- build.xml 2004-04-30 20:02:34.000000000 -0500
-+++ build.xml.patched 2004-05-08 14:16:02.487920896 -0500
-@@ -19,6 +19,13 @@
- on date February 16 2004, time 2310-->
-
- <project default="jar" name="commons-net" basedir=".">
-+ <path id="compile.classpath">
-+ <pathelement location="target/classes"/>
-+ <pathelement location="target/test-classes"/>
-+ <pathelement location="target/test-reports"/>
-+ <pathelement location="${oro.jar}"/>
-+ <pathelement location="${junit.jar}"/>
-+ </path>
- <property name="defaulttargetdir" value="target">
- </property>
- <property name="libdir" value="target/lib">
-@@ -43,7 +50,7 @@
- </equals>
- </condition>
- </target>
-- <target name="compile" description="o Compile the code" depends="get-deps">
-+ <target name="compile" description="o Compile the code">
- <mkdir dir="${classesdir}">
- </mkdir>
- <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
-@@ -51,15 +58,10 @@
- <pathelement location="src/java">
- </pathelement>
- </src>
-- <classpath>
-- <fileset dir="${libdir}">
-- <include name="*.jar">
-- </include>
-- </fileset>
-- </classpath>
-+ <classpath refid="compile.classpath"/>
- </javac>
- </target>
-- <target name="jar" description="o Create the jar" depends="compile,test">
-+ <target name="jar" description="o Create the jar" depends="compile">
- <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
- </jar>
- </target>
-@@ -143,30 +145,13 @@
- <property name="title" value="Jakarta Commons/Net 1.2.0-dev API">
- </property>
- <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.net.*">
-- <classpath>
-- <fileset dir="${libdir}">
-- <include name="*.jar">
-- </include>
-- </fileset>
-- <pathelement location="target/${final.name}.jar">
-- </pathelement>
-- </classpath>
-+ <classpath refid="compile.classpath"/>
- </javadoc>
- </target>
-- <target name="get-deps" unless="noget" depends="init">
-- <get dest="${libdir}/oro-2.0.8.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/oro/jars/oro-2.0.8.jar">
-- </get>
-- <get dest="${libdir}/junit-3.8.1.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/junit/jars/junit-3.8.1.jar">
-- </get>
-- <get dest="${libdir}/ant-1.5.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/ant/jars/ant-1.5.jar">
-- </get>
-- <get dest="${libdir}/ant-optional-1.5.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/ant/jars/ant-optional-1.5.jar">
-- </get>
-- </target>
- <target name="install-maven">
- <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar">
- </get>
- <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
- </unjar>
- </target>
--</project>
-\ No newline at end of file
-+</project>
diff --git a/dev-java/commons-net/files/gentoo.diff b/dev-java/commons-net/files/gentoo.diff
deleted file mode 100644
index 80348a3cfc15..000000000000
--- a/dev-java/commons-net/files/gentoo.diff
+++ /dev/null
@@ -1,125 +0,0 @@
---- build.xml 2003-10-22 21:12:59.000000000 -0500
-+++ build.xml.patched 2004-02-28 13:04:14.563419552 -0500
-@@ -6,6 +6,14 @@
- -->
-
- <project default="jar" name="commons-net" basedir=".">
-+ <path id="compile.classpath">
-+ <pathelement location="target/classes"/>
-+ <pathelement location="target/test-classes"/>
-+ <pathelement location="target/test-reports"/>
-+ <pathelement location="${oro.jar}"/>
-+ <pathelement location="${junit.jar}"/>
-+ </path>
-+
- <property name="defaulttargetdir" value="target">
- </property>
- <property name="libdir" value="target/lib">
-@@ -25,12 +33,8 @@
- <target name="init" description="o Initializes some properties">
- <mkdir dir="${libdir}">
- </mkdir>
-- <condition property="noget">
-- <equals arg2="only" arg1="${build.sysclasspath}">
-- </equals>
-- </condition>
- </target>
-- <target name="compile" description="o Compile the code" depends="get-deps">
-+ <target name="compile" description="o Compile the code">
- <mkdir dir="${classesdir}">
- </mkdir>
- <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
-@@ -38,15 +42,10 @@
- <pathelement location="src/java">
- </pathelement>
- </src>
-- <classpath>
-- <fileset dir="${libdir}">
-- <include name="*.jar">
-- </include>
-- </fileset>
-- </classpath>
-+ <classpath refid="compile.classpath"/>
- </javac>
- </target>
-- <target name="jar" description="o Create the jar" depends="compile,test">
-+ <target name="jar" description="o Create the jar" depends="compile">
- <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
- </jar>
- </target>
-@@ -73,23 +72,12 @@
- <target name="internal-test" depends="compile-tests">
- <mkdir dir="${testreportdir}">
- </mkdir>
-- <junit dir="./" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
-- <sysproperty key="basedir" value=".">
-- </sysproperty>
-+ <junit>
-+ <classpath refid="compile.classpath"/>
- <formatter type="xml">
- </formatter>
- <formatter usefile="false" type="plain">
- </formatter>
-- <classpath>
-- <fileset dir="${libdir}">
-- <include name="*.jar">
-- </include>
-- </fileset>
-- <pathelement path="${testclassesdir}">
-- </pathelement>
-- <pathelement path="${classesdir}">
-- </pathelement>
-- </classpath>
- <batchtest todir="${testreportdir}">
- <fileset dir="src/test">
- <include name="**/*Test.java">
-@@ -108,14 +96,7 @@
- <pathelement location="src/test">
- </pathelement>
- </src>
-- <classpath>
-- <fileset dir="${libdir}">
-- <include name="*.jar">
-- </include>
-- </fileset>
-- <pathelement path="${classesdir}">
-- </pathelement>
-- </classpath>
-+ <classpath refid="compile.classpath"/>
- </javac>
- </target>
- <target name="javadoc" description="o Generate javadoc" depends="jar">
-@@ -130,30 +111,13 @@
- <property name="title" value="Jakarta Commons/Net 1.0.1-dev API">
- </property>
- <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.net.*">
-- <classpath>
-- <fileset dir="${libdir}">
-- <include name="*.jar">
-- </include>
-- </fileset>
-- <pathelement location="target/${final.name}.jar">
-- </pathelement>
-- </classpath>
-+ <classpath refid="compile.classpath"/>
- </javadoc>
- </target>
-- <target name="get-deps" unless="noget" depends="init">
-- <get dest="${libdir}/oro-2.0.7.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/oro/jars/oro-2.0.7.jar">
-- </get>
-- <get dest="${libdir}/junit-3.8.1.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/junit/jars/junit-3.8.1.jar">
-- </get>
-- <get dest="${libdir}/ant-1.5.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/ant/jars/ant-1.5.jar">
-- </get>
-- <get dest="${libdir}/ant-optional-1.5.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/ant/jars/ant-optional-1.5.jar">
-- </get>
-- </target>
- <target name="install-maven">
- <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar">
- </get>
- <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
- </unjar>
- </target>
--</project>
-\ No newline at end of file
-+</project>