summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-11-16 16:15:14 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-11-16 16:15:14 +0000
commit6906aa52b2bf6b25518c6e1f22e4ae1a42e98407 (patch)
treee163d7cec7098adbbc3e36acef303f251d7a8390 /dev-java/httpunit
parentStable on alpha, bug #246826 (diff)
downloadhistorical-6906aa52b2bf6b25518c6e1f22e4ae1a42e98407.tar.gz
historical-6906aa52b2bf6b25518c6e1f22e4ae1a42e98407.tar.bz2
historical-6906aa52b2bf6b25518c6e1f22e4ae1a42e98407.zip
Added ebuild from java-overlay
Package-Manager: portage-2.2_rc14/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'dev-java/httpunit')
-rw-r--r--dev-java/httpunit/ChangeLog10
-rw-r--r--dev-java/httpunit/Manifest5
-rw-r--r--dev-java/httpunit/files/rhino-fix-1.6.2.diff25
-rw-r--r--dev-java/httpunit/httpunit-1.6.2-r2.ebuild52
-rw-r--r--dev-java/httpunit/metadata.xml12
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-java/httpunit/ChangeLog b/dev-java/httpunit/ChangeLog
new file mode 100644
index 000000000000..155f8f462d7d
--- /dev/null
+++ b/dev-java/httpunit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/httpunit
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpunit/ChangeLog,v 1.1 2008/11/16 16:15:14 fordfrog Exp $
+
+*httpunit-1.6.2-r2 (16 Nov 2008)
+
+ 16 Nov 2008; Miroslav Šulc <fordfrog@gentoo.org>
+ +files/rhino-fix-1.6.2.diff, +metadata.xml, +httpunit-1.6.2-r2.ebuild:
+ Added ebuild from java-overlay
+
diff --git a/dev-java/httpunit/Manifest b/dev-java/httpunit/Manifest
new file mode 100644
index 000000000000..db4b50b65c71
--- /dev/null
+++ b/dev-java/httpunit/Manifest
@@ -0,0 +1,5 @@
+AUX rhino-fix-1.6.2.diff 1099 RMD160 3453cd0ef9a5afd8de724771af3721371a4a1aa0 SHA1 dfd598fbd74c79e0f2834494ebc2a87c65009687 SHA256 0d805d2fd551ec4f35c8245aaf710cd2e9ea0d86ce3c816e088a480abade81d3
+DIST httpunit-1.6.2.zip 3186694 RMD160 14a73ec624f5a42df9ee7ad99f16a1516ac375b0 SHA1 a73da239509668ff24e2bf07d7d437b9283811a3 SHA256 03d86b78064e1f4e07d9fc468a4a108f297a9969b52f8bcbc0633d146cf69e14
+EBUILD httpunit-1.6.2-r2.ebuild 1205 RMD160 4094cc90a896febaa90ae1527c9739e99d9237ff SHA1 ad30eac7956ff784d082883dc3ec2f1fc8e61b99 SHA256 510a4bce8014101b18bac46e3be7e6fa94116abf462b666f8508e7095f62f4a8
+MISC ChangeLog 402 RMD160 38a2a99512b68a7c30badc937f2f2a6c3eb073a2 SHA1 d5b508a9307e00f6a3bb7318cb1ce4c4bd90503f SHA256 8cc2e62de58ceeb7d402e495a321c4bb158061a2f0515240d694f5855030d58d
+MISC metadata.xml 507 RMD160 4f686a878365421111b80fd0bf2e21e42c01b432 SHA1 8f86706408320b0d6d8fe06baa08b57ba58a6dec SHA256 d8142cbfeb1867461ca204d51007a57e60eebc254140dfe6a3e49192ccdcf0b8
diff --git a/dev-java/httpunit/files/rhino-fix-1.6.2.diff b/dev-java/httpunit/files/rhino-fix-1.6.2.diff
new file mode 100644
index 000000000000..c439d7183ca0
--- /dev/null
+++ b/dev-java/httpunit/files/rhino-fix-1.6.2.diff
@@ -0,0 +1,25 @@
+diff -Nur httpunit-1.6.2/src/com/meterware/httpunit/javascript/JavaScript.java httpunit-1.6.2_fixed/src/com/meterware/httpunit/javascript/JavaScript.java
+--- httpunit-1.6.2/src/com/meterware/httpunit/javascript/JavaScript.java 2006-03-26 22:16:46.000000000 +0300
++++ httpunit-1.6.2_fixed/src/com/meterware/httpunit/javascript/JavaScript.java 2007-10-14 20:34:03.000000000 +0300
+@@ -838,8 +838,6 @@
+ static ElementArray newElementArray( Scriptable parent ) {
+ try {
+ return (ElementArray) Context.getCurrentContext().newObject( parent, "ElementArray" );
+- } catch (PropertyException e) {
+- throw new RhinoException( e );
+ } catch (NotAFunctionException e) {
+ throw new RhinoException( e );
+ } catch (JavaScriptException e) {
+@@ -1144,10 +1142,10 @@
+
+ class RhinoException extends RuntimeException {
+
+- private Exception _cause;
++ private Throwable _cause;
+
+
+- public RhinoException( Exception cause ) {
++ public RhinoException( Throwable cause ) {
+ _cause = cause;
+ }
+
diff --git a/dev-java/httpunit/httpunit-1.6.2-r2.ebuild b/dev-java/httpunit/httpunit-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..53e102122a0b
--- /dev/null
+++ b/dev-java/httpunit/httpunit-1.6.2-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpunit/httpunit-1.6.2-r2.ebuild,v 1.1 2008/11/16 16:15:14 fordfrog Exp $
+
+EAPI="2"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="HttpUnit emulates the relevant portions of browser behavior."
+HOMEPAGE="http://httpunit.sourceforge.net/"
+# TODO what is metainf for?
+# TODO where did it come from?
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+CDEPEND="
+ >=dev-java/junit-3.8:0
+ dev-java/rhino:1.5
+ dev-java/jtidy:0
+ java-virtuals/servlet-api:2.3
+ dev-java/xerces:2"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ find "${S}" -name "*.jar" | xargs rm -v
+ cd "${S}"
+ epatch "${FILESDIR}/rhino-fix-${PV}.diff"
+ cd "${S}/jars"
+ java-pkg_jar-from junit,rhino-1.5,xerces-2,jtidy,servlet-api-2.3
+}
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+ eant clean jar $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_dojar "lib/${PN}.jar"
+ dodoc doc/*.txt
+ if use doc; then
+ dohtml -r doc/manual doc/tutorial
+ java-pkg_dojavadoc doc/api
+ fi
+}
diff --git a/dev-java/httpunit/metadata.xml b/dev-java/httpunit/metadata.xml
new file mode 100644
index 000000000000..8337051fb6b7
--- /dev/null
+++ b/dev-java/httpunit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ HttpUnit emulates the relevant portions of browser behavior,
+ including form submission, JavaScript, basic http authentication,
+ cookies and automatic page redirection, and allows Java test code
+ to examine returned pages either as text, an XML DOM, or containers
+ of forms, tables, and links.
+ </longdescription>
+</pkgmetadata>