summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-14 05:32:00 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-14 05:32:00 +0000
commit8c820edab98db9223d075d99a274c8fb95918437 (patch)
tree2798394f008161f1a9a0e6426bc57fecce640802 /dev-java/junit
parentversion update (diff)
downloadhistorical-8c820edab98db9223d075d99a274c8fb95918437.tar.gz
historical-8c820edab98db9223d075d99a274c8fb95918437.tar.bz2
historical-8c820edab98db9223d075d99a274c8fb95918437.zip
Fixes #17284 and problems reported in Gentoo Forums.
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/ChangeLog9
-rw-r--r--dev-java/junit/files/digest-junit-3.7-r21
-rw-r--r--dev-java/junit/files/junit-3.7-build.xml106
-rw-r--r--dev-java/junit/junit-3.7-r2.ebuild38
4 files changed, 153 insertions, 1 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index 09414ea73437..0bc446474527 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/junit
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.7 2003/02/12 05:53:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.8 2003/03/14 05:32:00 absinthe Exp $
+
+*junit-3.7-r2 (14 Mar 2003)
+
+ 14 Mar 2003; Dylan Carlson <absinthe@gentoo.org> junit-3.7-r2.ebuild,
+ files/junit-3.7-build.xml:
+ Fixed ant build problem reported in user forums, and got this process
+ to compile. Closes #17284.
*junit-3.8.1 (14 Oct 2002)
diff --git a/dev-java/junit/files/digest-junit-3.7-r2 b/dev-java/junit/files/digest-junit-3.7-r2
new file mode 100644
index 000000000000..1f890c0d2aba
--- /dev/null
+++ b/dev-java/junit/files/digest-junit-3.7-r2
@@ -0,0 +1 @@
+MD5 ff5816f35fa99bc4347af65fb40d86c9 junit3.7.zip 374491
diff --git a/dev-java/junit/files/junit-3.7-build.xml b/dev-java/junit/files/junit-3.7-build.xml
new file mode 100644
index 000000000000..50060e0c3f22
--- /dev/null
+++ b/dev-java/junit/files/junit-3.7-build.xml
@@ -0,0 +1,106 @@
+<!-- JUnit build script using ant 1.3 -->
+<project name="junit" default="dist" basedir=".">
+ <target name="init">
+ <tstamp/>
+ <property name="version" value="3.7" />
+ <property name="dist" value="junit${version}" />
+ <property name="versionfile" value="junit/runner/Version.java" />
+ <property name="zipfile" value="${dist}.zip" />
+ </target>
+
+ <target name="versiontag" depends="init">
+ <filter token="version" value="${version}" />
+ <copy
+ file="${versionfile}"
+ tofile="${versionfile}tmp"
+ filtering="on"
+ />
+ <move file="${versionfile}tmp" tofile="${versionfile}" />
+ </target>
+
+ <target name="build" depends="versiontag">
+ <javac
+ srcdir="."
+ destdir="."
+ debug="on"
+ />
+ </target>
+
+ <target name="dist" depends="build">
+ <delete dir="${dist}" />
+ <mkdir dir="${dist}" />
+ <jar
+ jarfile="${dist}/src.jar"
+ basedir="."
+ excludes="${dist}/src.jar, junit/tests/**, junit/samples/**, **/*.class, doc/**, README.html, build.xml"
+ />
+ <jar
+ jarfile="${dist}/junit.jar"
+ basedir="."
+ excludes="${dist}/junit.jar, junit/tests/**, junit/samples/**, **/*.java, doc/**, README.html, jar-manifest.txt"
+ />
+ <copy todir="${dist}/junit/samples">
+ <fileset dir="junit/samples" />
+ </copy>
+ <copy todir="${dist}/junit/tests">
+ <fileset dir="junit/tests" />
+ </copy>
+ <delete file="${dist}/junit/tests/test.jar"/>
+ <jar
+ jarfile="${dist}/junit/tests/test.jar"
+ basedir="."
+ includes="junit/tests/LoadedFromJar.class"
+ />
+ <mkdir dir="${dist}/javadoc" />
+ <javadoc
+ sourcepath="."
+ packagenames="junit.framework.*, junit.extensions.*"
+ destdir="${dist}/javadoc"
+ author="false"
+ version="false"
+ use="false"
+ windowtitle="JUnit API"
+ />
+ <copy todir="${dist}/doc">
+ <fileset dir="doc"/>
+ </copy>
+ <copy file="README.html" tofile="${dist}/README.html" />
+
+ <java classname="junit.textui.TestRunner" fork="yes">
+ <arg value="junit.samples.AllTests" />
+ <classpath>
+ <pathelement location="${dist}" />
+ <pathelement location="${dist}/junit.jar" />
+ </classpath>
+ </java>
+ </target>
+
+ <target name="zip">
+ <!-- !!! hard code names, variable substitution doesn't work !!! -->
+ <zip
+ zipfile="junit3.6.zip"
+ basedir="."
+ includes="junit3.6/**"
+ />
+ </target>
+
+ <target name="awtui" depends="dist">
+ <java classname="junit.awtui.TestRunner" fork="yes">
+ <arg value="junit.samples.AllTests" />
+ <classpath>
+ <pathelement location="${dist}" />
+ <pathelement location="${dist}/junit.jar" />
+ </classpath>
+ </java>
+ </target>
+
+ <target name="swingui" depends="dist">
+ <java classname="junit.swingui.TestRunner" fork="yes">
+ <arg value="junit.samples.AllTests" />
+ <classpath>
+ <pathelement location="${dist}" />
+ <pathelement location="${dist}/junit.jar" />
+ </classpath>
+ </java>
+ </target>
+</project>
diff --git a/dev-java/junit/junit-3.7-r2.ebuild b/dev-java/junit/junit-3.7-r2.ebuild
new file mode 100644
index 000000000000..8fad353a02e7
--- /dev/null
+++ b/dev-java/junit/junit-3.7-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.7-r2.ebuild,v 1.1 2003/03/14 05:32:00 absinthe Exp $
+
+NP="junit3.7"
+S=${WORKDIR}/${NP}
+DESCRIPTION="simple framework to write repeatable tests"
+SRC_URI="http://download.sourceforge.net/junit/${NP}.zip"
+HOMEPAGE="http://www.junit.org/"
+
+LICENSE="CPL-0.5"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jdk-1.3"
+
+src_unpack() {
+ unpack ${NP}.zip
+ cd ${S}
+ rm junit.jar
+ cp -a ${FILESDIR}/${PN}-${PV}-build.xml ${S}/build.xml
+ unzip src.jar
+ rm src.jar
+}
+
+src_compile() {
+ ant || die
+}
+
+src_install() {
+ dojar ${PN}${PV}/junit.jar ${PN}${PV}/src.jar ${PN}${PV}/junit/tests/test.jar
+ dodir /usr/share/ant/lib
+ dosym /usr/share/junit/lib/junit.jar /usr/share/ant/lib/
+ dohtml -r README.html doc javadoc
+}