summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-11 21:28:28 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-11 21:28:28 +0000
commit3d526aac551c4f7d453354da3a803dd0f40f4ba9 (patch)
treef10d9bea4254da1e4656e918a3b028fd741df682 /dev-java/nanoxml/nanoxml-2.2.1.ebuild
parentsync IUSE (+junit) (diff)
downloadhistorical-3d526aac551c4f7d453354da3a803dd0f40f4ba9.tar.gz
historical-3d526aac551c4f7d453354da3a803dd0f40f4ba9.tar.bz2
historical-3d526aac551c4f7d453354da3a803dd0f40f4ba9.zip
version bump
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/nanoxml/nanoxml-2.2.1.ebuild')
-rw-r--r--dev-java/nanoxml/nanoxml-2.2.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-java/nanoxml/nanoxml-2.2.1.ebuild b/dev-java/nanoxml/nanoxml-2.2.1.ebuild
index 2782b06f06bd..6c9c54a8cebb 100644
--- a/dev-java/nanoxml/nanoxml-2.2.1.ebuild
+++ b/dev-java/nanoxml/nanoxml-2.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/nanoxml/nanoxml-2.2.1.ebuild,v 1.4 2004/10/22 09:42:59 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nanoxml/nanoxml-2.2.1.ebuild,v 1.5 2005/07/11 21:28:28 axxo Exp $
inherit java-pkg
@@ -11,11 +11,12 @@ MY_P=NanoXML-${PV}
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="doc"
-DEPEND="virtual/jdk
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}"
+RDEPEND=">=virtual/jre-1.3
dev-java/sax"
-RDEPEND="virtual/jre"
S=${WORKDIR}/${MY_P}
@@ -24,7 +25,7 @@ src_unpack() {
cd ${S}/ThirdParty/SAX
java-pkg_jar-from sax
cd ${S}
- sed -e "s:/tmp/:${T}:" -i build.sh
+ sed -e "s:/tmp/:${T}:g" -i build.sh || die "failed to sed"
}
src_compile() {