summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-03-18 15:01:32 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-03-18 15:01:32 +0000
commitee7a06deb50c4fc4a0a9b2b8ecb4a51b1e04fdcc (patch)
tree13e3177a906571dd577e0205378de5939faf41cd /dev-java/sax/sax-2.2.1-r2.ebuild
parentFix mask for net-p2p/amule, bug 171341 (diff)
downloadhistorical-ee7a06deb50c4fc4a0a9b2b8ecb4a51b1e04fdcc.tar.gz
historical-ee7a06deb50c4fc4a0a9b2b8ecb4a51b1e04fdcc.tar.bz2
historical-ee7a06deb50c4fc4a0a9b2b8ecb4a51b1e04fdcc.zip
Revision bump to fix some Java QA issues.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'dev-java/sax/sax-2.2.1-r2.ebuild')
-rw-r--r--dev-java/sax/sax-2.2.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/sax/sax-2.2.1-r2.ebuild b/dev-java/sax/sax-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..b37855451c03
--- /dev/null
+++ b/dev-java/sax/sax-2.2.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sax/sax-2.2.1-r2.ebuild,v 1.1 2007/03/18 15:01:32 nelchael Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="SAX is the Simple API for XML, originally a Java-only API. SAX was the first widely adopted API for XML in Java."
+
+HOMEPAGE="http://sax.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sax/sax2r3.zip"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/sax2r3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf classes *.jar
+}
+
+src_install() {
+ java-pkg_newjar sax2.jar
+ dodoc ChangeLog CHANGES README || die
+
+ use doc && java-pkg_dojavadoc docs/javadoc
+ use source && java-pkg_dosrc ${S}/src/*
+}