summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2003-08-26 21:43:35 +0000
committerHanno Boeck <hanno@gentoo.org>2003-08-26 21:43:35 +0000
commit3c768c28ce4d85663c04d5a165f0b7114707952c (patch)
tree5d4a5da0f0cf031470fd3b7c0b6b8fa9d56475a4 /dev-lang/fpc/fpc-1.0.10.ebuild
parentfree pascal ebuild (diff)
downloadhistorical-3c768c28ce4d85663c04d5a165f0b7114707952c.tar.gz
historical-3c768c28ce4d85663c04d5a165f0b7114707952c.tar.bz2
historical-3c768c28ce4d85663c04d5a165f0b7114707952c.zip
free pascal ebuild
Diffstat (limited to 'dev-lang/fpc/fpc-1.0.10.ebuild')
-rw-r--r--dev-lang/fpc/fpc-1.0.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lang/fpc/fpc-1.0.10.ebuild b/dev-lang/fpc/fpc-1.0.10.ebuild
new file mode 100644
index 000000000000..8bad8fac4a27
--- /dev/null
+++ b/dev-lang/fpc/fpc-1.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-1.0.10.ebuild,v 1.1 2003/08/26 21:43:29 hanno Exp $
+
+DESCRIPTION="The Free Pascal compiler"
+HOMEPAGE="http://www.freepascal.org/"
+SRC_URI="ftp://ftp.freepascal.org/pub/fpc/dist/Linux/rpm/${P}-0.i386.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+DEPEND="virtual/glibc"
+S=${WORKDIR}
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${P}-0.i386.rpm
+}
+
+src_compile() {
+ einfo Nothing to compile
+}
+
+src_install() {
+ cd ${D}
+ tar -xzf ${WORKDIR}/${P}-0.i386.tar.gz
+ chmod -R 755 usr/lib/* usr/share/*
+}