summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-10-07 00:27:28 +0000
committerKeri Harris <keri@gentoo.org>2006-10-07 00:27:28 +0000
commit1674e132c30f3ea6aeaecb3c8e0c860bf224b13c (patch)
treecb8163eb70d2930555f781aeecb102c66a5d94da /dev-lang/mercury/mercury-0.12.2-r3.ebuild
parentVersion bump (diff)
downloadhistorical-1674e132c30f3ea6aeaecb3c8e0c860bf224b13c.tar.gz
historical-1674e132c30f3ea6aeaecb3c8e0c860bf224b13c.tar.bz2
historical-1674e132c30f3ea6aeaecb3c8e0c860bf224b13c.zip
Do not pre-strip binaries.
Package-Manager: portage-2.1.2_pre2-r5
Diffstat (limited to 'dev-lang/mercury/mercury-0.12.2-r3.ebuild')
-rw-r--r--dev-lang/mercury/mercury-0.12.2-r3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-lang/mercury/mercury-0.12.2-r3.ebuild b/dev-lang/mercury/mercury-0.12.2-r3.ebuild
index 5a1f95b522f3..640f8ebc2974 100644
--- a/dev-lang/mercury/mercury-0.12.2-r3.ebuild
+++ b/dev-lang/mercury/mercury-0.12.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r3.ebuild,v 1.8 2006/10/05 17:40:19 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r3.ebuild,v 1.9 2006/10/07 00:27:28 keri Exp $
inherit eutils
@@ -58,7 +58,9 @@ src_compile() {
${myconf} \
BOOTSTRAP_STAGE="1" \
|| die "econf stage 1 failed"
- emake || die "emake stage 1 failed"
+ emake \
+ EXTRA_MLFLAGS=--no-strip \
+ || die "emake stage 1 failed"
einfo "Performing stage 2 bootstrap"
cp "${S}"/compiler/mercury_compile "${S}"/mercury_compile
@@ -71,6 +73,7 @@ src_compile() {
depend || die "emake stage 2 depend failed"
emake \
MERCURY_COMPILER="${S}"/mercury_compile \
+ EXTRA_MLFLAGS=--no-strip \
|| die "emake stage 2 failed"
einfo "Compiling libgrades"