summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-07-12 18:06:22 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-07-12 18:06:22 +0000
commit98ee3c883d40750430e75bc2d2c8462b496c604d (patch)
tree2f275f76e95bce16ebf37576404fcb8d6b8eb1a1 /dev-lang/tcl
parentalpha/x86 stable wrt #185012 (diff)
downloadhistorical-98ee3c883d40750430e75bc2d2c8462b496c604d.tar.gz
historical-98ee3c883d40750430e75bc2d2c8462b496c604d.tar.bz2
historical-98ee3c883d40750430e75bc2d2c8462b496c604d.zip
Fixed library filenames issue, bug #149037.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog7
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.14-r13
-rw-r--r--dev-lang/tcl/tcl-8.4.14-r1.ebuild122
3 files changed, 131 insertions, 1 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 3eb856c3a730..abc72593aa94 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.80 2007/06/24 23:36:14 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.81 2007/07/12 18:06:14 matsuu Exp $
+
+*tcl-8.4.14-r1 (12 Jul 2007)
+
+ 12 Jul 2007; MATSUU Takuto <matsuu@gentoo.org> +tcl-8.4.14-r1.ebuild:
+ Fixed library filenames issue, bug #149037.
24 Jun 2007; Piotr Jaroszyński <peper@gentoo.org> tcl-8.4.9.ebuild,
tcl-8.4.14.ebuild:
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.14-r1 b/dev-lang/tcl/files/digest-tcl-8.4.14-r1
new file mode 100644
index 000000000000..dbdb813bb271
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.14-r1
@@ -0,0 +1,3 @@
+MD5 51c6bf74d3ffdb0bd866ecdac6ff6460 tcl8.4.14-src.tar.gz 3544609
+RMD160 392a4f4617ee77cfdae10b24e9ccbe84afed0a40 tcl8.4.14-src.tar.gz 3544609
+SHA256 2746e3c568a5837cfb7a83359ab34401886ad621965ab4571333859807ab6143 tcl8.4.14-src.tar.gz 3544609
diff --git a/dev-lang/tcl/tcl-8.4.14-r1.ebuild b/dev-lang/tcl/tcl-8.4.14-r1.ebuild
new file mode 100644
index 000000000000..6c0f6d6650ee
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.14-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.14-r1.ebuild,v 1.1 2007/07/12 18:06:14 matsuu Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Tool Command Language"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug threads"
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_setup() {
+ if use threads ; then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
+
+ # Bug 125971
+ epatch "${FILESDIR}"/${PN}-8.3.5-tclm4-soname.patch
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tcl-configure-LANG.patch
+ done
+
+ cd "${S}"/unix
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ local local_config_use=""
+
+ if use threads ; then
+ local_config_use="--enable-threads"
+ fi
+
+ cd "${S}"/unix
+ econf \
+ $(use_enable threads) \
+ $(use_enable debug symbols) || die
+ emake || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd "${S}"/unix
+ S= make DESTDIR="${D}" install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+ sed -i \
+ -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L$/usr/${mylibdir}," \
+ -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='/usr/${mylibdir}/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/${mylibdir}," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='/usr/${mylibdir}," \
+ -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
+ -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
+ -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
+ "${D}"/usr/${mylibdir}/tclConfig.sh || die
+
+ # install private headers
+ insinto /usr/${mylibdir}/tcl${v1}/include/unix
+ doins "${S}"/unix/*.h || die
+ insinto /usr/${mylibdir}/tcl${v1}/include/generic
+ doins "${S}"/generic/*.h || die
+ rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
+ rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
+ rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ if use debug ; then
+ dosym libtcl${v1}g.so /usr/${mylibdir}/libtcl${v1}.so
+ dosym libtclstub${v1}g.a /usr/${mylibdir}/libtclstub${v1}.a
+ fi
+ dosym libtcl${v1}.so /usr/${mylibdir}/libtcl.so
+ dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
+
+ dosym tclsh${v1} /usr/bin/tclsh
+
+ cd "${S}"
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild"
+ ewarn "in package app-portage/gentoolkit."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+}