summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-04 18:17:42 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-04 18:17:42 +0000
commita3b0df9a50259b3eb10fdc9896bdcc7879805e1c (patch)
tree985c0c2d1f0c9e07a53bee6919436d410ada7f45 /dev-lang/tcl
parenttouchups and removal of ugly code (diff)
downloadhistorical-a3b0df9a50259b3eb10fdc9896bdcc7879805e1c.tar.gz
historical-a3b0df9a50259b3eb10fdc9896bdcc7879805e1c.tar.bz2
historical-a3b0df9a50259b3eb10fdc9896bdcc7879805e1c.zip
Version bumped.
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog7
-rw-r--r--dev-lang/tcl/Manifest8
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.61
-rw-r--r--dev-lang/tcl/tcl-8.4.6.ebuild77
4 files changed, 89 insertions, 4 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 53dba698fb35..29a05975b376 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.25 2004/03/03 02:04:01 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.26 2004/03/04 18:17:42 mholzer Exp $
+
+*tcl-8.4.6 (04 Mar 2004)
+
+ 04 Mar 2004; Martin Holzer <mholzer@gentoo.org> tcl-8.4.6.ebuild:
+ Version bumped.
02 Mar 2004; Brian Jackson <iggy@gentoo.org> tcl-8.4.5.ebuild:
added s390 to keywords
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index 55e98c05279e..0bf2b0cb459e 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,10 +1,12 @@
+MD5 c03d7979ef7a8ff42a5947e3fdf132bc ChangeLog 3819
MD5 943d8eb3f9a0464d970139236a8f21a8 tcl-8.3.3-r1.ebuild 2066
-MD5 f16bfa6c34987b5bdc71be39b262ae9e tcl-8.4.3.ebuild 2671
MD5 20b56614e1c23dac56f07626f53ba649 tcl-8.3.3-r3.ebuild 2170
-MD5 72b87b80641626ae3f14912a328ef6a8 tcl-8.4.5.ebuild 2609
MD5 8457e085bd81e84fd52000d8df1f8167 tcl-8.3.4.ebuild 2180
+MD5 f16bfa6c34987b5bdc71be39b262ae9e tcl-8.4.3.ebuild 2671
MD5 d5cac72c15df6cd543b5f530a648edf6 tcl-8.4.4.ebuild 2626
-MD5 66c0317a10b9a5a8a94b3cbc10da7105 ChangeLog 3703
+MD5 72b87b80641626ae3f14912a328ef6a8 tcl-8.4.5.ebuild 2609
+MD5 0cb68aa8b0af3a35b9793165b10e3c3f tcl-8.4.6.ebuild 2626
+MD5 cb07b4bc1984a971b376e1da5e478fdc files/digest-tcl-8.4.6 65
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r1 61
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r3 61
MD5 d7d05b473cf799a637baaa9f321b070f files/digest-tcl-8.3.4 121
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.6 b/dev-lang/tcl/files/digest-tcl-8.4.6
new file mode 100644
index 000000000000..61274224905f
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.6
@@ -0,0 +1 @@
+MD5 9009a92dc648775fb8a9b0789b995756 tcl8.4.6-src.tar.gz 3448711
diff --git a/dev-lang/tcl/tcl-8.4.6.ebuild b/dev-lang/tcl/tcl-8.4.6.ebuild
new file mode 100644
index 000000000000..6958c65c047d
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.6.ebuild,v 1.1 2004/03/04 18:17:42 mholzer Exp $
+
+DESCRIPTION="Tool Command Language"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ppc64 ~ia64 ~s390"
+RESTRICT="nomirror"
+
+DEPEND="virtual/glibc
+ >=app-portage/gentoolkit-0.1.22"
+RDEPEND="virtual/glibc"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_compile() {
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+}