summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-18 19:39:28 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-18 19:39:28 +0000
commit17219e7d730b092c98f8f696b5bbf41ce38af0c0 (patch)
tree61bf66789d9ef2b760cf8883c0bca3ecdbf25506 /dev-lang
parentmanifest recommit (diff)
downloadhistorical-17219e7d730b092c98f8f696b5bbf41ce38af0c0.tar.gz
historical-17219e7d730b092c98f8f696b5bbf41ce38af0c0.tar.bz2
historical-17219e7d730b092c98f8f696b5bbf41ce38af0c0.zip
Add handling of CFLAGS, resolves bug #51593
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/Manifest10
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild12
-rw-r--r--dev-lang/ocaml/ocaml-3.08.ebuild12
4 files changed, 32 insertions, 8 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 1ffa965662f9..59f292e281a6 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.44 2004/08/16 23:33:49 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.45 2004/08/18 19:39:28 mattam Exp $
+
+ 18 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.07-r1.ebuild,
+ ocaml-3.08.ebuild:
+ Add handling of CFLAGS, use with care!
16 Aug 2004; Guy Martin <gmsoft@gentoo.org> ocaml-3.08.ebuild:
Yay, my port to hppa-linux is in the mainstream ! Marking stable !
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index e04e9c2474ed..a4569d129eaf 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,12 +1,12 @@
-MD5 7f0830751aebf93da5b65ca840cc8836 ChangeLog 7399
+MD5 b7ca52388a8e7a6b9d68670176d389cf ChangeLog 7535
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 a345c82ec2955b8bd3d3bbe3fadabe62 ocaml-3.06-r2.ebuild 1660
-MD5 f73836758126bfce1813d75995f8536e ocaml-3.07-r1.ebuild 2567
-MD5 ce734878f1ea3e423b47a16d674d54ff ocaml-3.08.ebuild 1867
+MD5 4428b19ad5871c85adbaa17ae3b5faaa ocaml-3.07-r1.ebuild 2878
+MD5 e18dd8c94164ddcb782c026b121c2c3f ocaml-3.08.ebuild 2177
+MD5 d996b9a852fbfcb0c2d9bddb4896add2 files/ocaml-rebuild.sh 1228
+MD5 77519cb4017543f060a963387b593299 files/digest-ocaml-3.08 65
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r2 63
MD5 c42de320103c2d3eb1aa4002e2e0716b files/digest-ocaml-3.07-r1 130
MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
MD5 45ff13419dd955aa86d021abbf325fc2 files/ocaml-3.07-hppa.patch 15730
-MD5 d996b9a852fbfcb0c2d9bddb4896add2 files/ocaml-rebuild.sh 1228
-MD5 77519cb4017543f060a963387b593299 files/digest-ocaml-3.08 65
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index f793d4298d09..e27fb047f0a6 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.22 2004/08/14 04:45:52 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.23 2004/08/18 19:39:28 mattam Exp $
inherit flag-o-matic eutils
@@ -18,6 +18,13 @@ IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
+pkg_setup() {
+ ewarn
+ ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn
+}
+
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -46,6 +53,9 @@ src_compile() {
-mandir /usr/share/man \
--with-pthread ${myconf} || die
+ sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+ sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+
make world || die
make opt || die
make opt.opt || die
diff --git a/dev-lang/ocaml/ocaml-3.08.ebuild b/dev-lang/ocaml/ocaml-3.08.ebuild
index c5106b245b76..3c7ed00ab13e 100644
--- a/dev-lang/ocaml/ocaml-3.08.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.3 2004/08/16 23:33:49 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.4 2004/08/18 19:39:28 mattam Exp $
inherit flag-o-matic eutils
@@ -19,6 +19,13 @@ DEPEND="virtual/libc
S="${WORKDIR}/${P}.0"
+pkg_setup() {
+ ewarn
+ ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn
+}
+
src_compile() {
filter-flags "-fstack-protector"
@@ -39,6 +46,9 @@ src_compile() {
-mandir /usr/share/man \
--with-pthread ${myconf} || die
+ sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+ sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+
make world || die
make opt || die
make opt.opt || die