summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-02-25 02:09:00 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-02-25 02:09:00 +0000
commite483e90a98fc50cf0e9e7dba7fdce66a7fbcda00 (patch)
tree115c0187f064b3f7bf2f51eda9bd342208e4a236 /dev-libs/boost
parentamd64 stable (diff)
downloadhistorical-e483e90a98fc50cf0e9e7dba7fdce66a7fbcda00.tar.gz
historical-e483e90a98fc50cf0e9e7dba7fdce66a7fbcda00.tar.bz2
historical-e483e90a98fc50cf0e9e7dba7fdce66a7fbcda00.zip
new version (finally) out
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/Manifest2
-rw-r--r--dev-libs/boost/boost-1.31.0.ebuild133
-rw-r--r--dev-libs/boost/files/digest-boost-1.31.01
3 files changed, 136 insertions, 0 deletions
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 1ac4624b91c2..12647663469d 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,3 +1,4 @@
+MD5 b6a65c59803e4589d9f8778ab5b6c1a5 boost-1.31.0.ebuild 3864
MD5 4537d46888da386ec78522e8def821c7 boost-1.29.0.ebuild 1437
MD5 513b268dfb4fcbe155360721bc2a2682 boost-1.31.0_alpha2-r1.ebuild 3854
MD5 8c005a1eb57abb8b207e804540b13e34 boost-1.31.0_alpha1.ebuild 3305
@@ -11,3 +12,4 @@ MD5 60837b07dcdf0907c66674b577ab6b9a files/digest-boost-1.31.0_alpha2 67
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
MD5 2b36d47323b021671d391600501685cc files/digest-boost-1.30.0 66
MD5 a09c431deb3a25504525921685cd0e57 files/digest-boost-1.30.2 66
+MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
diff --git a/dev-libs/boost/boost-1.31.0.ebuild b/dev-libs/boost/boost-1.31.0.ebuild
new file mode 100644
index 000000000000..6031b85ec972
--- /dev/null
+++ b/dev-libs/boost/boost-1.31.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0.ebuild,v 1.1 2004/02/25 02:09:00 george Exp $
+
+MyPV=${PV//./_}
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+#SRC_URI="http://easynews.dl.sourceforge.net/sourceforge/boost/boost-${PV}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MyPV}.tar.bz2"
+
+S=${WORKDIR}/${PN}_${MyPV}
+
+LICENSE="freedist"
+KEYWORDS="~x86 ~ppc ~amd64"
+SLOT="1"
+IUSE="icc"
+
+# This would be a good place for someone to figure out how to get
+# boost to build nicely with icc, as it's documented to be doable.
+
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1
+ icc? ( >=dev-lang/icc-7.1 )"
+
+src_compile() {
+ local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
+ local BOOST_TOOLSET
+ local arch
+
+ if [ "`use icc`" ] ; then
+ BOOST_TOOLSET="intel-linux"
+ else
+ BOOST_TOOLSET="gcc"
+ fi
+
+ # Build bjam, a jam variant, which is used instead of make
+ cd ${S}/tools/build/jam_src
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd ${S}
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if [ "`use icc`" ] ; then
+ ./tools/build/jam_src/bin.linux${arch}/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_LINUX_VERSION="70" || die "Failed to build boost libraries."
+ else
+ ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET}
+
+ einfo "Don't worry if there are a few (probably 6) failures above."
+ einfo "Some targets merely need to be combined. Here goes:"
+
+ ./tools/build/jam_src/bin.linux${arch}/bjam \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} || die "Failed to build boost libraries."
+ fi
+}
+
+src_install () {
+ # Unfortunately boost doesn't provide a standard way to
+ # install itself. So it's done "manually" here.
+
+ # install libraries
+ find bin/boost/libs -type f -name \*.a -exec dolib.a {} \;
+ find bin/boost/libs -type f -name "*.so*" -exec dolib.so {} \;
+ #find bin/boost/libs -type l -name "*.so*" -exec dosym {} /usr/lib \;
+
+ # install source/header files
+
+ find boost -type f \
+ -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
+ dohtml -A pdf -r more
+ dohtml -r people
+ dohtml -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${P}/html/\{\} \;
+
+ #create symlinks for the libs
+ LocalPV="1_31"
+ cd ${D}/usr/lib
+ for fn in *.so*; do
+ baseName=${fn%%so*}
+ #.so symlinks
+ ln -s $fn ${baseName}so
+ #remove version from .so's and .a's
+ ln -s ${baseName}so ${baseName/-$LocalPV/}so
+ ln -s ${baseName}a ${baseName/-$LocalPV/}a
+ done
+ #and finally set "default" links to -gcc-mt versions
+ for fn in `ls -1 *.so|cut -d- -f1|sort|uniq`; do
+ ln -s $fn-gcc-mt.so $fn.so
+ ln -s $fn-gcc-mt.a $fn.a
+ done
+}
diff --git a/dev-libs/boost/files/digest-boost-1.31.0 b/dev-libs/boost/files/digest-boost-1.31.0
new file mode 100644
index 000000000000..bd71acf23d9a
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.31.0
@@ -0,0 +1 @@
+MD5 8cc183538eaa5cfc53d88d0e94bd2fd4 boost_1_31_0.tar.bz2 6979482