summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-20 21:19:56 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-20 21:19:56 +0000
commitec42706c545680eb8554f51ae663f92d08dff096 (patch)
treedf0a252ee5da4b1653137a069a0e0f788de78f11 /dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
parentuse newer gen_usr_ldscript #144529 (diff)
downloadhistorical-ec42706c545680eb8554f51ae663f92d08dff096.tar.gz
historical-ec42706c545680eb8554f51ae663f92d08dff096.tar.bz2
historical-ec42706c545680eb8554f51ae663f92d08dff096.zip
initial import thanks to sourcemage, http://bugs.sourcemage.org/12907
Package-Manager: portage-2.1.1_pre5-r2
Diffstat (limited to 'dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild')
-rw-r--r--dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
new file mode 100644
index 000000000000..995d57fd11d7
--- /dev/null
+++ b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild,v 1.1 2006/08/20 21:19:56 genstef Exp $
+
+inherit qt3
+
+DESCRIPTION="D-BUS Qt3 bindings compatible with old application API and new dbus"
+HOMEPAGE="http://freedesktop.org/wiki/Software_2fdbus"
+SRC_URI="http://www.kolumbus.fi/juuso.alasuutari/${P/-old}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/dbus-core"
+DEPEND="sys-apps/dbus-core
+ =x11-libs/qt-3*"
+S=${WORKDIR}/${P/-old}
+
+src_compile() {
+ econf \
+ --enable-qt3 \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}