summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-02-02 22:13:21 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-02-02 22:13:21 +0000
commit9f657e9b776c4e27a01514f2023d0e266a8e5a03 (patch)
treedb0fa8b261069f74e15fcea7cb8831cd10a941e2 /dev-libs/libsigc++/libsigc++-2.0.17.ebuild
parentReadded tetex-1.0.7-r13 because stuff depends on it (which they shouldn't). (diff)
downloadhistorical-9f657e9b776c4e27a01514f2023d0e266a8e5a03.tar.gz
historical-9f657e9b776c4e27a01514f2023d0e266a8e5a03.tar.bz2
historical-9f657e9b776c4e27a01514f2023d0e266a8e5a03.zip
version bump
Package-Manager: portage-2.0.54
Diffstat (limited to 'dev-libs/libsigc++/libsigc++-2.0.17.ebuild')
-rw-r--r--dev-libs/libsigc++/libsigc++-2.0.17.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/libsigc++/libsigc++-2.0.17.ebuild b/dev-libs/libsigc++/libsigc++-2.0.17.ebuild
new file mode 100644
index 000000000000..e54e3b55f24f
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-2.0.17.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.0.17.ebuild,v 1.1 2006/02/02 22:13:21 allanonjl Exp $
+
+inherit eutils gnome.org flag-o-matic
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="debug doc test"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # don't waste time building examples/docs
+ sed -i 's|^\(SUBDIRS =.*\)docs examples\(.*\)$|\1\2|' Makefile.in || \
+ die "sed docs/examples failed"
+
+ # don't waste time building tests unless USE=test
+ if ! use test ; then
+ sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' Makefile.in || \
+ die "sed tests failed"
+ fi
+
+ # fix image paths
+ if use doc ; then
+ sed -i 's|../../images/||g' docs/reference/html/*.html || \
+ die "sed failed"
+ fi
+}
+
+src_compile() {
+ filter-flags -fno-exceptions
+
+ if use ppc-macos && [[ -e /usr/lib/lib/libgcc_s.1.dylib ]] ; then
+ append-ldflags -lgcc_s
+ fi
+
+ local myconf
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
+
+ econf ${myconf} || die "econf failed."
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+ rm -fr ${D}/usr/share
+ dodoc AUTHORS ChangeLog README NEWS TODO
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/*
+ cp -R examples ${D}/usr/share/doc/${PF}/
+ fi
+}
+
+pkg_postinst() {
+ ewarn "To allow parallel installation of sig++-1.0, sig++-1.2, and sig++2.0"
+ ewarn "the header files are now installed in a version specific"
+ ewarn "subdirectory. Be sure to unmerge any libsig++ versions"
+ ewarn "< 1.0.4 that you may have previously installed."
+}