summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-30 22:42:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-30 22:42:53 +0000
commitcb8a48c7b207527801ed8482c649a78048798250 (patch)
tree9406c3ae8a7819da3f2d706a21ca61b3f5012dc1 /dev-libs/libx86emu/libx86emu-1.1.ebuild
parentNew package, fixes bug 310559 (diff)
downloadhistorical-cb8a48c7b207527801ed8482c649a78048798250.tar.gz
historical-cb8a48c7b207527801ed8482c649a78048798250.tar.bz2
historical-cb8a48c7b207527801ed8482c649a78048798250.zip
Initial commit. Used by hwinfo >= 18.1.
Package-Manager: portage-2.2_rc88/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libx86emu/libx86emu-1.1.ebuild')
-rw-r--r--dev-libs/libx86emu/libx86emu-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libx86emu/libx86emu-1.1.ebuild b/dev-libs/libx86emu/libx86emu-1.1.ebuild
new file mode 100644
index 000000000000..27d79fb7dc37
--- /dev/null
+++ b/dev-libs/libx86emu/libx86emu-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libx86emu/libx86emu-1.1.ebuild,v 1.1 2010/09/30 22:42:53 ssuominen Exp $
+
+EAPI=2
+inherit multilib rpm toolchain-funcs
+
+DESCRIPTION="A library for emulating x86"
+HOMEPAGE="http://www.opensuse.org/"
+SRC_URI="http://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-9.8.src.rpm"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e 's:$(CC) -shared:& $(LDFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -fPIC -Wall" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die
+ dodoc Changelog README
+}