summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-16 20:28:47 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-16 20:28:47 +0000
commit922b39d3bb8696f6e05e14e8d67216e658f1ce63 (patch)
tree5aaf21117aa41c6efcdc487118c782e7adfec796 /dev-libs/pilot-link
parenttypo fix again (einfo block, text scrolled too far) (diff)
downloadhistorical-922b39d3bb8696f6e05e14e8d67216e658f1ce63.tar.gz
historical-922b39d3bb8696f6e05e14e8d67216e658f1ce63.tar.bz2
historical-922b39d3bb8696f6e05e14e8d67216e658f1ce63.zip
version bump
Diffstat (limited to 'dev-libs/pilot-link')
-rw-r--r--dev-libs/pilot-link/ChangeLog10
-rw-r--r--dev-libs/pilot-link/files/digest-pilot-link-0.11.71
-rw-r--r--dev-libs/pilot-link/pilot-link-0.11.7.ebuild72
3 files changed, 80 insertions, 3 deletions
diff --git a/dev-libs/pilot-link/ChangeLog b/dev-libs/pilot-link/ChangeLog
index c70149cb408b..d6a6c2d6530c 100644
--- a/dev-libs/pilot-link/ChangeLog
+++ b/dev-libs/pilot-link/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-libs/pilot-link
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/ChangeLog,v 1.13 2002/12/13 10:56:29 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/ChangeLog,v 1.14 2003/01/16 20:28:47 vapier Exp $
+
+*pilot-link-0.11.7 (16 Jan 2003)
+
+ 16 Jan 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + remove all fixes since upstream added them for this
+ release (except for perl ... but its supposed to be in for 0.11.8).
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*pilot-link-0.11.5-r1 (17 Nov 2002)
17 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
diff --git a/dev-libs/pilot-link/files/digest-pilot-link-0.11.7 b/dev-libs/pilot-link/files/digest-pilot-link-0.11.7
new file mode 100644
index 000000000000..00219f911363
--- /dev/null
+++ b/dev-libs/pilot-link/files/digest-pilot-link-0.11.7
@@ -0,0 +1 @@
+MD5 7d06c1101707125b1e385dbd3cd7ce91 pilot-link-0.11.7.tar.bz2 669470
diff --git a/dev-libs/pilot-link/pilot-link-0.11.7.ebuild b/dev-libs/pilot-link/pilot-link-0.11.7.ebuild
new file mode 100644
index 000000000000..d9d40f851821
--- /dev/null
+++ b/dev-libs/pilot-link/pilot-link-0.11.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/pilot-link-0.11.7.ebuild,v 1.1 2003/01/16 20:28:47 vapier Exp $
+
+inherit perl-module
+
+DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
+HOMEPAGE="http://www.pilot-link.org/"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="perl java tcltk python pic png readline"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses
+ perl? ( sys-devel/perl )
+ java? ( virtual/jre )
+ tcltk? ( dev-lang/tcl dev-tcltk/itcl dev-lang/tk )
+ python? ( dev-lang/python )
+ png? ( media-libs/libpng )
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+ local myconf="--with-gnu-ld --includedir=/usr/include/libpisock"
+
+ use pic && myconf="${myconf} --with-pic"
+
+ use java \
+ && myconf="${myconf} --with-java=yes" \
+ || myconf="${myconf} --with-java=no"
+
+ use perl \
+ && myconf="${myconf} --with-perl=yes" \
+ || myconf="${myconf} --with-perl=no"
+
+ use python \
+ && myconf="${myconf} --with-python=yes" \
+ || myconf="${myconf} --with-python=no"
+
+ use tcltk \
+ && myconf="${myconf} --with-tcl=yes --with-itcl=yes --with-tk=yes" \
+ || myconf="${myconf} --with-tcl=no --with-itcl=no --with-tk=no"
+
+ use png && myconf="${myconf} --with-libpng=/usr"
+
+ use readline \
+ && myconf="${myconf} --with-readline=yes" \
+ || myconf="${myconf} --with-readline=no"
+
+ econf ${myconf} || die
+ # java fails w/emake
+ make || die
+
+ if [ `use perl` ] ; then
+ cd ${S}/bindings/Perl
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
+
+ if [ `use perl` ] ; then
+ cd ${S}/bindings/Perl
+ perl-module_src_install
+ fi
+}