summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-02-10 17:15:56 +0000
committerMatt Turner <mattst88@gentoo.org>2012-02-10 17:15:56 +0000
commit72f24cd164d85b5c18743bf6590d97dc766af85d (patch)
tree422347cd9aa2a08a1913df5f1d755103d53e9c61 /dev-libs/wayland
parentAdd leechcraft-gacts plugin, by 0xd34df00d (diff)
downloadhistorical-72f24cd164d85b5c18743bf6590d97dc766af85d.tar.gz
historical-72f24cd164d85b5c18743bf6590d97dc766af85d.tar.bz2
historical-72f24cd164d85b5c18743bf6590d97dc766af85d.zip
First version of wayland in portage.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/ChangeLog10
-rw-r--r--dev-libs/wayland/metadata.xml5
-rw-r--r--dev-libs/wayland/wayland-0.85.0.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
new file mode 100644
index 000000000000..6e4f148300da
--- /dev/null
+++ b/dev-libs/wayland/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/wayland
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.1 2012/02/10 17:15:56 mattst88 Exp $
+
+*wayland-0.85.0 (10 Feb 2012)
+
+ 10 Feb 2012; Matt Turner <mattst88@gentoo.org> +wayland-0.85.0.ebuild,
+ +metadata.xml:
+ First version of wayland in portage.
+
diff --git a/dev-libs/wayland/metadata.xml b/dev-libs/wayland/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/dev-libs/wayland/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/dev-libs/wayland/wayland-0.85.0.ebuild b/dev-libs/wayland/wayland-0.85.0.ebuild
new file mode 100644
index 000000000000..0bcce7bb321d
--- /dev/null
+++ b/dev-libs/wayland/wayland-0.85.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-0.85.0.ebuild,v 1.1 2012/02/10 17:15:56 mattst88 Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libffi"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if tc-is-cross-compiler ; then
+ econf $(use_enable static-libs static) --disable-scanner
+ else
+ econf $(use_enable static-libs static)
+ fi
+}