summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-02 22:30:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-02 22:30:46 +0000
commitbef49caaebb81ca1b3b914d66448ebb083992c82 (patch)
tree8aaf7c4a2c2423325348a100dfd6f6bc0eaf23cf /dev-libs
parentMarked ~alpha and ~ia64 (diff)
downloadhistorical-bef49caaebb81ca1b3b914d66448ebb083992c82.tar.gz
historical-bef49caaebb81ca1b3b914d66448ebb083992c82.tar.bz2
historical-bef49caaebb81ca1b3b914d66448ebb083992c82.zip
Delete older ebuilds.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/files/icu-4.0.1-TestDisplayNamesMeta.patch177
-rw-r--r--dev-libs/icu/files/icu-4.0.1-fix_parallel_building.patch10
-rw-r--r--dev-libs/icu/files/icu-4.2.1-fix_misoptimizations.patch25
-rw-r--r--dev-libs/icu/files/icu-4.2.1-pkgdata-build_data_without_assembly.patch16
-rw-r--r--dev-libs/icu/files/icu-4.2.1-pkgdata.patch188
-rw-r--r--dev-libs/icu/icu-4.0.1.ebuild83
-rw-r--r--dev-libs/icu/icu-4.2.1.ebuild82
7 files changed, 0 insertions, 581 deletions
diff --git a/dev-libs/icu/files/icu-4.0.1-TestDisplayNamesMeta.patch b/dev-libs/icu/files/icu-4.0.1-TestDisplayNamesMeta.patch
deleted file mode 100644
index be1f7ec59f25..000000000000
--- a/dev-libs/icu/files/icu-4.0.1-TestDisplayNamesMeta.patch
+++ /dev/null
@@ -1,177 +0,0 @@
-https://bugs.icu-project.org/trac/ticket/6814
-https://bugs.icu-project.org/trac/changeset/25681
-
---- i18n/olsontz.cpp
-+++ i18n/olsontz.cpp
-@@ -1,6 +1,6 @@
- /*
- **********************************************************************
--* Copyright (c) 2003-2008, International Business Machines
-+* Copyright (c) 2003-2009, International Business Machines
- * Corporation and others. All Rights Reserved.
- **********************************************************************
- * Author: Alan Liu
-@@ -526,8 +526,8 @@
- if (transitionTimes[i] >= limit) {
- break;
- }
-- if (transitionTimes[i] >= start &&
-- dstOffset(typeData[i]) != 0) {
-+ if ((transitionTimes[i] >= start && dstOffset(typeData[i]) != 0)
-+ || (transitionTimes[i] > start && i > 0 && dstOffset(typeData[i - 1]) != 0)) {
- return TRUE;
- }
- }
---- i18n/timezone.cpp
-+++ i18n/timezone.cpp
-@@ -1,6 +1,6 @@
- /*
- *******************************************************************************
--* Copyright (C) 1997-2008, International Business Machines Corporation and *
-+* Copyright (C) 1997-2009, International Business Machines Corporation and *
- * others. All Rights Reserved. *
- *******************************************************************************
- *
-@@ -1240,6 +1240,8 @@
- }
- } else {
- // The display name for standard time was requested, but currently in DST
-+ // or display name for daylight saving time was requested, but this zone no longer
-+ // observes DST.
- tz = new SimpleTimeZone(rawOffset, tempID);
- if (U_FAILURE(status) || tz == NULL) {
- if (U_SUCCESS(status)) {
---- test/intltest/tztest.cpp
-+++ test/intltest/tztest.cpp
-@@ -34,6 +34,11 @@
- // class TimeZoneTest
- // *****************************************************************************
-
-+// TODO: We should probably read following data at runtime, so we can update
-+// the these values every release with necessary data changes.
-+const int32_t TimeZoneTest::REFERENCE_YEAR = 2009;
-+const char * TimeZoneTest::REFERENCE_DATA_VERSION = "2009d";
-+
- void TimeZoneTest::runIndexedTest( int32_t index, UBool exec, const char* &name, char* /*par*/ )
- {
- if (exec) logln("TestSuite TestTimeZone");
-@@ -579,18 +584,13 @@
- */
- void TimeZoneTest::TestShortZoneIDs()
- {
-- // TODO: This test case is tzdata sensitive.
-- // We should actually put the data version in this test code
-- // at build time. For now, we just hardcode the version string
-- // and display warning instead of error if non-reference tzdata
-- // version is used.
-- const char *REFERENCE_DATA_VERSION = "2008i";
--
- UErrorCode status = U_ZERO_ERROR;
-+
-+ // This test case is tzdata version sensitive.
- UBool isNonReferenceTzdataVersion = FALSE;
- const char *tzdataVer = TimeZone::getTZDataVersion(status);
- if (failure(status, "getTZDataVersion")) return;
-- if (uprv_strcmp(tzdataVer, REFERENCE_DATA_VERSION) != 0) {
-+ if (uprv_strcmp(tzdataVer, TimeZoneTest::REFERENCE_DATA_VERSION) != 0) {
- // Note: We want to display a warning message here if
- // REFERENCE_DATA_VERSION is out of date - so we
- // do not forget to update the value before GA.
-@@ -603,11 +603,11 @@
- // Note: useDaylightTime returns true if DST is observed
- // in the time zone in the current calendar year. The test
- // data is valid for the date after the reference year below.
-- // If system clock is before the year, some test cases may fail.
-- const int32_t REFERENCE_YEAR = 2009;
-+ // If system clock is before the year, some test cases may
-+ // fail.
- GregorianCalendar cal(*TimeZone::getGMT(), status);
- if (failure(status, "GregorianCalendar")) return;
-- cal.set(REFERENCE_YEAR, UCAL_JANUARY, 2); // day 2 in GMT
-+ cal.set(TimeZoneTest::REFERENCE_YEAR, UCAL_JANUARY, 2); // day 2 in GMT
-
- UBool isDateBeforeReferenceYear = ucal_getNow() < cal.getTime(status);
- if (failure(status, "Calendar::getTime")) return;
-@@ -1898,6 +1898,15 @@
- };
-
- void TimeZoneTest::TestDisplayNamesMeta() {
-+ UErrorCode status = U_ZERO_ERROR;
-+ GregorianCalendar cal(*TimeZone::getGMT(), status);
-+ if (failure(status, "GregorianCalendar")) return;
-+
-+ UBool isReferenceYear = TRUE;
-+ if (cal.get(UCAL_YEAR, status) != TimeZoneTest::REFERENCE_YEAR) {
-+ isReferenceYear = FALSE;
-+ }
-+
- UBool sawAnError = FALSE;
- for (int testNum = 0; zoneDisplayTestData[testNum].zoneName != NULL; testNum++) {
- Locale locale = Locale::createFromName(zoneDisplayTestData[testNum].localeName);
-@@ -1908,20 +1917,33 @@
- locale,
- displayName);
- if (displayName != zoneDisplayTestData[testNum].expectedDisplayName) {
-- sawAnError = TRUE;
- char name[100];
- UErrorCode status = U_ZERO_ERROR;
- displayName.extract(name, 100, NULL, status);
-- errln("Incorrect time zone display name. zone = \"%s\",\n"
-- " locale = \"%s\", style = %s, Summertime = %d\n"
-- " Expected \"%s\", "
-- " Got \"%s\"\n", zoneDisplayTestData[testNum].zoneName,
-- zoneDisplayTestData[testNum].localeName,
-- zoneDisplayTestData[testNum].style==TimeZone::SHORT ?
-- "SHORT" : "LONG",
-- zoneDisplayTestData[testNum].summerTime,
-- zoneDisplayTestData[testNum].expectedDisplayName,
-- name);
-+ if (isReferenceYear) {
-+ sawAnError = TRUE;
-+ errln("Incorrect time zone display name. zone = \"%s\",\n"
-+ " locale = \"%s\", style = %s, Summertime = %d\n"
-+ " Expected \"%s\", "
-+ " Got \"%s\"\n", zoneDisplayTestData[testNum].zoneName,
-+ zoneDisplayTestData[testNum].localeName,
-+ zoneDisplayTestData[testNum].style==TimeZone::SHORT ?
-+ "SHORT" : "LONG",
-+ zoneDisplayTestData[testNum].summerTime,
-+ zoneDisplayTestData[testNum].expectedDisplayName,
-+ name);
-+ } else {
-+ logln("Incorrect time zone display name. zone = \"%s\",\n"
-+ " locale = \"%s\", style = %s, Summertime = %d\n"
-+ " Expected \"%s\", "
-+ " Got \"%s\"\n", zoneDisplayTestData[testNum].zoneName,
-+ zoneDisplayTestData[testNum].localeName,
-+ zoneDisplayTestData[testNum].style==TimeZone::SHORT ?
-+ "SHORT" : "LONG",
-+ zoneDisplayTestData[testNum].summerTime,
-+ zoneDisplayTestData[testNum].expectedDisplayName,
-+ name);
-+ }
- }
- delete zone;
- }
---- test/intltest/tztest.h
-+++ test/intltest/tztest.h
-@@ -1,6 +1,6 @@
-
- /********************************************************************
-- * Copyright (c) 1997-2008, International Business Machines
-+ * Copyright (c) 1997-2009, International Business Machines
- * Corporation and others. All Rights Reserved.
- ********************************************************************/
-
-@@ -98,6 +98,11 @@
- // internal functions
- static UnicodeString& formatOffset(int32_t offset, UnicodeString& rv);
- static UnicodeString& formatTZID(int32_t offset, UnicodeString& rv);
-+
-+ // Some test case data is current date/tzdata version sensitive and producing errors
-+ // when year/rule are changed.
-+ static const int32_t REFERENCE_YEAR;
-+ static const char *REFERENCE_DATA_VERSION;
- };
-
- #endif /* #if !UCONFIG_NO_FORMATTING */
diff --git a/dev-libs/icu/files/icu-4.0.1-fix_parallel_building.patch b/dev-libs/icu/files/icu-4.0.1-fix_parallel_building.patch
deleted file mode 100644
index 0e09fd9eda39..000000000000
--- a/dev-libs/icu/files/icu-4.0.1-fix_parallel_building.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- data/Makefile.in
-+++ data/Makefile.in
-@@ -355,6 +355,7 @@
- endif
- endif
-
-+$(BUILD_DIRS): build-dir
-
- build-dir:
- @list='$(BUILD_DIRS)'; \
diff --git a/dev-libs/icu/files/icu-4.2.1-fix_misoptimizations.patch b/dev-libs/icu/files/icu-4.2.1-fix_misoptimizations.patch
deleted file mode 100644
index 10838240e74f..000000000000
--- a/dev-libs/icu/files/icu-4.2.1-fix_misoptimizations.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://bugs.icu-project.org/trac/ticket/7039
-
---- common/unicode/unistr.h
-+++ common/unicode/unistr.h
-@@ -4048,7 +4048,8 @@
-
- {
- // This dstSize value will be checked explicitly
-- return extract(start, _length, dst, dst!=0 ? 0xffffffff : 0, codepage);
-+ // Ticket #7039: Clip length to the maximum valid length to the end of addressable memory given the starting address
-+ return extract(start, _length, dst, dst!=0 ? ((dst >= (char*)((size_t)-1) - UINT32_MAX) ? (((char*)UINT32_MAX) - dst) : UINT32_MAX) : 0, codepage);
- }
-
- #endif
---- runConfigureICU
-+++ runConfigureICU
-@@ -318,7 +318,7 @@
- then
- case $CXX in
- g++|*/g++|*-g++-*|*/*-g++-*)
-- RELEASE_CXXFLAGS=-O
-+ RELEASE_CXXFLAGS=-O3
- ;;
- esac
- fi
diff --git a/dev-libs/icu/files/icu-4.2.1-pkgdata-build_data_without_assembly.patch b/dev-libs/icu/files/icu-4.2.1-pkgdata-build_data_without_assembly.patch
deleted file mode 100644
index 9edab456dd66..000000000000
--- a/dev-libs/icu/files/icu-4.2.1-pkgdata-build_data_without_assembly.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=275769
-
---- tools/pkgdata/pkgdata.cpp
-+++ tools/pkgdata/pkgdata.cpp
-@@ -77,6 +77,11 @@
- #define CAN_WRITE_OBJ_CODE
- #endif
-
-+#ifdef CAN_WRITE_OBJ_CODE
-+#undef CAN_WRITE_OBJ_CODE
-+#define BUILD_DATA_WITHOUT_ASSEMBLY
-+#endif
-+
- /*
- * When building the data library without assembly,
- * some platforms use a single c code file for all of
diff --git a/dev-libs/icu/files/icu-4.2.1-pkgdata.patch b/dev-libs/icu/files/icu-4.2.1-pkgdata.patch
deleted file mode 100644
index a66b0ff4617b..000000000000
--- a/dev-libs/icu/files/icu-4.2.1-pkgdata.patch
+++ /dev/null
@@ -1,188 +0,0 @@
-https://bugs.icu-project.org/trac/ticket/6969
-https://bugs.icu-project.org/trac/changeset/26210
-
---- tools/pkgdata/pkgdata.cpp
-+++ tools/pkgdata/pkgdata.cpp
-@@ -118,6 +118,7 @@
- static void createFileNames(const char *version_major, const char *version, const char *libName, const UBool reverseExt);
-
- static int32_t pkg_getOptionsFromICUConfig(UOption *option);
-+static int runCommand(const char* command);
-
- enum {
- NAME,
-@@ -461,6 +462,15 @@
- return result;
- }
-
-+static int runCommand(const char* command) {
-+ printf("pkgdata: %s\n", command);
-+ int result = system(command);
-+ if (result != 0) {
-+ printf("-- return status = %d\n", result);
-+ }
-+ return result;
-+}
-+
- #define LN_CMD "ln -s"
- #define RM_CMD "rm -f"
-
-@@ -724,7 +734,7 @@
- LN_CMD,
- libFileNames[LIB_FILE_VERSION],
- libFileNames[LIB_FILE_VERSION_MAJOR]);
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- return result;
- }
-@@ -737,7 +747,7 @@
- libFileNames[LIB_FILE_VERSION],
- libFileNames[LIB_FILE], pkgDataFlags[SO_EXT]);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
-
- return result;
- }
-@@ -753,7 +763,7 @@
- installDir, PKGDATA_FILE_SEP_STRING, libFileNames[LIB_FILE_VERSION]
- );
-
-- result = system(cmd);
-+ result = runCommand(cmd);
-
- if (result != 0) {
- return result;
-@@ -795,7 +805,7 @@
- srcDir, PKGDATA_FILE_SEP_STRING, buffer,
- installDir, PKGDATA_FILE_SEP_STRING, buffer);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- fprintf(stderr, "Failed to install data file with command: %s\n", cmd);
- break;
-@@ -815,7 +825,7 @@
- }
- #else
- sprintf(cmd, "%s %s %s %s", WIN_INSTALL_CMD, srcDir, installDir, WIN_INSTALL_CMD_FLAGS);
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- fprintf(stderr, "Failed to install data file with command: %s\n", cmd);
- }
-@@ -849,7 +859,17 @@
- targetDir,
- libFileNames[LIB_FILE_VERSION_TMP]);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
-+ if (result != 0) {
-+ return result;
-+ }
-+
-+ sprintf(cmd, "%s %s%s",
-+ pkgDataFlags[RANLIB],
-+ targetDir,
-+ libFileNames[LIB_FILE_VERSION]);
-+
-+ result = runCommand(cmd);
- if (result != 0) {
- return result;
- }
-@@ -860,7 +880,7 @@
- targetDir,
- libFileNames[LIB_FILE_VERSION_TMP]);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- return result;
- }
-@@ -908,7 +928,21 @@
- pkgDataFlags[A_EXT],
- objectFile);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
-+ if (result == 0)
-+ {
-+#ifdef OS400
-+ sprintf(cmd, "QSH CMD('%s %s%s.%s')",
-+#else
-+ sprintf(cmd, "%s %s%s.%s",
-+#endif
-+ pkgDataFlags[RANLIB],
-+ targetDir,
-+ libFileNames[LIB_FILE],
-+ pkgDataFlags[A_EXT]);
-+
-+ result = runCommand(cmd);
-+ }
- } else /* if (mode == MODE_DLL) */ {
- #ifdef U_CYGWIN
- sprintf(cmd, "%s%s%s %s -o %s%s %s %s%s %s %s",
-@@ -935,7 +969,7 @@
- pkgDataFlags[BIR_FLAGS]);
-
- /* Generate the library file. */
-- result = system(cmd);
-+ result = runCommand(cmd);
- }
-
- if (freeCmd) {
-@@ -961,7 +995,7 @@
- tempObjectFile,
- gencFilePath);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- return result;
- }
-@@ -1043,7 +1077,7 @@
- tempObjectFile,
- gencmnFile);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- break;
- }
-@@ -1094,7 +1128,7 @@
- sprintf(cmd, "cat %s >> %s", gencmnFile, icudtAll);
- #endif
-
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- break;
- }
-@@ -1110,7 +1144,7 @@
- pkgDataFlags[LIBFLAGS],
- tempObjectFile,
- gencmnFile);
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result != 0) {
- break;
- }
-@@ -1139,7 +1173,7 @@
- tempObjectFile,
- icudtAll);
-
-- result = system(cmd);
-+ result = runCommand(cmd);
- if (result == 0) {
- sprintf(buffer, "%s %s",
- buffer,
-@@ -1222,7 +1256,7 @@
- );
- }
-
-- return system(cmd);
-+ return runCommand(cmd);
- }
- #endif
-
diff --git a/dev-libs/icu/icu-4.0.1.ebuild b/dev-libs/icu/icu-4.0.1.ebuild
deleted file mode 100644
index ab81dd373faa..000000000000
--- a/dev-libs/icu/icu-4.0.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.0.1.ebuild,v 1.10 2010/06/16 19:50:33 patrick Exp $
-
-EAPI="2"
-
-inherit eutils versionator
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
-
-BASEURI="http://download.icu-project.org/files/${PN}4c/${PV}"
-DOCS_PV="$(get_version_component_range 1-2)"
-DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${DOCS_PV}"
-DOCS_PV="${DOCS_PV/./_}"
-SRCPKG="${PN}4c-${PV//./_}-src.tgz"
-USERGUIDE="${PN}-${DOCS_PV}-userguide.zip"
-APIDOCS="${PN}4c-${DOCS_PV}-docs.zip"
-
-SRC_URI="${BASEURI}/${SRCPKG}
- doc? ( ${DOCS_BASEURI}/${USERGUIDE}
- ${DOCS_BASEURI}/${APIDOCS} )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-DEPEND="doc? ( app-arch/unzip )"
-RDEPEND=""
-
-S="${WORKDIR}/${PN}/source"
-
-src_unpack() {
- unpack ${SRCPKG}
- if use doc ; then
- mkdir userguide
- pushd ./userguide > /dev/null
- unpack ${USERGUIDE}
- popd > /dev/null
-
- mkdir apidocs
- pushd ./apidocs > /dev/null
- unpack ${APIDOCS}
- popd > /dev/null
- fi
-}
-
-src_prepare() {
- # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
- # Bug 202059
- # http://bugs.icu-project.org/trac/ticket/6102
- for x in CFLAGS CXXFLAGS CPPFLAGS LDFLAGS ; do
- sed -i -e "/^${x} =.*/s:@${x}@::" config/Makefile.inc.in || die "sed failed"
- done
-
- # Bug 258377
- sed -i -e 's:^#elif$:#else:g' ${S}/layoutex/ParagraphLayout.cpp || die 'elif sed failed'
-
- epatch "${FILESDIR}/${P}-fix_parallel_building.patch"
- epatch "${FILESDIR}/${P}-TestDisplayNamesMeta.patch"
-}
-
-src_configure() {
- econf \
- --enable-static \
- $(use_enable debug) \
- $(use_enable examples samples)
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- dohtml ../readme.html
- dodoc ../unicode-license.txt
- if use doc ; then
- insinto /usr/share/doc/${PF}/html/userguide
- doins -r "${WORKDIR}"/userguide/userguide/*
-
- insinto /usr/share/doc/${PF}/html/apidocs
- doins -r "${WORKDIR}"/apidocs/*
- fi
-}
diff --git a/dev-libs/icu/icu-4.2.1.ebuild b/dev-libs/icu/icu-4.2.1.ebuild
deleted file mode 100644
index 641739f88d8a..000000000000
--- a/dev-libs/icu/icu-4.2.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.2.1.ebuild,v 1.13 2010/06/16 19:50:33 patrick Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic versionator
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
-
-BASEURI="http://download.icu-project.org/files/${PN}4c/${PV}"
-DOCS_PV="$(get_version_component_range 1-2)"
-DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${DOCS_PV}"
-DOCS_PV="${DOCS_PV/./_}"
-SRCPKG="${PN}4c-${PV//./_}-src.tgz"
-APIDOCS="${PN}4c-${DOCS_PV}-docs.zip"
-
-SRC_URI="${BASEURI}/${SRCPKG}
- doc? ( ${DOCS_BASEURI}/${APIDOCS} )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-DEPEND="doc? ( app-arch/unzip )"
-RDEPEND=""
-
-S="${WORKDIR}/${PN}/source"
-
-pkg_setup() {
- # ICU fails to build with enabled optimizations (bug #296901).
- if use arm || use ia64 || use sparc; then
- filter-flags -O*
- fi
-}
-
-src_unpack() {
- unpack ${SRCPKG}
- if use doc; then
- mkdir apidocs
- pushd apidocs > /dev/null
- unpack ${APIDOCS}
- popd > /dev/null
- fi
-}
-
-src_prepare() {
- # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
- # Bug 202059
- # http://bugs.icu-project.org/trac/ticket/6102
- for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
- done
-
- epatch "${FILESDIR}/${P}-fix_misoptimizations.patch"
- epatch "${FILESDIR}/${P}-pkgdata.patch"
- epatch "${FILESDIR}/${P}-pkgdata-build_data_without_assembly.patch"
-}
-
-src_configure() {
- econf \
- --enable-static \
- $(use_enable debug) \
- $(use_enable examples samples)
-}
-
-src_test() {
- emake -j1 check || die "emake check failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- dohtml ../readme.html
- dodoc ../unicode-license.txt
- if use doc; then
- insinto /usr/share/doc/${PF}/html/apidocs
- doins -r "${WORKDIR}"/apidocs/*
- fi
-}