summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-05-08 23:26:22 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-05-08 23:26:22 +0000
commitaf551bdb30bebdc780f034b125508da15ceee6d5 (patch)
tree027738f2965a5bc1280749c0d71ed004129fe025 /dev-lisp/cl-albert/cl-albert-0.4.10.ebuild
parentFix prefix back to /usr/lib/mozilla, my mistake (diff)
downloadhistorical-af551bdb30bebdc780f034b125508da15ceee6d5.tar.gz
historical-af551bdb30bebdc780f034b125508da15ceee6d5.tar.bz2
historical-af551bdb30bebdc780f034b125508da15ceee6d5.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-albert/cl-albert-0.4.10.ebuild')
-rw-r--r--dev-lisp/cl-albert/cl-albert-0.4.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lisp/cl-albert/cl-albert-0.4.10.ebuild b/dev-lisp/cl-albert/cl-albert-0.4.10.ebuild
new file mode 100644
index 000000000000..28fcee678f3c
--- /dev/null
+++ b/dev-lisp/cl-albert/cl-albert-0.4.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-albert/cl-albert-0.4.10.ebuild,v 1.1 2004/05/08 23:26:22 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Albert is a documentation-generator for Common Lisp, comparable to Javadoc and Doxygen. Currently it generates DocBook documentation. It reads an ASDF system definition and documents the system."
+HOMEPAGE="http://albert.sourceforge.net/"
+SRC_URI="mirror://sourceforge/albert/${P/cl-/}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ app-text/docbook-dsssl-stylesheets
+ virtual/commonlisp"
+
+CLPACKAGE=albert
+
+S=${WORKDIR}/${P/cl-/}
+
+src_compile() {
+ make -C expat all || die
+}
+
+src_install() {
+ for p in . apispec base lisp2csf specs spres tools ; do
+ insinto /usr/share/common-lisp/source/${CLPACKAGE}/${p}
+ doins ${p}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/${CLPACKAGE}
+ doins *.asd
+ common-lisp-system-symlink
+ dodoc COPYING README ChangeLog THANKS
+ dohtml web/*
+ dobin expat/alb_xml2sexp
+ doman expat/alb_xml2sexp.1
+
+ insinto /usr/share/albert
+ doins data/*
+ insinto /usr/share/albert/icons
+ doins data/icons/*
+ insinto /usr/share/albert/apis
+ doins data/apis
+}