summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-13 09:53:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-13 09:53:00 +0000
commitd606edc545ecc2c98fb148580aa7b07281c4e0c7 (patch)
tree9359d59582c1d8b972b851b17bcf2e5010dd5e51 /dev-lisp/hedgehog
parentold (diff)
downloadhistorical-d606edc545ecc2c98fb148580aa7b07281c4e0c7.tar.gz
historical-d606edc545ecc2c98fb148580aa7b07281c4e0c7.tar.bz2
historical-d606edc545ecc2c98fb148580aa7b07281c4e0c7.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lisp/hedgehog')
-rw-r--r--dev-lisp/hedgehog/ChangeLog10
-rw-r--r--dev-lisp/hedgehog/Manifest4
-rw-r--r--dev-lisp/hedgehog/files/digest-hedgehog-2.0.01
-rw-r--r--dev-lisp/hedgehog/hedgehog-2.0.0.ebuild39
-rw-r--r--dev-lisp/hedgehog/metadata.xml19
5 files changed, 73 insertions, 0 deletions
diff --git a/dev-lisp/hedgehog/ChangeLog b/dev-lisp/hedgehog/ChangeLog
new file mode 100644
index 000000000000..5cc1c3956bbe
--- /dev/null
+++ b/dev-lisp/hedgehog/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/hedgehog
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/hedgehog/ChangeLog,v 1.1 2005/03/13 09:53:00 mkennedy Exp $
+
+*hedgehog-2.0.0 (13 Mar 2005)
+
+ 13 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +hedgehog-2.0.0.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/hedgehog/Manifest b/dev-lisp/hedgehog/Manifest
new file mode 100644
index 000000000000..157edce7fe25
--- /dev/null
+++ b/dev-lisp/hedgehog/Manifest
@@ -0,0 +1,4 @@
+MD5 8dfcde21dac8ff512e6ddf9f03892307 hedgehog-2.0.0.ebuild 960
+MD5 7a9d2ebe58775b5f5ba58968db4d406f metadata.xml 1017
+MD5 63dcf33c3eabb204c18389824a2e85bf ChangeLog 412
+MD5 a84634e23dd156f08563d59a4a8054f6 files/digest-hedgehog-2.0.0 66
diff --git a/dev-lisp/hedgehog/files/digest-hedgehog-2.0.0 b/dev-lisp/hedgehog/files/digest-hedgehog-2.0.0
new file mode 100644
index 000000000000..cb6615bed4a1
--- /dev/null
+++ b/dev-lisp/hedgehog/files/digest-hedgehog-2.0.0
@@ -0,0 +1 @@
+MD5 dfef75312d62f240790ca2131486bb0a hedgehog-2.0.0.tar.gz 160764
diff --git a/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild b/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild
new file mode 100644
index 000000000000..893c252f49e6
--- /dev/null
+++ b/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/hedgehog/hedgehog-2.0.0.ebuild,v 1.1 2005/03/13 09:53:00 mkennedy Exp $
+
+inherit eutils
+
+DESCRIPTION="Hedgehog is a very concise implementation of a Lisp-like language for low-end and embedded devices."
+SRC_URI="http://hedgehog.oliotalo.fi/download/${P}.tar.gz"
+HOMEPAGE="http://hedgehog.oliotalo.fi/"
+SLOT="0"
+LICENSE="LGPL-2.1 BSD"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+# Documentation can't be built until weblint-perl and html2ps are added to
+# portage.
+
+src_unpack() {
+ unpack ${A}
+ pushd ${S}
+ cp configure configure.template \
+ && sed "s,CFLAGS=',CFLAGS='$CFLAGS ,g" \
+ < configure.template \
+ > configure || die
+}
+
+src_compile() {
+ mkdir build
+ cd build
+ ../configure linux /usr || die
+ make || die
+}
+
+src_install () {
+ make -C build install prefix=${D}/usr
+ dodoc LICENSE* README TODO
+}
diff --git a/dev-lisp/hedgehog/metadata.xml b/dev-lisp/hedgehog/metadata.xml
new file mode 100644
index 000000000000..379af1b5c472
--- /dev/null
+++ b/dev-lisp/hedgehog/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Hedgehog is a very concise implementation of a Lisp-like language for low-end
+and embedded devices. It consists of a compiler and a byte code interpreter. The
+byte code interpreter is written in standard conforming C, is efficient and
+easily portable, and can be compiled to a very small executable of only some 20
+kilobytes in the smallest configuration for the Intel x86 architecture.
+
+The Hedgehog Lisp dialect has proper support for local and lambda functions,
+lexical scoping, variable argument functions, garbage collection, exceptions,
+macros, and over a hundred predefined functions or special forms. The built-in
+types are lists, symbols, strings, 32-bit integers, AVL-trees, and tuples up to
+16 elements wide. Proper 32-bit wide integers are necessary for various
+bit-level operations in embedded systems.
+</longdescription>
+</pkgmetadata>