summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-10-17 12:29:14 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-10-17 12:29:14 +0000
commitbac014a630b6828efa95052a29d6dd990f49001d (patch)
tree3de8bce775e09ff86279cfa6752272415f0a2eea /dev-lisp
parentx11-libs/gtksourceview: Bump to version 2.0.1 (bugfix and translations) (diff)
downloadhistorical-bac014a630b6828efa95052a29d6dd990f49001d.tar.gz
historical-bac014a630b6828efa95052a29d6dd990f49001d.tar.bz2
historical-bac014a630b6828efa95052a29d6dd990f49001d.zip
bump
Package-Manager: portage-2.1.3.13
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog76
-rw-r--r--dev-lisp/clisp/Manifest26
-rw-r--r--dev-lisp/clisp/clisp-2.42.ebuild76
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.423
4 files changed, 165 insertions, 16 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index e854758c1ded..6dde6d540965 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,7 +1,79 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.63 2007/09/09 18:01:53 josejx Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.64 2007/10/17 12:29:14 hkbst Exp $
+
+*clisp-2.42 (17 Oct 2007)
+
+ 17 Oct 2007; Marijn Schouten <hkBst@gentoo.org> +clisp-2.42.ebuild:
+ bump
+User visible changes
+--------------------
+
+* New module gtk2 interfaces to GTK+ v2 and makes it possible to build
+ GUI with Glade.
+ Thanks to James Bailey <dgym.bailey@gmail.com> for the original code.
+ See <http://clisp.cons.org/impnotes/gtk.html> for details.
+
+* New module gdbm interfaces to GNU DataBase Manager.
+ Thanks to Masayuki Onjo <masayuki.onjo@gmail.com>.
+ See <http://clisp.cons.org/impnotes/gdbm.html> for details.
+
+* A kind of Meta-Object Protocol for structures is now available.
+ See <http://clisp.cons.org/impnotes/defstruct-mop.html> for details.
+
+* Module libsvm has been upgraded to the upstream version 2.84.
+ See <http://clisp.cons.org/impnotes/libsvm.html> for details.
+
+* NEW-CLX module now supports Stumpwm <http://www.nongnu.org/stumpwm/>.
+ Thanks to Shawn Betts <sabetts@vcn.bc.ca>.
+ New NEW-CLX demos: bball bwindow greynetic hanoi petal plaid recurrence from
+ <http://www.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/gui/clx/clx_demo.cl>.
+ New NEW-CLX demo: clclock based on <http://common-lisp.net/~crhodes/clx>.
+ New function XLIB:OPEN-DEFAULT-DISPLAY from portable CLX.
+
+* Function EXT:ARGLIST now works on macros too.
+ See <http://clisp.cons.org/impnotes/flow-dict.html#arglist> for details.
+
+* Macro TRACE has a new option :BINDINGS, which is useful to share data
+ between PRE-* and POST-* forms.
+ See <http://clisp.cons.org/environment-dict.html#trace> for details.
+
+* Macro FFI:DEF-C-TYPE can now be called with one argument to define an
+ integer type.
+ See <http://clisp.cons.org/impnotes/dffi.html#def-c-type> for details.
+
+* New function EXT:RENAME-DIR can be used to rename directories.
+ See <http://clisp.cons.org/impnotes/file-dict.html#rename-dir> for details.
+
+* Functions FILE-LENGTH and FILE-POSITION now work on unbuffered streams too.
+ See <http://clisp.cons.org/impnotes/stream-dict.html#file-pos> for details.
+
+* Bug fixes:
+ + Fixed EXT:LETF to work with more than one place. [ 1731462 ]
+ + Fixed rounding of long floats [even+1/2]. [ 1589311 ]
+ + Fixed stdio when running without a TTY, e.g., under SSH. [ 1592343 ]
+ + ANSI compliance: PPRINT dispatch is now respected for nested
+ objects, not just the top-level. [ 1483768, 1598053 ]
+ + Fixed print-read-consistency of strings containing #\Return characters
+ (manifested by COMPILE-FILE). [ 1578179 ]
+ + Fixed "clisp-link run". [ 1469663 ]
+ + Fixed ATANH branch cut continuity. [ 1436987 ]
+ + Reset the function lambda expression when loading a compiled file.
+ [ 1603260 ]
+ + DOCUMENTATION set by SETF is now preserved by COMPILE. [ 1604579 ]
+ + LISTEN now calls STREAM-LISTEN as per the Gray proposal. [ 1607666 ]
+ + IMPORT into the KEYWORD package does not make a symbol a constant
+ variable. [ 1612859 ]
+ + DEFPACKAGE code was executed during non top-level compilation. [ 1612313 ]
+ + Fixed format error message formatting. [ 1482465 ]
+ + Fixed *PPRINT-FIRST-NEWLINE* handling. [ 1412454 ]
+ + Improved hash code generation for very large bignums and for long lists.
+ [ 948868, 1208124 ]
+ + Some bugs related to UNICODE-16 & UNICODE-32. [ 1564818, 1631760, 1632718 ]
+ + All exported defined symbols are now properly locked. [ 1713130 ]
+ + Berkeley-DB module no longer fills up error log file. [ 1779416 ]
+ + New-clx now supports 64-bit KeySym. [ 1797132 ]
+
09 Sep 2007; Joseph Jezak <josejx@gentoo.org> clisp-2.41.ebuild:
Marked ppc stable for bug #173050.
diff --git a/dev-lisp/clisp/Manifest b/dev-lisp/clisp/Manifest
index 5f0c0d5515a2..0714dad097b4 100644
--- a/dev-lisp/clisp/Manifest
+++ b/dev-lisp/clisp/Manifest
@@ -1,6 +1,3 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
AUX 2.38/README.Gentoo 334 RMD160 c236897c39f4c8e8f75ff9782d2ee7a7b30aece4 SHA1 3d552a225c26e205c01ec4ebc5286f2d3442cf49 SHA256 336e4287ec4cfdbe8fda692bd217431adb4e303d3f5204bdf3df0ea711fbebd6
MD5 66e5b3968b3a6ad0301ca028447b26b3 files/2.38/README.Gentoo 334
RMD160 c236897c39f4c8e8f75ff9782d2ee7a7b30aece4 files/2.38/README.Gentoo 334
@@ -48,6 +45,7 @@ SHA256 cbf3bd75cc5a9457f34e81c8071865af64310c4f664b1b64b3658cd22abe0e59 files/2.
DIST clisp-2.38.tar.bz2 8078151 RMD160 9070e1d7cd4db66de62f077b68a7fef7413da622 SHA1 d9586c04ed4778b5c603b3b1df73e8c76220df59 SHA256 98ddb7faa384b9b62621ac9af8b4416cbe1b6df420306fceea9e1e01a880e051
DIST clisp-2.39.tar.bz2 8071957 RMD160 b31e53cb97a116c683543ee74093fe2a05ed9ea4 SHA1 388cc208cd0bd05a154840e83a4b824a493acbc0 SHA256 9e7db421d076420d60652e7bdaf8241e36d1db6a4cad2a8253afc9952200bbb7
DIST clisp-2.41.tar.bz2 8319471 RMD160 e98ee7142c01e946f242360c7495df5668694d34 SHA1 0f53703d45807c10e0398fc85352ed605ee566a3 SHA256 1e5f8d9b04024ae072536ae3271075c1a422c02d3997a729a6b00912ed2ae323
+DIST clisp-2.42.tar.bz2 8284453 RMD160 b6d6b3c255c3f91f76e5fc46b1f05cca2ebbb388 SHA1 4c39a5549d2821b1d5ab1cfca172527e9053af1c SHA256 6e0f44fd76505557620b43d8b6cfdb3fcd6bfbe1facd7c1b951fc0e47fff30d8
EBUILD clisp-2.38-r1.ebuild 3111 RMD160 4588e6a1a50481322ca14e801dfb19df55ea6756 SHA1 048919a8acc248e5a10c0f735f5b8397e28f9e32 SHA256 7ab1b327f61d587c2ae2f390b3d901770ed31b6cb3eebacb1c79e0fab987bfe6
MD5 a992b5f32a78421a1de39176d44b7dff clisp-2.38-r1.ebuild 3111
RMD160 4588e6a1a50481322ca14e801dfb19df55ea6756 clisp-2.38-r1.ebuild 3111
@@ -68,10 +66,14 @@ EBUILD clisp-2.41.ebuild 2691 RMD160 1a054ed8dd499b2ae8a403789abc6e3ac319c0c2 SH
MD5 3f730e26aa1ef6180ce105cb51e59542 clisp-2.41.ebuild 2691
RMD160 1a054ed8dd499b2ae8a403789abc6e3ac319c0c2 clisp-2.41.ebuild 2691
SHA256 aa1a4950b505a65a1f57311deef166c38525cb977a11e3f4d5a9067fb1ba691d clisp-2.41.ebuild 2691
-MISC ChangeLog 14371 RMD160 d1480ba70d5b17265d18c176da47a11199b87b5c SHA1 1fc88586d4e5fa48d4fd5b291d80fc2f2cd5e6db SHA256 bc1b9f70aa4ab74242a17411b455d7a9cb1229edf3682171d5c892d631fcb5d4
-MD5 364728f2cde84dc41a5c82a386d92f7b ChangeLog 14371
-RMD160 d1480ba70d5b17265d18c176da47a11199b87b5c ChangeLog 14371
-SHA256 bc1b9f70aa4ab74242a17411b455d7a9cb1229edf3682171d5c892d631fcb5d4 ChangeLog 14371
+EBUILD clisp-2.42.ebuild 2520 RMD160 6f02ba3f8e7df5b14eb7f6922210431546fbf81e SHA1 c9be277afcd296fa34f7ccfda9013309703e8d45 SHA256 9ff4171abc157bb1039e028ce179e5564d8ab2b2928d16e947ebef60d729e1dd
+MD5 e43296026e7f8770dad6d410dae4107d clisp-2.42.ebuild 2520
+RMD160 6f02ba3f8e7df5b14eb7f6922210431546fbf81e clisp-2.42.ebuild 2520
+SHA256 9ff4171abc157bb1039e028ce179e5564d8ab2b2928d16e947ebef60d729e1dd clisp-2.42.ebuild 2520
+MISC ChangeLog 17800 RMD160 082e215bcac2443e5673bf21bbc32153bb1da9d4 SHA1 517a051895e30abe9d2c74a12d00ce6c233a1111 SHA256 1556dee06a0c63100e127c3fbb96c1aa25a63dbea57a8b40d0aed6c074a91a80
+MD5 6b5ee54f3234fb4cec9a8cd5fb914922 ChangeLog 17800
+RMD160 082e215bcac2443e5673bf21bbc32153bb1da9d4 ChangeLog 17800
+SHA256 1556dee06a0c63100e127c3fbb96c1aa25a63dbea57a8b40d0aed6c074a91a80 ChangeLog 17800
MISC metadata.xml 882 RMD160 c1c9236c3fb6d0594a998221fbff50add9b1d1b2 SHA1 87e15aa8db7170dd4ca3bb0e71c5ce2fb097f588 SHA256 b55a5dec0b7c7764565517bab024bb1526dd21cf58bc4a727f09ac3d2ff4983f
MD5 485cde76397408cf913fc6d4c7a45a67 metadata.xml 882
RMD160 c1c9236c3fb6d0594a998221fbff50add9b1d1b2 metadata.xml 882
@@ -91,10 +93,6 @@ SHA256 c3bfe5f9bfd6dee2728f0a3ca4ef42a95c7bfed32324a1b2b30e656f4bcc8c59 files/di
MD5 751572a6bad499c23e70a91bf73e4d6e files/digest-clisp-2.41 238
RMD160 c0949434828b8947ae28dd971848db0ee45bfa74 files/digest-clisp-2.41 238
SHA256 16ca4c78b4938a9b53837d811e79eab641480a62fcd769d34cb2e5bb01a390d6 files/digest-clisp-2.41 238
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.6 (GNU/Linux)
-
-iD8DBQFG5DVbcsIHjyDViGQRAqzsAJ9PB27jXCiKsRLxXhUHseCjmE2b6gCfaXPh
-VBfCGnOfvjhzKnciCnrfNzo=
-=eXwI
------END PGP SIGNATURE-----
+MD5 89ef2d07195a7029f4aa6166aac36e8a files/digest-clisp-2.42 238
+RMD160 17921ea7bfcff03a1744736808897f3971e550d3 files/digest-clisp-2.42 238
+SHA256 fcce8250235a0e09dff537da7f524cd123c91ad35039447da084883b6ab89939 files/digest-clisp-2.42 238
diff --git a/dev-lisp/clisp/clisp-2.42.ebuild b/dev-lisp/clisp/clisp-2.42.ebuild
new file mode 100644
index 000000000000..b65e764af220
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.42.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.42.ebuild,v 1.1 2007/10/17 12:29:14 hkbst Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="X new-clx fastcgi pcre postgres readline zlib"
+
+RDEPEND=">=dev-libs/libsigsegv-2.4
+ virtual/tetex
+ fastcgi? ( dev-libs/fcgi )
+ postgres? ( >=dev-db/postgresql-8.0 )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( x11-libs/libXpm ) )"
+# * GNU gettext
+# + Not needed on systems with glibc 2.2 or newer, but recommended on all
+# other systems: needed if you want clisp with native language support.
+# sys-devel/gettext
+
+DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PROVIDE="virtual/commonlisp"
+
+BUILDDIR="builddir"
+
+src_compile() {
+ CC="$(tc-getCC)"
+ local myconf="--with-dynamic-ffi --with-module=wildcard --with-module=rawsock"
+ use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
+ use readline || myconf="${myconf} --with-noreadline"
+ if use X; then
+ if use new-clx; then
+ myconf="${myconf} --with-module=clx/new-clx"
+ else
+ myconf="${myconf} --with-module=clx/mit-clx"
+ fi
+ fi
+ if use postgres; then
+ myconf="${myconf} --with-module=postgresql"
+ CC="${CC} -I $(pg_config --includedir)"
+ fi
+ use fastcgi && myconf="${myconf} --with-module=fastcgi"
+ use pcre && myconf="${myconf} --with-module=pcre"
+ use zlib && myconf="${myconf} --with-module=zlib"
+
+ # configure chokes on --infodir option
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ --hyperspec="http://www.lisp.org/HyperSpec/FrontMatter/" \
+ ${myconf} ${BUILDDIR} || die "./configure failed"
+ cd ${BUILDDIR}
+ ./makemake ${myconf} >Makefile
+ emake config.lisp
+ sed -i 's,"vi","nano",g' config.lisp
+ # parallel build fails
+ emake -j1|| die "emake failed"
+}
+
+src_install() {
+ pushd ${BUILDDIR}
+ make DESTDIR="${D}" prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ chmod a+x "${D}"/usr/$(get_libdir)/clisp/clisp-link
+ popd
+ dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
+ dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
+}
diff --git a/dev-lisp/clisp/files/digest-clisp-2.42 b/dev-lisp/clisp/files/digest-clisp-2.42
new file mode 100644
index 000000000000..0634b9bb6066
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.42
@@ -0,0 +1,3 @@
+MD5 3fc28342e446a62c1eb4f65277929888 clisp-2.42.tar.bz2 8284453
+RMD160 b6d6b3c255c3f91f76e5fc46b1f05cca2ebbb388 clisp-2.42.tar.bz2 8284453
+SHA256 6e0f44fd76505557620b43d8b6cfdb3fcd6bfbe1facd7c1b951fc0e47fff30d8 clisp-2.42.tar.bz2 8284453