summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-30 11:42:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-30 11:42:30 +0000
commit1d59902cea228d60167d7eaea9b60205fd3af0f3 (patch)
treeb54c90f73330bc9ec1f0523dc23685df3c10c88c /dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
parentKeyword ~mips, requested by scarabeus (diff)
downloadhistorical-1d59902cea228d60167d7eaea9b60205fd3af0f3.tar.gz
historical-1d59902cea228d60167d7eaea9b60205fd3af0f3.tar.bz2
historical-1d59902cea228d60167d7eaea9b60205fd3af0f3.zip
version bump
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild')
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
new file mode 100644
index 000000000000..637cbba1406c
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild,v 1.1 2012/10/30 11:42:23 aballier Exp $
+
+EAPI=4
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
+SRC_URI="http://nodeload.github.com/vincenthz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}