summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 13:51:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 13:51:36 +0000
commitece183c19c4dffb4bf31a1718c8af3bd1ca1941a (patch)
tree941c76cc8bddeb1f13c256f6b1cbdb70439a4821 /dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
parenteapi5, define subslot and add := dep on ocaml (diff)
downloadhistorical-ece183c19c4dffb4bf31a1718c8af3bd1ca1941a.tar.gz
historical-ece183c19c4dffb4bf31a1718c8af3bd1ca1941a.tar.bz2
historical-ece183c19c4dffb4bf31a1718c8af3bd1ca1941a.zip
eapi5, define subslot and add := dep on ocaml packages
Package-Manager: portage-2.2.0/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild')
-rw-r--r--dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
index 62cd29e18652..17b7c980f861 100644
--- a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
+++ b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild,v 1.5 2011/02/12 16:02:42 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild,v 1.6 2013/08/19 13:51:29 aballier Exp $
-EAPI="2"
+EAPI=5
inherit base findlib
@@ -11,11 +11,11 @@ HOMEPAGE="http://oandrieu.nerim.net/ocaml/gsl/"
SRC_URI="http://oandrieu.nerim.net/ocaml/gsl/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="amd64 ~ppc x86"
IUSE="doc test"
-RDEPEND=">=dev-lang/ocaml-3.10
+RDEPEND=">=dev-lang/ocaml-3.10:=
sci-libs/gsl"
DEPEND="${RDEPEND}
test? ( dev-ml/fort )"
@@ -23,16 +23,16 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${P}-ocaml311.patch" )
src_compile() {
- emake CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CFLAGS="${CFLAGS}"
}
src_install() {
findlib_src_preinst
- emake install-findlib || die "emake install failed"
+ emake install-findlib
dodoc README NEWS NOTES
- doinfo *.info* || die "info install failed"
+ doinfo *.info*
if use doc; then
- dohtml doc/* || die "html docs install failed"
+ dohtml doc/*
fi
}