summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-28 11:37:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-28 11:37:13 +0000
commitbb2947cd64a9a28519ec8762359b9b8fcf9ba0dd (patch)
tree6b6377e7295e1a92d59bb44ac99512e495616193 /dev-ml
parentBad bug number reference on previous commit (diff)
downloadhistorical-bb2947cd64a9a28519ec8762359b9b8fcf9ba0dd.tar.gz
historical-bb2947cd64a9a28519ec8762359b9b8fcf9ba0dd.tar.bz2
historical-bb2947cd64a9a28519ec8762359b9b8fcf9ba0dd.zip
initial import, based on Olivier Huber work in bug #350056 and then converted to oasis.eclass
Package-Manager: portage-2.2.0_alpha96/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-text/ChangeLog11
-rw-r--r--dev-ml/ocaml-text/Manifest14
-rw-r--r--dev-ml/ocaml-text/metadata.xml5
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.5.ebuild26
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/ocaml-text/ChangeLog b/dev-ml/ocaml-text/ChangeLog
new file mode 100644
index 000000000000..6260de8e87c1
--- /dev/null
+++ b/dev-ml/ocaml-text/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocaml-text
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ChangeLog,v 1.1 2012/03/28 11:37:13 aballier Exp $
+
+*ocaml-text-0.5 (28 Mar 2012)
+
+ 28 Mar 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-text-0.5.ebuild,
+ +metadata.xml:
+ initial import, based on Olivier Huber work in bug #350056 and then converted
+ to oasis.eclass
+
diff --git a/dev-ml/ocaml-text/Manifest b/dev-ml/ocaml-text/Manifest
new file mode 100644
index 000000000000..b1d4017fb615
--- /dev/null
+++ b/dev-ml/ocaml-text/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST ocaml-text-0.5.tar.gz 248862 RMD160 860fbfc66511d008ab4f18c53bcadc78e961c5ad SHA1 26d02d1a5340c24c0ed2ecf852f5857a8c49c646 SHA256 d7fc2ae616130a61f822686a6c366a5a4653d3fd8785c14d57038c9f5643dfc3
+EBUILD ocaml-text-0.5.ebuild 670 RMD160 027126b4b5ceb9c9a714854bb962990f935ecdb8 SHA1 5004fae674b3ebc0e6d6617188850abe5dbf0ec4 SHA256 03dd94f57360ed75980adc9dc6aadadaec361112bdd54b98c381137d1ea86f98
+MISC ChangeLog 432 RMD160 045254a118eed5f6be3f251822cd7a868f6d0a8f SHA1 11295223eef9e887a513edc73c4c6b5e65a29389 SHA256 433b075f4a43ae9c14cdca3ca366ace3dcac69769aa040c60f7cb7a7c89b4e23
+MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEARECAAYFAk9y9+8ACgkQvFcC4BYPU0pE2ACfYlnyzy2nCXNhSemyysriZJom
+BmcAoMpXkL7ciKw+4Mo9xoQ1LKJDghkt
+=c0JS
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/ocaml-text/metadata.xml b/dev-ml/ocaml-text/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ocaml-text/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-text/ocaml-text-0.5.ebuild b/dev-ml/ocaml-text/ocaml-text-0.5.ebuild
new file mode 100644
index 000000000000..e4b68c9728b2
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ocaml-text-0.5.ebuild,v 1.1 2012/03/28 11:37:13 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_DOCS=1
+inherit oasis
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/641/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+DEPEND="virtual/libiconv
+ pcre? ( dev-ml/pcre-ocaml[ocamlopt?] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}