summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-11-21 13:00:22 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-11-21 13:00:22 +0000
commitcacb7909ae8ad2407ec0936c926a7232faada774 (patch)
treea81240c6bbf0abc763462b6e13b8a47d19e033d5 /dev-perl/HTML-Mason
parentMarked stable. (diff)
downloadhistorical-cacb7909ae8ad2407ec0936c926a7232faada774.tar.gz
historical-cacb7909ae8ad2407ec0936c926a7232faada774.tar.bz2
historical-cacb7909ae8ad2407ec0936c926a7232faada774.zip
Fixes bug 10866 with a nasty work around
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog11
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.15-r1.ebuild48
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild24
-rw-r--r--dev-perl/HTML-Mason/files/digest-HTML-Mason-1.15-r11
4 files changed, 81 insertions, 3 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index 9f440d1b4699..8085a31fd039 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.4 2002/11/17 06:38:01 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.5 2002/11/21 13:00:22 mcummings Exp $
+
+*HTML-Mason-1.15-r1 (21 Nov 2002)
+
+ 21 Nov 2002; Michael Cummings <mcummings@gentoo.org> ChangeLog,
+ HTML-Mason-1.15-r1, files/digest-HTML-Mason-1.15-r1 :
+
+ Addresses bug 10866 with a rather nasty fix. HTML-Mason wants to delete some
+ previously installed files if it detects them, which violates the sandbox.
+
*HTML-Mason-1.15 (16 Nov 2002)
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.15-r1.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.15-r1.ebuild
new file mode 100644
index 000000000000..30bbd12f375c
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.15-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.15-r1.ebuild,v 1.1 2002/11/21 13:00:22 mcummings Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="http://www.masonhq.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0-r2
+ >=dev-perl/Params-Validate-0.24-r1
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.07
+ >=dev-perl/Cache-Cache-1.01"
+
+mydoc="CREDITS UPGRADE"
+
+src_install () {
+ #This is a nasty fix for a sandbox violation that Mason wants to do
+ mv -f install/delete_old_pods.pl install/delete_old_pods.pl2
+ sed -e "s/use strict/exit()/" install/delete_old_pods.pl2 > install/delete_old_pods.pl
+ perl-module_src_install
+ dohtml htdocs/*
+}
+
+
+pkg_postinst() {
+ einfo
+ einfo "Due to a change in documention in HTML-Mason, you will need to note"
+ einfo "that the documentation in the following files is no longer valid."
+ einfo "These files are present only if you had a previous install of "
+ einfo "HTML-Mason. Feel free to remove these docs from your system: "
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Interp.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/ApacheHandler.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Request.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Component.pod"
+ einfo "Where PERLVERSION is your version of perl (5.6.1, 5.8)"
+ einfo
+
+}
+
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild
index 7e2ea1e5e95c..85ffc9f8bb1e 100644
--- a/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild,v 1.2 2002/11/18 02:15:38 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild,v 1.3 2002/11/21 13:00:22 mcummings Exp $
inherit perl-module
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.masonhq.com/"
SLOT="0"
LICENSE="Artistic | GPL-2"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
DEPEND="${DEPEND}
>=dev-perl/libapreq-1.0-r2
@@ -23,6 +23,26 @@ DEPEND="${DEPEND}
mydoc="CREDITS UPGRADE"
src_install () {
+ #This is a nasty fix for a sandbox violation that Mason wants to do
+ mv -f install/delete_old_pods.pl install/delete_old_pods.pl2
+ sed -e "s/use strict/exit()/" install/delete_old_pods.pl2 > install/delete_old_pods.pl
perl-module_src_install
dohtml htdocs/*
}
+
+
+pkg_postinst() {
+ einfo
+ einfo "Due to a change in documention in HTML-Mason, you will need to note"
+ einfo "that the documentation in the following files is no longer valid."
+ einfo "These files are present only if you had a previous install of "
+ einfo "HTML-Mason. Feel free to remove these docs from your system: "
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Interp.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/ApacheHandler.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Request.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Component.pod"
+ einfo "Where PERLVERSION is your version of perl (5.6.1, 5.8)"
+ einfo
+
+}
+
diff --git a/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.15-r1 b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.15-r1
new file mode 100644
index 000000000000..297ad8bee2c3
--- /dev/null
+++ b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.15-r1
@@ -0,0 +1 @@
+MD5 f06c67a65add14b0232d63a4f43d8cf5 HTML-Mason-1.15.tar.gz 284903