summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-08-30 10:53:37 +0000
committerTorsten Veller <tove@gentoo.org>2011-08-30 10:53:37 +0000
commit17073036c8d7782cc6ced4b849a98f2749526ba6 (patch)
tree22729497425ae7fce500399415c8c1eb8d3ca361 /dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing
parentSupport for LZMA as written by Oschtan in bug #357703. Ported to EAPI 4. (diff)
downloadhistorical-17073036c8d7782cc6ced4b849a98f2749526ba6.tar.gz
historical-17073036c8d7782cc6ced4b849a98f2749526ba6.tar.bz2
historical-17073036c8d7782cc6ced4b849a98f2749526ba6.zip
Change version scheme
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing')
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog10
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog
index febc1445db9e..ba912bc26876 100644
--- a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog,v 1.4 2010/04/23 11:47:31 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog,v 1.5 2011/08/30 10:42:46 tove Exp $
+
+*Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0 (30 Aug 2011)
+
+ 30 Aug 2011; Torsten Veller <tove@gentoo.org>
+ +Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0.ebuild:
+ Change version scheme
23 Apr 2010; Torsten Veller <tove@gentoo.org>
Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03-r1.ebuild:
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0.ebuild b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0.ebuild
new file mode 100644
index 000000000000..2608cdeb0514
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0.ebuild,v 1.1 2011/08/30 10:42:46 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DANBORN
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="SpamAssassin plugin to score mail based on Google blocklists."
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="test"
+
+RDEPEND="dev-perl/Net-Google-SafeBrowsing-Blocklist
+ dev-perl/Net-Google-SafeBrowsing-UpdateRequest
+ mail-filter/spamassassin"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod )"
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ insinto /etc/mail/spamassassin
+ doins "${FILESDIR}"/init_google_safebrowsing.pre
+ doins "${FILESDIR}"/24_google_safebrowsing.cf
+ insinto /etc/cron.d/
+ newins "${FILESDIR}"/update_google_safebrowsing.cron update_google_safebrowsing
+ dosbin "${FILESDIR}"/update_google_safebrowsing.sh
+ keepdir /var/lib/spamassassin/google_safebrowsing/
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/etc/cron.d/update_google_safebrowsing.sh ]]; then
+ ewarn "You MUST remove ${ROOT}/etc/cron.d/update_google_safebrowsing.sh"
+ fi
+ elog "To use this package:"
+ elog "1. You MUST apply for a free apikey at:"
+ elog " http://code.google.com/apis/safebrowsing/key_signup.html"
+ elog "2. Place the key into /etc/mail/spamassassin/24_google_safebrowsing.cf"
+ elog "3. Manually run the script /usr/sbin/update_google_safebrowsing.sh"
+ elog "4. Enable the plugin by uncommenting the loadplugin entry in"
+ elog " /etc/mail/spamassassin/init_google_safebrowsing.pre"
+ elog "5. Restart spamd"
+}