summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-04 00:33:51 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-04 00:33:51 +0000
commitbf2d1f2e9287fda6083cba6b2e56534d6e205be8 (patch)
treea7739aecb5efb82b427d056f9e8df693370d0259 /dev-php/jpgraph
parentInitial commit (diff)
downloadhistorical-bf2d1f2e9287fda6083cba6b2e56534d6e205be8.tar.gz
historical-bf2d1f2e9287fda6083cba6b2e56534d6e205be8.tar.bz2
historical-bf2d1f2e9287fda6083cba6b2e56534d6e205be8.zip
Initial commit
Diffstat (limited to 'dev-php/jpgraph')
-rw-r--r--dev-php/jpgraph/Manifest4
-rw-r--r--dev-php/jpgraph/files/digest-jpgraph-1.12.21
-rw-r--r--dev-php/jpgraph/jpgraph-1.12.2.ebuild55
3 files changed, 58 insertions, 2 deletions
diff --git a/dev-php/jpgraph/Manifest b/dev-php/jpgraph/Manifest
index 990438c48a45..e6a8948c9053 100644
--- a/dev-php/jpgraph/Manifest
+++ b/dev-php/jpgraph/Manifest
@@ -1,3 +1,3 @@
-MD5 56ccb7972e6ff088e0d502e5383fd96f jpgraph-1.12.2.ebuild 1501
-MD5 46039a1ae46a2ae5c2ff9f687037042e ChangeLog 346
+MD5 43ab004f6a5691fd3a7a0435e5b220a6 jpgraph-1.12.2.ebuild 1601
+MD5 de741e00821ff163119f289d0ae008fd ChangeLog 434
MD5 4f6fb9ae9a7dd1daf9b37c4b458bf0d3 files/digest-jpgraph-1.12.2 67
diff --git a/dev-php/jpgraph/files/digest-jpgraph-1.12.2 b/dev-php/jpgraph/files/digest-jpgraph-1.12.2
new file mode 100644
index 000000000000..75d003ddac91
--- /dev/null
+++ b/dev-php/jpgraph/files/digest-jpgraph-1.12.2
@@ -0,0 +1 @@
+MD5 666d934c67fb79f278e7695fd3660f75 jpgraph-1.12.2.tar.gz 1991375
diff --git a/dev-php/jpgraph/jpgraph-1.12.2.ebuild b/dev-php/jpgraph/jpgraph-1.12.2.ebuild
new file mode 100644
index 000000000000..e78a424093ee
--- /dev/null
+++ b/dev-php/jpgraph/jpgraph-1.12.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Released under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-1.12.2.ebuild,v 1.1 2003/08/04 00:33:41 stuart Exp $
+#
+# Based on the ebuild submitted by ??
+
+DESCRIPTION="JpGraph is a fully OO graph drawing library for PHP."
+HOMEPAGE="http://www.aditus.nu/jpgraph/"
+SRC_URI="http://www.aditus.nu/jpgraph/downloads/${P}.tar.gz"
+
+# QPL license for non-commercial use, regular commercial license available
+LICENSE="QPL-1.0"
+
+IUSE="truetype"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND="virtual/php
+ >=media-libs/libgd-1.8"
+
+S="${WORKDIR}/${P}"
+JPGRAPH_CACHE_DIR="/var/cache/jpgraph"
+
+inherit php-lib
+
+# setup defaults in case we don't have a web server installed
+
+HTTPD_USER=root
+HTTPD_GROUP=root
+
+has_version "net-www/apache" && inherit webapp-apache
+
+src_install ()
+{
+ sed -i 's|DEFINE("CACHE_FILE_GROUP", "wwwadmin");|DEFINE("CACHE_FILE_GROUP", "${HTTPD_GROUP}";|' src/jpgraph.php
+ sed -i 's|/tmp/jpgraph_cache/|${JPGRAPH_CACHE_DIR}/|g' src/jpgraph.php
+
+ sed -i 's|DEFINE("USE_CACHE",false);|if (!defined("USE_CACHE")) DEFINE("USE_CACHE", false);|' src/jpgraph.php
+
+ # install php files
+ php-lib_src_install src `cd src ; find . -type f -print`
+
+ # install documentation
+ dodoc README src/Changelog
+ dohtml -r docs/*
+
+ # setup the cache dir
+ # cachedir must be world-writable, because PHP/CLI doesn't run
+ # as the apache user!
+
+ keepdir "${JPGRAPH_CACHE_DIR}"
+ fowners ${HTTPD_USER}.${HTTPD_GROUP} "${JPGRAPH_CACHE_DIR}"
+ fperms 777 "${JPGRAPH_CACHE_DIR}"
+}