summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Shoemaker <kutsuya@gentoo.org>2003-03-06 03:00:37 +0000
committerJason Shoemaker <kutsuya@gentoo.org>2003-03-06 03:00:37 +0000
commit1bfefdc51d74efd219cb99efaf0bd371b13673f3 (patch)
tree6fae35e3cd965c0ecf68007d55f07604503421a8 /dev-python/Imaging/Imaging-1.1.3-r1.ebuild
parenttstr shoudl have been tmpstr. Fixed. (diff)
downloadhistorical-1bfefdc51d74efd219cb99efaf0bd371b13673f3.tar.gz
historical-1bfefdc51d74efd219cb99efaf0bd371b13673f3.tar.bz2
historical-1bfefdc51d74efd219cb99efaf0bd371b13673f3.zip
Major revision. Now using distutils.eclass, so removed all but ~x86 arch.
Diffstat (limited to 'dev-python/Imaging/Imaging-1.1.3-r1.ebuild')
-rw-r--r--dev-python/Imaging/Imaging-1.1.3-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/Imaging/Imaging-1.1.3-r1.ebuild b/dev-python/Imaging/Imaging-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..6454c8ba1bdf
--- /dev/null
+++ b/dev-python/Imaging/Imaging-1.1.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/Imaging-1.1.3-r1.ebuild,v 1.1 2003/03/06 03:00:37 kutsuya Exp $
+
+inherit distutils
+
+IUSE="tcltk"
+
+DESCRIPTION="Python Imaging Library (PIL)."
+SRC_URI="http://www.pythonware.com/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.pythonware.com/downloads/#pil"
+
+DEPEND=">=media-libs/jpeg-6a
+ >=sys-libs/zlib-0.95
+ tcltk? ( dev-lang/tk )"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="as-is"
+
+ src_compile() {
+ export OPT=${CFLAGS}
+
+ #Build the core imaging library (libImaging.a)
+ cd ${S}/libImaging
+ econf
+ cp Makefile Makefile.orig
+
+ #Not configured by configure
+ sed \
+ -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
+ Makefile.orig > Makefile
+ emake || die
+ cd ${S}
+ distutils_src_compile
+}
+
+src_install ()
+{
+ local mydoc="CHANGES* CONTENTS"
+ distutils_src_install
+ distutils_python_version
+
+ # install headers required by media-gfx/sketch
+ insinto "${ROOT}/usr/include/python${PYVER}"
+ doins libImaging/Imaging.h
+ doins libImaging/ImPlatform.h
+ doins libImaging/ImConfig.h
+}
+