summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-20 23:41:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-20 23:41:25 +0000
commit2882b076061019ef090e79b44fdfb29fed580365 (patch)
treef1af9ef33d416f35bc34f6d7043e1b7262bf04b9 /dev-python/beautifulsoup
parentAdd a RAKE_FAKEGEM_BINWRAP variable. (diff)
downloadhistorical-2882b076061019ef090e79b44fdfb29fed580365.tar.gz
historical-2882b076061019ef090e79b44fdfb29fed580365.tar.bz2
historical-2882b076061019ef090e79b44fdfb29fed580365.zip
Reduce differences between ebuilds.
Package-Manager: portage-15121-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/Manifest4
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild25
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild9
3 files changed, 22 insertions, 16 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index 2ecd51b8f2b7..f1750875666b 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1,7 +1,7 @@
AUX beautifulsoup-3.1.0.1-python-3.patch 42319 RMD160 4f7c565db498c1b8716bb339b5835308e5b6ea18 SHA1 949794c651fc1214d59379d9eee18b2232841dc6 SHA256 ff316866451fa89bcd55f2a12590960df0d1c5b099cb94ca8e2d684024536a97
DIST BeautifulSoup-3.0.7.tar.gz 30217 RMD160 770f64396132c9104b586b6e32db477b14631311 SHA1 f5466428556856c89d923adb6d75c9cecff84160 SHA256 56699116e4f4dbd2e3708ef7c4ad0a1e57c08207d8eed863eedbcac81907a1e0
DIST BeautifulSoup-3.1.0.1.tar.gz 71460 RMD160 24a4ac2a5faef8136223cba3f3532f7ce0b6bb70 SHA1 e9593b0412402325b6a98e3bf35ac8d00da5fc00 SHA256 820a80f473240d9d30047f36c959d530a699a732500662dd8b03e1d3ccad12a8
-EBUILD beautifulsoup-3.0.7.ebuild 730 RMD160 7a100ed58c698b353b5869af6209812247186dae SHA1 f932f3fa46919c265901667f413ad33234f8d41c SHA256 bdced03dfbb5c54ab1b01b99811b6de903b7a3569efdd1017ab58824cd8fa765
-EBUILD beautifulsoup-3.1.0.1.ebuild 1362 RMD160 c3e0e864082b5be3e16db71dc77bc30d95969d6a SHA1 0fedca8605e00c05a422c078c250fecb532c9d0a SHA256 3d0cc4e4b0acd0a80a372c0979908b5f6c9fef62f2878051f94763aa98465c5e
+EBUILD beautifulsoup-3.0.7.ebuild 915 RMD160 08282e9e63692b4324f17e1f646b6ed76055eb75 SHA1 b544d3edb2f8e3401de2605790df0bc48f52d47f SHA256 08d6102a1b7103a6f4a430039c513bd5678d6005d09d0a89fa6de006896e028d
+EBUILD beautifulsoup-3.1.0.1.ebuild 1320 RMD160 7c96dfcc5c21b8f26270b02c5e75f3c4762679d4 SHA1 df402c9a9d5d6b2331ddc87b78d0c38323608b80 SHA256 58adbbc639ad567969b8afc0e9607803916c28e09d0a2d5e7648d5057838db97
MISC ChangeLog 3418 RMD160 73c7f4a6053c7a8da8c5a7adfb25a847a2a63f1b SHA1 09ace28cd61863e182e0ea2561a40c957219f09c SHA256 a52725edd20d30e94503195b96e4692f1add74836e65e6378ee4059a033e7b90
MISC metadata.xml 563 RMD160 cf0490772a189d33d61d70e36a3284d931b25a2e SHA1 e2ee0122de0b6ca86344eed9f21757142d2e8e7d SHA256 a6cb08d6eeabbc3b9229ffd0de8f9abf724346d62891f33183bd6ae37a5417cf
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild
index 59b827f71518..9ed58df11e1b 100644
--- a/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild
@@ -1,24 +1,35 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild,v 1.5 2009/11/03 18:52:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild,v 1.6 2009/12/20 23:41:25 arfrever Exp $
-NEED_PYTHON="2.3"
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-MY_PN=BeautifulSoup
-MY_P=${MY_PN}-${PV}
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
SRC_URI="http://www.crummy.com/software/${MY_PN}/download/${MY_P}.tar.gz"
+
LICENSE="PSF-2.3"
SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
IUSE=""
-S=${WORKDIR}/${MY_P}
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
src_test() {
- PYTHONPATH="." "${python}" BeautifulSoupTests.py || die "tests failed"
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" BeautifulSoupTests.py
+ }
+ python_execute_function testing
}
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild
index 0120838793ad..314a956f06b3 100644
--- a/dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild,v 1.6 2009/11/22 19:00:36 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.1.0.1.ebuild,v 1.7 2009/12/20 23:41:25 arfrever Exp $
EAPI="2"
-
-NEED_PYTHON="2.3"
SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
@@ -27,6 +25,7 @@ RDEPEND=""
S="${WORKDIR}/${MY_P}"
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
src_prepare() {
python_copy_sources --no-link
@@ -44,7 +43,3 @@ src_test() {
}
python_execute_function -s testing
}
-
-pkg_postinst() {
- python_mod_optimize BeautifulSoup.py BeautifulSoupTests.py
-}