summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 20:56:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 20:56:46 +0000
commit65b661169406b2856fbefcb0e312fc351183db44 (patch)
tree07dfe2ffb8b07466a0cccf205424985581e7a4e2 /dev-python/louie
parentUpdate Gnome 2.32 mask. (diff)
downloadhistorical-65b661169406b2856fbefcb0e312fc351183db44.tar.gz
historical-65b661169406b2856fbefcb0e312fc351183db44.tar.bz2
historical-65b661169406b2856fbefcb0e312fc351183db44.zip
Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Enable tests. Use PyPI mirrors.
Package-Manager: portage-2.2.0_alpha2_p2/cvs/Linux x86_64
Diffstat (limited to 'dev-python/louie')
-rw-r--r--dev-python/louie/ChangeLog7
-rw-r--r--dev-python/louie/Manifest4
-rw-r--r--dev-python/louie/louie-1.1.ebuild25
3 files changed, 25 insertions, 11 deletions
diff --git a/dev-python/louie/ChangeLog b/dev-python/louie/ChangeLog
index af8b572d38ad..7038e688253d 100644
--- a/dev-python/louie/ChangeLog
+++ b/dev-python/louie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/louie
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/louie/ChangeLog,v 1.5 2010/10/15 14:19:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/louie/ChangeLog,v 1.6 2010/10/30 20:56:46 arfrever Exp $
+
+ 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ louie-1.1.ebuild:
+ Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Enable tests. Use
+ PyPI mirrors.
15 Oct 2010; Brent Baude <ranger@gentoo.org> louie-1.1.ebuild:
Marking louie-1.1 ~ppc for bug 311825
diff --git a/dev-python/louie/Manifest b/dev-python/louie/Manifest
index 75f9925c4bd3..a303f5156d34 100644
--- a/dev-python/louie/Manifest
+++ b/dev-python/louie/Manifest
@@ -1,4 +1,4 @@
DIST Louie-1.1.tar.gz 22306 RMD160 85b963990e49a07e2931855c947c0d337e69f3e0 SHA1 8d9df8fb3eab98064463d587da9e14ee29be3ad5 SHA256 75f33f2978e9a7ba1f541c594d8e93d0c4a965a706db688fd11a77f4049e5a5b
-EBUILD louie-1.1.ebuild 735 RMD160 ebef197e82c78a24a5ed3c85eed20e2bf9008c7d SHA1 ed857c1b74f92aaf01bc82cd001a5a0b84ddefbc SHA256 873a3f5e5a4c30e735291fb23be924dfcddaf6d8e6a5a97ee424e820f4b42903
-MISC ChangeLog 803 RMD160 f421d3747232b771fbdad27c620047c80e911315 SHA1 2bde03fa249b4349e1bf73bee0690cc48072c809 SHA256 6130b4253134f9e4a127f2226a6567d264cd54607c6f7309ec09cea69b501be7
+EBUILD louie-1.1.ebuild 779 RMD160 5b9a95410b2e042c14d10cc4bf8f9a6e0a9967d1 SHA1 e8ec3986dcfdceaca6f6a0cd607a325ed6676307 SHA256 db278c9207f242351b14257ec4dfe57a28a9208ccddf71241fe1352796d708a2
+MISC ChangeLog 991 RMD160 f27b8148ddcab89b4ceecd1fe6a733db3dc52dc2 SHA1 62d1f0175cbb9bc50aa2bf920b6726fe5ecae3b7 SHA256 7e4c2597264806387db1e0c95bc3907d28163ad37b553b287f7c5d7b3da1fbb4
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/louie/louie-1.1.ebuild b/dev-python/louie/louie-1.1.ebuild
index 4fa5814e73a3..bba3e19f1a1e 100644
--- a/dev-python/louie/louie-1.1.ebuild
+++ b/dev-python/louie/louie-1.1.ebuild
@@ -1,13 +1,22 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/louie/louie-1.1.ebuild,v 1.5 2010/10/15 14:19:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/louie/louie-1.1.ebuild,v 1.6 2010/10/30 20:56:46 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
-MY_P="Louie-${PV}"
+MY_PN="Louie"
+MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="Signal dispatching mechanism for Python"
-HOMEPAGE="http://pypi.python.org/pypi/Louie/"
-SRC_URI="http://cheeseshop.python.org/packages/source/L/Louie/${MY_P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/Louie"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
@@ -18,7 +27,7 @@ RDEPEND=""
S="${WORKDIR}/${MY_P}"
-# This has changed with upstream migrating to setuptools. No idea how to actually run them tests now ...
-#src_test() {
-# python selftest.py || die "selftest.py failed"
-#}
+src_prepare() {
+ distutils_src_prepare
+ sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"
+}