summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Farina <zerochaos@gentoo.org>2015-03-18 02:14:13 +0000
committerRichard Farina <zerochaos@gentoo.org>2015-03-18 02:14:13 +0000
commita35aeae58c0f925f4e438f322d2720c13b352f7d (patch)
tree556480d1b2c6c872257fad397caf203838308013 /dev-python/nltk/nltk-2.0.4.ebuild
parentAdd "-a" to egrep to force it print lines. #542534 (diff)
downloadhistorical-a35aeae58c0f925f4e438f322d2720c13b352f7d.tar.gz
historical-a35aeae58c0f925f4e438f322d2720c13b352f7d.tar.bz2
historical-a35aeae58c0f925f4e438f322d2720c13b352f7d.zip
fix bug #538056
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0xDD11F94A
Diffstat (limited to 'dev-python/nltk/nltk-2.0.4.ebuild')
-rw-r--r--dev-python/nltk/nltk-2.0.4.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/nltk/nltk-2.0.4.ebuild b/dev-python/nltk/nltk-2.0.4.ebuild
index cfb292eea2a5..74375c0a6977 100644
--- a/dev-python/nltk/nltk-2.0.4.ebuild
+++ b/dev-python/nltk/nltk-2.0.4.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.2 2014/12/22 10:17:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.3 2015/03/18 02:14:08 zerochaos Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="tk?,xml(+)"
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="Natural Language Toolkit"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -24,3 +24,8 @@ RDEPEND="${RDEPEND}
DEPEND="${RDEPEND}
app-arch/unzip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-newer-setuptools.patch
+ distutils-r1_src_prepare
+}