summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 21:19:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 21:19:03 +0000
commit4535e3f8db9dbad7b650f524c9d54ef5c615d5ef (patch)
tree0828d263ccaca617baf1ce833ca36f312a8fd8af /dev-python/numpy/files
parentVersion bump. Remove java5 useflag, and default to java5. (diff)
downloadhistorical-4535e3f8db9dbad7b650f524c9d54ef5c615d5ef.tar.gz
historical-4535e3f8db9dbad7b650f524c9d54ef5c615d5ef.tar.bz2
historical-4535e3f8db9dbad7b650f524c9d54ef5c615d5ef.zip
Delete older ebuilds.
Package-Manager: portage-14479-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/numpy/files')
-rw-r--r--dev-python/numpy/files/numpy-1.0.1-f2py.patch42
-rw-r--r--dev-python/numpy/files/numpy-1.0.4-cpuinfo.patch133
-rw-r--r--dev-python/numpy/files/numpy-1.0.4-freebsd.patch69
3 files changed, 0 insertions, 244 deletions
diff --git a/dev-python/numpy/files/numpy-1.0.1-f2py.patch b/dev-python/numpy/files/numpy-1.0.1-f2py.patch
deleted file mode 100644
index d64f1d647af2..000000000000
--- a/dev-python/numpy/files/numpy-1.0.1-f2py.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Nur numpy/f2py/f2py.1 numpy/f2py.new/f2py.1
---- numpy/f2py/f2py.1 2006-07-26 21:04:19.000000000 +0100
-+++ numpy/f2py.new/f2py.1 2007-02-14 12:16:47.000000000 +0000
-@@ -184,7 +184,7 @@
-
- Optional Numarray 0.9 or higher partially supported.
-
--numpy_distutils from Scipy (can be downloaded from F2PY homepage)
-+numpy_distutils from Numpy (can be downloaded from F2PY homepage)
- .SH "SEE ALSO"
- python(1)
- .SH BUGS
-@@ -200,10 +200,8 @@
-
- Mailing list: http://cens.ioc.ee/mailman/listinfo/f2py-users/
-
--Scipy website: http://www.numpy.org
-+Numpy website: http://numeric.numpy.org
- .SH COPYRIGHT
- Copyright (c) 1999, 2000, 2001, 2002, 2003, 2004, 2005 Pearu Peterson
- .SH LICENSE
- NumPy License
--.SH VERSION
--2.45.241
-diff -Nur numpy/f2py/setup.py numpy/f2py.new/setup.py
---- numpy/f2py/setup.py 2006-10-03 05:35:22.000000000 +0100
-+++ numpy/f2py.new/setup.py 2007-02-14 12:16:41.000000000 +0000
-@@ -35,13 +35,12 @@
-
- config.add_data_files('src/fortranobject.c',
- 'src/fortranobject.h',
-- 'f2py.1'
- )
-
- config.make_svn_version_py()
-
- def generate_f2py_py(build_dir):
-- f2py_exe = 'f2py'+os.path.basename(sys.executable)[6:]
-+ f2py_exe = 'f2py'
- if f2py_exe[-4:]=='.exe':
- f2py_exe = f2py_exe[:-4] + '.py'
- if 'bdist_wininst' in sys.argv and f2py_exe[-3:] != '.py':
diff --git a/dev-python/numpy/files/numpy-1.0.4-cpuinfo.patch b/dev-python/numpy/files/numpy-1.0.4-cpuinfo.patch
deleted file mode 100644
index f38b43038971..000000000000
--- a/dev-python/numpy/files/numpy-1.0.4-cpuinfo.patch
+++ /dev/null
@@ -1,133 +0,0 @@
---- numpy-1.0.4/numpy/distutils/cpuinfo.py 2007-11-07 23:05:15.000000000 +0100
-+++ numpy-1.0.4_changed/numpy/distutils/cpuinfo.py 2008-05-19 20:30:40.000000000 +0200
-@@ -18,6 +18,7 @@
- import os
- import commands
- import warnings
-+import platform
-
- def getoutput(cmd, successful_status=(0,), stacklevel=1):
- try:
-@@ -80,8 +81,16 @@
- def _getNCPUs(self):
- return 1
-
-+ def __get_nbits(self):
-+ abits = platform.architecture()[0]
-+ nbits = re.compile('(\d+)bit').search(abits).group(1)
-+ return nbits
-+
- def _is_32bit(self):
-- return not self.is_64bit()
-+ return self.__get_nbits() == '32'
-+
-+ def _is_64bit(self):
-+ return self.__get_nbits() == '64'
-
- class LinuxCPUInfo(CPUInfoBase):
-
-@@ -104,7 +113,7 @@
- if len(name_value) != 2:
- continue
- name, value = name_value
-- if not info or info[-1].has_key(name): # next processor
-+ if not info or name in info[-1]: # next processor
- info.append({})
- info[-1][name] = value
- fo.close()
-@@ -134,7 +143,16 @@
- self.info[0]['model name']) is not None
-
- def _is_AMD64(self):
-- return self.is_AMD() and self.info[0]['family'] == '15'
-+ if 'family' in self.info[0]:
-+ family=self.info[0]['family'] in ['15','16']
-+ else:
-+ family=False
-+ if 'cpu family' in self.info[0]:
-+ cpu_family=self.info[0]['cpu family']in ['15','16']
-+ else:
-+ cpu_family=False
-+ result=(self.is_AMD() and family) or cpu_family
-+ return result
-
- def _is_Athlon64(self):
- return re.match(r'.*?Athlon\(tm\) 64\b',
-@@ -152,6 +170,10 @@
- return re.match(r'.*?Hammer\b',
- self.info[0]['model name']) is not None
-
-+ def _is_Phenom(self):
-+ return re.match(r'.*?Phenom\b',
-+ self.info[0]['model name']) is not None
-+
- # Alpha
-
- def _is_Alpha(self):
-@@ -222,7 +244,11 @@
- return self.is_PentiumIV() and self.has_sse3()
-
- def _is_Nocona(self):
-- return self.is_64bit() and self.is_PentiumIV()
-+ return self.is_Intel() \
-+ and (self.info[0]['cpu family'] == '6' \
-+ or self.info[0]['cpu family'] == '15' ) \
-+ and (self.has_sse3() and not self.has_ssse3())\
-+ and re.match(r'.*?\blm\b',self.info[0]['flags']) is not None
-
- def _is_Core2(self):
- return self.is_64bit() and self.is_Intel() and \
-@@ -263,7 +289,10 @@
- return re.match(r'.*?\bsse2\b',self.info[0]['flags']) is not None
-
- def _has_sse3(self):
-- return re.match(r'.*?\bsse3\b',self.info[0]['flags']) is not None
-+ return re.match(r'.*?\bpni\b',self.info[0]['flags']) is not None
-+
-+ def _has_ssse3(self):
-+ return re.match(r'.*?\bssse3\b',self.info[0]['flags']) is not None
-
- def _has_3dnow(self):
- return re.match(r'.*?\b3dnow\b',self.info[0]['flags']) is not None
-@@ -271,20 +300,6 @@
- def _has_3dnowext(self):
- return re.match(r'.*?\b3dnowext\b',self.info[0]['flags']) is not None
-
-- def _is_64bit(self):
-- if self.is_Alpha():
-- return True
-- if self.info[0].get('clflush size','')=='64':
-- return True
-- if self.info[0].get('uname_m','')=='x86_64':
-- return True
-- if self.info[0].get('arch','')=='IA-64':
-- return True
-- return False
--
-- def _is_32bit(self):
-- return not self.is_64bit()
--
- class IRIXCPUInfo(CPUInfoBase):
- info = None
-
-@@ -412,11 +427,6 @@
-
- def _not_impl(self): pass
-
-- def _is_32bit(self):
-- return self.info['isainfo_b']=='32'
-- def _is_64bit(self):
-- return self.info['isainfo_b']=='64'
--
- def _is_i386(self):
- return self.info['isainfo_n']=='i386'
- def _is_sparc(self):
-@@ -552,7 +562,7 @@
- # require looking at the 'brand' from cpuid
-
- def _is_AMD64(self):
-- return self.is_AMD() and self.info[0]['Family'] == 15
-+ return self.is_AMD() and self.info[0]['Family'] in [15,16]
-
- # Intel
-
diff --git a/dev-python/numpy/files/numpy-1.0.4-freebsd.patch b/dev-python/numpy/files/numpy-1.0.4-freebsd.patch
deleted file mode 100644
index a0d86f13e8ec..000000000000
--- a/dev-python/numpy/files/numpy-1.0.4-freebsd.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-diff -Nur numpy-1.0.4.old/numpy/core/include/numpy/ufuncobject.h numpy-1.0.4/numpy/core/include/numpy/ufuncobject.h
---- numpy-1.0.4.old/numpy/core/include/numpy/ufuncobject.h 2007-11-07 15:05:15 -0700
-+++ numpy-1.0.4/numpy/core/include/numpy/ufuncobject.h 2007-11-20 18:10:46 -0700
-@@ -223,6 +223,10 @@
- /* This code checks the IEEE status flags in a platform-dependent way */
- /* Adapted from Numarray */
-
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- /* OSF/Alpha (Tru64) ---------------------------------------------*/
- #if defined(__osf__) && defined(__alpha)
-
-@@ -267,7 +271,7 @@
- /* Solaris --------------------------------------------------------*/
- /* --------ignoring SunOS ieee_flags approach, someone else can
- ** deal with that! */
--#elif defined(sun) || defined(__BSD__) || defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#elif defined(sun) || defined(__BSD__) || defined(__OpenBSD__) || (defined(__FreeBSD__) && (__FreeBSD_version < 502114)) || defined(__NetBSD__)
- #include <ieeefp.h>
-
- #define UFUNC_CHECK_STATUS(ret) { \
-@@ -281,9 +285,9 @@
- (void) fpsetsticky(0); \
- }
-
--#elif defined(__GLIBC__) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__)
-+#elif defined(__GLIBC__) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__) || (defined(__FreeBSD__) && (__FreeBSD_version >= 502114))
-
--#if defined(__GLIBC__) || defined(__APPLE__) || defined(__MINGW32__)
-+#if defined(__GLIBC__) || defined(__APPLE__) || defined(__MINGW32__) || defined(__FreeBSD__)
- #include <fenv.h>
- #elif defined(__CYGWIN__)
- #include "fenv/fenv.c"
-diff -Nur numpy-1.0.4.old/numpy/numarray/_capi.c numpy-1.0.4/numpy/numarray/_capi.c
---- numpy-1.0.4.old/numpy/numarray/_capi.c 2007-11-07 15:05:16 -0700
-+++ numpy-1.0.4/numpy/numarray/_capi.c 2007-11-20 18:05:20 -0700
-@@ -4,7 +4,11 @@
- #include "numpy/libnumarray.h"
- #include <float.h>
-
--#if defined(__GLIBC__) || defined(__APPLE__) || defined(__MINGW32__)
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
-+#if defined(__GLIBC__) || defined(__APPLE__) || defined(__MINGW32__) || (defined(__FreeBSD__) && (__FreeBSD_version >= 502114))
- #include <fenv.h>
- #elif defined(__CYGWIN__)
- #include "numpy/fenv/fenv.h"
-@@ -231,7 +235,7 @@
- }
-
- /* Likewise for Integer overflows */
--#if defined(__GLIBC__) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__)
-+#if defined(__GLIBC__) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__) || (defined(__FreeBSD__) && (__FreeBSD_version >= 502114))
- static int int_overflow_error(Float64 value) { /* For x86_64 */
- feraiseexcept(FE_OVERFLOW);
- return (int) value;
-@@ -2939,7 +2943,7 @@
- return retstatus;
- }
-
--#elif defined(__GLIBC__) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__)
-+#elif defined(__GLIBC__) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__) || (defined(__FreeBSD__) && (__FreeBSD_version >= 502114))
-
- static int
- NA_checkFPErrors(void)