summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-06-24 20:29:31 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-06-24 20:29:31 +0000
commit65b00380563bf279ebcf8069533fa4b89a0af5e5 (patch)
tree103ebd0a1eb7330e2c6a1da1f50747b09535e1e9 /dev-python/pykde/pykde-3.11.3.ebuild
parentusing consistent coding style (diff)
downloadhistorical-65b00380563bf279ebcf8069533fa4b89a0af5e5.tar.gz
historical-65b00380563bf279ebcf8069533fa4b89a0af5e5.tar.bz2
historical-65b00380563bf279ebcf8069533fa4b89a0af5e5.zip
Fixed $ROOT abuse (bug #167271) and some cleanup
Package-Manager: portage-2.1.3_rc5
Diffstat (limited to 'dev-python/pykde/pykde-3.11.3.ebuild')
-rw-r--r--dev-python/pykde/pykde-3.11.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/pykde/pykde-3.11.3.ebuild b/dev-python/pykde/pykde-3.11.3.ebuild
index b574341304d5..0eb8a5b69eb8 100644
--- a/dev-python/pykde/pykde-3.11.3.ebuild
+++ b/dev-python/pykde/pykde-3.11.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pykde/pykde-3.11.3.ebuild,v 1.5 2004/12/07 02:46:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pykde/pykde-3.11.3.ebuild,v 1.6 2007/06/24 20:29:31 dev-zero Exp $
inherit eutils distutils
@@ -18,7 +18,6 @@ KEYWORDS="x86 ~ppc"
IUSE="debug doc kjs"
RDEPEND="virtual/libc
- virtual/python
>=dev-python/sip-3.10.2
>=dev-python/PyQt-3.12
kde-base/kdelibs
@@ -40,11 +39,11 @@ src_compile() {
use kjs && myconf="${myconf} -m"
python configure.py ${myconf}
- emake || die
+ emake || die "emake failed"
}
src_install() {
- einstall DESTDIR=${D} || die
+ emake install DESTDIR="${D}" || die "emake install failed"
find ${D}/usr/share/sip -not -type d -not -iname *.sip -exec rm '{}' \;
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS
use doc && ( cp -r examples ${D}/usr/share/doc/${PF}