summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-14 18:42:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-14 18:42:52 +0000
commitaa0eb6bb19773825dd8a67a912c14388a4242045 (patch)
tree6be1c8549edf12424be8607837e104f4a63564dd /dev-python/pylint
parentsparc stable wrt #290112 (diff)
downloadhistorical-aa0eb6bb19773825dd8a67a912c14388a4242045.tar.gz
historical-aa0eb6bb19773825dd8a67a912c14388a4242045.tar.bz2
historical-aa0eb6bb19773825dd8a67a912c14388a4242045.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/files/pylint-0.10.0-extra-gtk-disable.patch10
-rw-r--r--dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch17
-rw-r--r--dev-python/pylint/files/pylint-0.13.1-test-fixes.patch39
-rw-r--r--dev-python/pylint/pylint-0.13.1.ebuild77
-rw-r--r--dev-python/pylint/pylint-0.18.0.ebuild82
5 files changed, 0 insertions, 225 deletions
diff --git a/dev-python/pylint/files/pylint-0.10.0-extra-gtk-disable.patch b/dev-python/pylint/files/pylint-0.10.0-extra-gtk-disable.patch
deleted file mode 100644
index 6ebcd93ace20..000000000000
--- a/dev-python/pylint/files/pylint-0.10.0-extra-gtk-disable.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-=== modified file 'test/regrtest_data/pygtk_import.py'
---- test/regrtest_data/pygtk_import.py
-+++ test/regrtest_data/pygtk_import.py
-@@ -1,4 +1,4 @@
--#pylint: disable-msg=R0903,R0904
-+#pylint: disable-msg=R0903,R0904,W0232
- """#10026"""
- __revision__ = 1
- from gtk import VBox
-
diff --git a/dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch b/dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch
deleted file mode 100644
index ac967247141f..000000000000
--- a/dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-=== modified file 'a/bin/pylint-gui' (properties changed)
---- a/bin/pylint-gui
-+++ b/bin/pylint-gui
-@@ -1,4 +1,12 @@
- #!/usr/bin/env python
- import sys
-+
-+try:
-+ import Tkinter
-+except ImportError:
-+ print 'Importing Tkinter failed. You probably have to enable the tcltk'
-+ print 'USE flag on python.'
-+ sys.exit(1)
-+
- from pylint import gui
- gui.Run(sys.argv[1:])
-
diff --git a/dev-python/pylint/files/pylint-0.13.1-test-fixes.patch b/dev-python/pylint/files/pylint-0.13.1-test-fixes.patch
deleted file mode 100644
index da5e3b9f311c..000000000000
--- a/dev-python/pylint/files/pylint-0.13.1-test-fixes.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-=== modified file '__pkginfo__.py'
---- __pkginfo__.py 2007-03-02 13:25:10 +0000
-+++ __pkginfo__.py 2007-03-02 13:26:27 +0000
-@@ -53,7 +53,7 @@
- for filename in ('pylint', 'pylint-gui', "symilar")]
-
- include_dirs = [join('test', 'input'), join('test', 'messages'),
-- join('test', 'regrtest_data')]
-+ join('test', 'regrtest_data'), join('test', 'rpythonmessages')]
-
- pyversions = ["2.3", "2.4"]
-
-
-=== modified file 'test/func_test_rpython.py'
---- test/func_test_rpython.py 2007-03-02 13:25:10 +0000
-+++ test/func_test_rpython.py 2007-03-02 21:46:27 +0000
-@@ -57,7 +57,7 @@
- # skip rpython checker messages
- missing = [msgid for msgid in linter._messages.keys()
- if msgid[1:3] == '12' and not msgid in test_reporter.message_ids]
-- self.assertEqual(missing, [])
-+ self.assertEqual(missing, ['W1201', 'E1205'])
-
- def make_tests(filter_rgx):
- """generate tests classes from test info
-
-=== modified file 'test/test_import_graph.py'
---- test/test_import_graph.py 2007-03-02 13:25:10 +0000
-+++ test/test_import_graph.py 2007-03-02 21:45:39 +0000
-@@ -47,7 +47,7 @@
- l.global_set_option('ext-import-graph', 'ext_import.dot')
- l.global_set_option('int-import-graph', 'int_import.dot')
- try:
-- l.check('input')
-+ l.check('pylint')
- self.assert_(exists('import.dot'))
- self.assert_(exists('ext_import.dot'))
- self.assert_(exists('int_import.dot'))
-
diff --git a/dev-python/pylint/pylint-0.13.1.ebuild b/dev-python/pylint/pylint-0.13.1.ebuild
deleted file mode 100644
index 314a338de70a..000000000000
--- a/dev-python/pylint/pylint-0.13.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.13.1.ebuild,v 1.9 2008/07/12 00:21:13 pythonhead Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding standard"
-SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/pylint/"
-
-IUSE="tk"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86"
-LICENSE="GPL-2"
-DEPEND=">=dev-python/logilab-common-0.21.0
- >=dev-python/astng-0.17.0
- tk? ( >=dev-lang/tk-8.4.9 )"
-
-DOCS="doc/*.txt"
-
-pkg_setup() {
- if use tk && ! built_with_use dev-lang/python tk; then
- eerror "You have USE='tk' enabled."
- eerror "Python has not been compiled with tkinter support."
- eerror "Please re-emerge python with the 'tk' USE-flag set."
- die "Missing USE-flag for dev-lang/python"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Make the test that tries to import gtk a bit less strict
- epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
-
- # Make pylint-gui print a gentoo-specific message if Tkinter is missing
- epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
-
- # Install the rpython test message data, skip a test.
- epatch "${FILESDIR}/${P}-test-fixes.patch"
-}
-
-src_install() {
- distutils_src_install
- # do not install the test suite (we ran it from src_test already
- # and it makes .py[co] generation very noisy because there are
- # files with SyntaxErrors in there)
- python_version
- rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
-
- doman man/pylint.1
- dohtml doc/*.html
-}
-
-src_test() {
- # The tests will not work properly from the source dir, so do a
- # temporary install:
- "${python}" setup.py install --home="${T}/test" || die "test copy failed"
- # dir needs to be this or the tests fail
- cd "${T}/test/lib/python/pylint/test"
-
- # These fail, have not been able to track down why.
- rm rpythoninput/func_unsupported_protocol.py || die "rm failed"
- rm func_test_rpython.py || die "rm failed"
- PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
- die "tests failed"
- cd "${S}"
- rm -rf "${T}/test"
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog 'A couple of important configuration settings (like "disable-msg")'
- elog 'moved from the "MASTER" to "MESSAGES CONTROL" section.'
- elog 'See "pylint --help".'
-}
diff --git a/dev-python/pylint/pylint-0.18.0.ebuild b/dev-python/pylint/pylint-0.18.0.ebuild
deleted file mode 100644
index 683df6828695..000000000000
--- a/dev-python/pylint/pylint-0.18.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.18.0.ebuild,v 1.3 2009/08/25 15:53:35 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils distutils python
-
-DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
-HOMEPAGE="http://www.logilab.org/projects/pylint/"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc examples html test tk"
-
-DEPEND=">=dev-python/logilab-common-0.38
- >=dev-python/astng-0.19.0"
-RDEPEND="${DEPEND}
- dev-lang/python[tk?]"
-
-RESTRICT_PYTHON_ABIS="3*"
-
-src_test() {
- testing() {
- local lpath="${T}/test/lib/python"
- local tpath=""
-
- rm -fr "${lpath}"
-
- # Create testdir and copy pylint into it for testing purpose.
- mkdir -p "${lpath}/logilab" || die
- PYTHONPATH="${lpath}" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${T}/test" || die "test copy failed"
-
- # To support test w/o setuptools.
- if [[ -d "${lpath}/${PN}" ]]; then
- tpath="${lpath}/${PN}"
- else
- tpath="${lpath}/${P}-py${PYTHON_ABI}.egg/${PN}"
- fi
-
- # Copy pylint unittest and logilab-{common,astng} into our temporary test
- # dir.
- cp -r test/ ${tpath} || die "copy tests failed"
- cp -r "$(python_get_sitedir)/logilab/"{common,astng} "${lpath}/logilab" || die "copying logilab-{common,astng} failed!"
-
- pushd "${tpath}" >/dev/null || die
- PYTHONPATH="${lpath}" pytest -v || die "tests failed"
- popd >/dev/null || die
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- doman man/{pylint,pyreverse}.1 || die "doman failed"
- dodoc doc/FAQ.txt || die "dodoc failed"
-
- if use doc; then
- dodoc doc/*.txt || die "dodoc failed"
- fi
-
- if use html; then
- dohtml doc/*.html || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-}
-
-pkg_postinst() {
- if ! built_with_use dev-lang/python tk; then
- ewarn "dev-lang/python has been built without tk support,"
- ewarn "${PN}-gui doesn't work without Tkinter so if you really need it"
- ewarn "re-install dev-lang/python with tk useflag enabled."
- fi
-}