summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2004-07-06 15:18:49 +0000
committerAnders Rune Jensen <arj@gentoo.org>2004-07-06 15:18:49 +0000
commit22615cf193ec6ddbcb370cfff46eabf8ac14232f (patch)
treed3a180e22fb7dd2fe3072deb58d033447ec6f56f /dev-python/pysqlite/pysqlite-0.5.1.ebuild
parentbump ebuild (diff)
downloadhistorical-22615cf193ec6ddbcb370cfff46eabf8ac14232f.tar.gz
historical-22615cf193ec6ddbcb370cfff46eabf8ac14232f.tar.bz2
historical-22615cf193ec6ddbcb370cfff46eabf8ac14232f.zip
new version
Diffstat (limited to 'dev-python/pysqlite/pysqlite-0.5.1.ebuild')
-rw-r--r--dev-python/pysqlite/pysqlite-0.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pysqlite/pysqlite-0.5.1.ebuild b/dev-python/pysqlite/pysqlite-0.5.1.ebuild
new file mode 100644
index 000000000000..768123478c07
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-0.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-0.5.1.ebuild,v 1.1 2004/07/06 15:18:49 arj Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="mirror://sourceforge/pysqlite/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://pysqlite.sourceforge.net/"
+
+KEYWORDS="~x86 ~alpha ~amd64"
+LICENSE="pysqlite"
+SLOT="0"
+
+DEPEND="virtual/python
+ dev-db/sqlite"
+
+src_unpack() {
+ unpack ${A}
+ # distutils expects to find setup.py in ${S}
+ mv ${WORKDIR}/pysqlite ${S}
+}
+
+src_install() {
+ distutils_src_install
+ # Need to do the examples explicitly since dodoc
+ # doesn't do directories properly
+ dodir /usr/share/doc/${PF}/examples || die
+ cp -r ${S}/examples/* ${D}/usr/share/doc/${PF}/examples || die
+}