summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-01-18 01:11:27 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-01-18 01:11:27 +0000
commit77e832238f7907c8306736c2f787f8d72cac517a (patch)
tree9ff4c548acd86f1a6532bca59ed1530fa389d618 /dev-python/sip
parentVersion bump (diff)
downloadhistorical-77e832238f7907c8306736c2f787f8d72cac517a.tar.gz
historical-77e832238f7907c8306736c2f787f8d72cac517a.tar.bz2
historical-77e832238f7907c8306736c2f787f8d72cac517a.zip
Version bump
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest4
-rw-r--r--dev-python/sip/files/digest-sip-3.101
-rw-r--r--dev-python/sip/sip-3.10.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index d0d8d64af3fd..813687864ab3 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,11 +1,11 @@
-MD5 c64a6a15132b0c4339afbc155288844f ChangeLog 2792
+MD5 bc59a12be07374627b63468fd2358ab5 ChangeLog 2792
MD5 811c07ba7510a315382249fc3adb44fc metadata.xml 175
MD5 1284a8182100df6f8028c1b0a9a3e7e1 sip-3.5.ebuild 1144
MD5 ec49578a524ed7e000d2426ec8ce5a53 sip-3.8.ebuild 1146
MD5 8f7a382122fe77c74b22776c280d97e0 sip-3.9.ebuild 1144
MD5 0417bc97bae45238a7ab12d6ba8fd4e6 sip-4.0_rc1.ebuild 1184
MD5 b64a43e852cd66ab363b8dc9ecaf508e sip-4.0_rc2.ebuild 1200
-MD5 6a127902110f929bb99aebf0ddc9f526 sip-3.10.ebuild 1154
+MD5 c792c56951d980d7a24d651eccd7e9b2 sip-3.10.ebuild 1160
MD5 c831f241fb8226cef9609e2afabe95f6 files/digest-sip-3.10 60
MD5 02beeecfef8cd92555d0a20b8d331fa6 files/digest-sip-3.5 67
MD5 821af86e779d5bc5b3457336a0426fa1 files/digest-sip-3.8 67
diff --git a/dev-python/sip/files/digest-sip-3.10 b/dev-python/sip/files/digest-sip-3.10
new file mode 100644
index 000000000000..3c67da517b52
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-3.10
@@ -0,0 +1 @@
+MD5 d202d2d7f55f139529860dcd43c1b723 sip-3.10.tar.gz 222620
diff --git a/dev-python/sip/sip-3.10.ebuild b/dev-python/sip/sip-3.10.ebuild
new file mode 100644
index 000000000000..5d7c2d3c85a6
--- /dev/null
+++ b/dev-python/sip/sip-3.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.10.ebuild,v 1.1 2004/01/18 01:11:20 pythonhead Exp $
+
+IUSE=""
+
+inherit eutils distutils
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ x11-libs/qt
+ >=dev-lang/python-2.2.1"
+
+src_compile(){
+ distutils_python_version
+ dodir /usr/bin
+ dodir /usr/lib/python${PYVER}/site-packages
+ python configure.py -l qt-mt \
+ -b ${D}usr/bin \
+ -d ${D}usr/lib/python${PYVER}/site-packages \
+ -e ${D}usr/include/python${PYVER} \
+ "CXXFLAGS+=${CXXFLAGS}"
+ make || die
+}
+
+src_install() {
+ distutils_python_version
+ dodir /usr/include/python${PYVER}
+ make install || die
+ echo "/${D//\//\\/}/s//\//" > fixpaths.sed
+ sed -i -f fixpaths.sed ${D}usr/lib/python${PYVER}/site-packages/sipconfig.py
+ dodoc ChangeLog LICENS NEWS README THANKS TODO
+}