summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-02-11 10:54:51 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-02-11 10:54:51 +0000
commit4edc118277d2b942fd8548f01f4c82f495ac6dc1 (patch)
treed3ded217057436d088916d76d2528456aac88a60 /dev-python/webpy
parentsane-backends 1.0.19 is out. (diff)
downloadhistorical-4edc118277d2b942fd8548f01f4c82f495ac6dc1.tar.gz
historical-4edc118277d2b942fd8548f01f4c82f495ac6dc1.tar.bz2
historical-4edc118277d2b942fd8548f01f4c82f495ac6dc1.zip
Added webpy-0.23 to the tree.
Package-Manager: portage-2.1.4_rc7
Diffstat (limited to 'dev-python/webpy')
-rw-r--r--dev-python/webpy/ChangeLog9
-rw-r--r--dev-python/webpy/webpy-0.23.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/webpy/ChangeLog b/dev-python/webpy/ChangeLog
index d30b06cba441..13cd86732c0a 100644
--- a/dev-python/webpy/ChangeLog
+++ b/dev-python/webpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webpy
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.3 2007/12/20 14:30:04 wrobel Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.4 2008/02/11 10:54:51 wrobel Exp $
+
+*webpy-0.23 (11 Feb 2008)
+
+ 11 Feb 2008; Gunnar Wrobel <wrobel@gentoo.org> +webpy-0.23.ebuild:
+ Added webpy-0.23 to the tree.
20 Dec 2007; Gunnar Wrobel <wrobel@gentoo.org> ChangeLog:
Added webpy-0.22 to the tree (#196487).
diff --git a/dev-python/webpy/webpy-0.23.ebuild b/dev-python/webpy/webpy-0.23.ebuild
new file mode 100644
index 000000000000..7ff2ce8ec098
--- /dev/null
+++ b/dev-python/webpy/webpy-0.23.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.23.ebuild,v 1.1 2008/02/11 10:54:51 wrobel Exp $
+
+inherit distutils
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for python"
+HOMEPAGE="http://www.webpy.org"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+PYTHON_MODNAME="web"
+
+src_test() {
+ TESTS="db template net http utils"
+
+ cd "${S}"
+
+ for TEST in ${TESTS}
+ do
+ ${python} web/${TEST}.py || die "Doctest in web/${TEST}.py failed!"
+ done
+}