summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-12-16 20:26:41 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-12-16 20:26:41 +0000
commit6e3b564505a7efb9ca10fedb1e4abc728cdffedb (patch)
treec986f70cd941e265709d550c2a2b73746eeffbec /dev-python
parentDoing libtoolize. (diff)
downloadhistorical-6e3b564505a7efb9ca10fedb1e4abc728cdffedb.tar.gz
historical-6e3b564505a7efb9ca10fedb1e4abc728cdffedb.tar.bz2
historical-6e3b564505a7efb9ca10fedb1e4abc728cdffedb.zip
Changing ownership to livecd herd, bumping to version 1.6.9, and closing bug #67312.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyparted/ChangeLog9
-rw-r--r--dev-python/pyparted/Manifest6
-rw-r--r--dev-python/pyparted/files/digest-pyparted-1.6.91
-rw-r--r--dev-python/pyparted/metadata.xml2
-rw-r--r--dev-python/pyparted/pyparted-1.6.9.ebuild37
5 files changed, 51 insertions, 4 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index e9cee896a42f..bd1c02f714ef 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyparted
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.4 2004/06/25 01:42:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.5 2004/12/16 20:26:41 wolf31o2 Exp $
+
+*pyparted-1.6.9 (16 Dec 2004)
+
+ 16 Dec 2004; Chris Gianelloni <wolf31o2@gentoo.org> metadata.xml,
+ +pyparted-1.6.9.ebuild:
+ Changing ownership to livecd herd, bumping to version 1.6.9, and closing bug
+ #67312.
08 May 2004; Bryan Østergaard <kloeri@gentoo.org> pyparted-1.6.6.ebuild:
Remove default S and RDEPEND.
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
index b5c8ba6a6b7e..d4efd59c69b6 100644
--- a/dev-python/pyparted/Manifest
+++ b/dev-python/pyparted/Manifest
@@ -1,4 +1,6 @@
+MD5 a77e4ae4cc7dbed13508fb046a499718 pyparted-1.6.9.ebuild 874
MD5 3ae0a32ebd7c6480093c3e4a907e311d pyparted-1.6.6.ebuild 874
-MD5 8ad7ab69540ef9cc9ff55edbc7674348 ChangeLog 541
-MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 7ed59d04bb8c1d5e63177c99f3b9eb2c ChangeLog 756
+MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
MD5 1c3b5c95a85ac9c079423549c7922a84 files/digest-pyparted-1.6.6 69
+MD5 d0b426a010ec790060151f6c56b4aaa6 files/digest-pyparted-1.6.9 69
diff --git a/dev-python/pyparted/files/digest-pyparted-1.6.9 b/dev-python/pyparted/files/digest-pyparted-1.6.9
new file mode 100644
index 000000000000..f743baea7396
--- /dev/null
+++ b/dev-python/pyparted/files/digest-pyparted-1.6.9
@@ -0,0 +1 @@
+MD5 acf3b9f9db016502630f8640ff5fef78 pyparted-1.6.9-2.src.rpm 302265
diff --git a/dev-python/pyparted/metadata.xml b/dev-python/pyparted/metadata.xml
index de483c53568f..88653ddd7172 100644
--- a/dev-python/pyparted/metadata.xml
+++ b/dev-python/pyparted/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
+<herd>livecd</herd>
</pkgmetadata>
diff --git a/dev-python/pyparted/pyparted-1.6.9.ebuild b/dev-python/pyparted/pyparted-1.6.9.ebuild
new file mode 100644
index 000000000000..30602cfda17b
--- /dev/null
+++ b/dev-python/pyparted/pyparted-1.6.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9.ebuild,v 1.1 2004/12/16 20:26:41 wolf31o2 Exp $
+
+RH_EXTRAVERSION="2"
+
+inherit eutils rpm
+
+DESCRIPTION="Python bindings for parted"
+HOMEPAGE="http://fedora.redhat.com"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/${P}-${RH_EXTRAVERSION}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -*"
+IUSE=""
+
+# Needed to build...
+DEPEND=">=sys-apps/parted-1.6.9"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_compile() {
+ cd ${S}
+
+ # This is needed otherwise it won't build
+ # If anyone wants to figure out why... go ahead!
+ export LDFLAGS="-ldl"
+ econf || die
+ emake || die
+}
+
+src_install () {
+ einstall || die "Install failed!"
+ dodoc AUTHORS COPYING README ChangeLog
+}