summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 18:12:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 18:12:04 +0000
commit8292af3b3ec7540d7f9465633d3252ac12cc05ee (patch)
tree9d0d3ab1c4819e23f69f268f6db3818dd0a4335d /dev-python
parentalpha/arm/ia64/sparc stable wrt #348987 (diff)
downloadhistorical-8292af3b3ec7540d7f9465633d3252ac12cc05ee.tar.gz
historical-8292af3b3ec7540d7f9465633d3252ac12cc05ee.tar.bz2
historical-8292af3b3ec7540d7f9465633d3252ac12cc05ee.zip
Fix dependencies.
Package-Manager: portage-2.2.0_alpha19_p24/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apptools/apptools-3.4.1.ebuild6
-rw-r--r--dev-python/enable/enable-3.4.0.ebuild4
-rw-r--r--dev-python/envisagecore/envisagecore-3.2.0.ebuild4
-rw-r--r--dev-python/envisageplugins/envisageplugins-3.2.0.ebuild4
-rw-r--r--dev-python/traitsgui/traitsgui-3.6.0.ebuild8
5 files changed, 13 insertions, 13 deletions
diff --git a/dev-python/apptools/apptools-3.4.1.ebuild b/dev-python/apptools/apptools-3.4.1.ebuild
index 19fa511f12ec..6c5593aa851b 100644
--- a/dev-python/apptools/apptools-3.4.1.ebuild
+++ b/dev-python/apptools/apptools-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/apptools-3.4.1.ebuild,v 1.1 2011/01/30 17:38:22 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/apptools-3.4.1.ebuild,v 1.2 2011/01/30 18:05:48 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -25,9 +25,9 @@ IUSE="doc examples test"
RDEPEND="dev-python/configobj
>=dev-python/enthoughtbase-3.1.0
dev-python/numpy
+ dev-python/setuptools
>=dev-python/traitsgui-3.6.0"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
+DEPEND="doc? ( dev-python/sphinx )
test? (
dev-python/coverage
dev-python/nose
diff --git a/dev-python/enable/enable-3.4.0.ebuild b/dev-python/enable/enable-3.4.0.ebuild
index a25e04780bbe..4dc7f2fea84a 100644
--- a/dev-python/enable/enable-3.4.0.ebuild
+++ b/dev-python/enable/enable-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.4.0.ebuild,v 1.1 2011/01/30 17:02:25 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.4.0.ebuild,v 1.2 2011/01/30 18:07:12 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -25,6 +25,7 @@ IUSE="doc examples test"
RDEPEND=">=dev-python/enthoughtbase-3.1.0
dev-python/numpy
dev-python/reportlab
+ dev-python/setuptools
>=dev-python/traitsgui-3.6.0[wxwidgets]
>=media-libs/freetype-2
virtual/opengl
@@ -32,7 +33,6 @@ RDEPEND=">=dev-python/enthoughtbase-3.1.0
DEPEND="${RDEPEND}
dev-lang/swig
dev-python/cython
- dev-python/setuptools
doc? ( dev-python/sphinx )
test? (
dev-python/coverage
diff --git a/dev-python/envisagecore/envisagecore-3.2.0.ebuild b/dev-python/envisagecore/envisagecore-3.2.0.ebuild
index 19cf72a7ad78..29ab20824572 100644
--- a/dev-python/envisagecore/envisagecore-3.2.0.ebuild
+++ b/dev-python/envisagecore/envisagecore-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/envisagecore/envisagecore-3.2.0.ebuild,v 1.1 2011/01/30 17:56:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisagecore/envisagecore-3.2.0.ebuild,v 1.2 2011/01/30 18:02:55 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -24,9 +24,9 @@ IUSE="doc examples test"
RDEPEND=">=dev-python/apptools-3.4.1
>=dev-python/enthoughtbase-3.1.0
+ dev-python/setuptools
>=dev-python/traits-3.6.0"
DEPEND="${RDEPEND}
- dev-python/setuptools
doc? ( dev-python/sphinx )
test? (
dev-python/coverage
diff --git a/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild b/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild
index d309e7a98027..f7e96543af87 100644
--- a/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild
+++ b/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild,v 1.1 2011/01/30 17:58:55 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild,v 1.2 2011/01/30 18:04:11 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -23,9 +23,9 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples test"
RDEPEND=">=dev-python/envisagecore-3.2.0
+ dev-python/setuptools
>=dev-python/traitsgui-3.6.0"
DEPEND="${RDEPEND}
- dev-python/setuptools
test? (
dev-python/coverage
dev-python/nose
diff --git a/dev-python/traitsgui/traitsgui-3.6.0.ebuild b/dev-python/traitsgui/traitsgui-3.6.0.ebuild
index 816f01d7da93..8b8ce56091c0 100644
--- a/dev-python/traitsgui/traitsgui-3.6.0.ebuild
+++ b/dev-python/traitsgui/traitsgui-3.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/traitsgui-3.6.0.ebuild,v 1.2 2011/01/30 14:58:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/traitsgui-3.6.0.ebuild,v 1.3 2011/01/30 18:12:04 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -21,13 +21,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc examples qt4 wxwidgets"
-RDEPEND=">=dev-python/enthoughtbase-3.1.0
+DEPEND=">=dev-python/enthoughtbase-3.1.0
+ dev-python/setuptools
>=dev-python/traits-${PV}
qt4? ( >=dev-python/traitsbackendqt-${PV} )
wxwidgets? ( >=dev-python/traitsbackendwx-${PV} )
!wxwidgets? ( !qt4? ( >=dev-python/traitsbackendwx-${PV} ) )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"