summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-09-27 18:17:04 +0000
committerMarien Zwart <marienz@gentoo.org>2012-09-27 18:17:04 +0000
commitcbf7e5b262411a1ef259576bdbedbe25dc8ab0b2 (patch)
tree6d7a88dcc5fe8dae03f323f3800a845f75e07044 /dev-python
parentBump to 12.2.0 (bug #423777) with some test-related ebuild improvements. (diff)
downloadhistorical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.tar.gz
historical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.tar.bz2
historical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.zip
Bump to 12.2.0 (bug #423789)
Package-Manager: portage-2.2.0_alpha133/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted-conch/ChangeLog8
-rw-r--r--dev-python/twisted-conch/twisted-conch-12.2.0.ebuild33
-rw-r--r--dev-python/twisted-lore/ChangeLog8
-rw-r--r--dev-python/twisted-lore/twisted-lore-12.2.0.ebuild22
-rw-r--r--dev-python/twisted-mail/ChangeLog8
-rw-r--r--dev-python/twisted-mail/twisted-mail-12.2.0.ebuild22
-rw-r--r--dev-python/twisted-names/ChangeLog8
-rw-r--r--dev-python/twisted-names/twisted-names-12.2.0.ebuild21
-rw-r--r--dev-python/twisted-news/ChangeLog8
-rw-r--r--dev-python/twisted-news/twisted-news-12.2.0.ebuild22
10 files changed, 150 insertions, 10 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
index 332bb04fbe41..1a51e8eb03b9 100644
--- a/dev-python/twisted-conch/ChangeLog
+++ b/dev-python/twisted-conch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-conch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.80 2012/03/22 07:04:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.81 2012/09/27 18:15:49 marienz Exp $
+
+*twisted-conch-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-conch-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-conch-12.0.0 (22 Mar 2012)
@@ -322,4 +327,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-conch-0.5.0:
initial import
twisted-conch was part of the main twisted release
-
diff --git a/dev-python/twisted-conch/twisted-conch-12.2.0.ebuild b/dev-python/twisted-conch/twisted-conch-12.2.0.ebuild
new file mode 100644
index 000000000000..c79f0498ad9e
--- /dev/null
+++ b/dev-python/twisted-conch/twisted-conch-12.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-12.2.0.ebuild,v 1.1 2012/09/27 18:15:49 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+MY_PACKAGE="Conch"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted SSHv2 implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ dev-python/pyasn1
+ dev-python/pycrypto"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/conch twisted/plugins"
+
+src_prepare() {
+ distutils_src_prepare
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_checkKeyAsRoot/_&/" -i twisted/conch/test/test_checkers.py
+ sed -e "s/test_getPrivateKeysAsRoot/_&/" -i twisted/conch/test/test_openssh_compat.py
+ fi
+}
diff --git a/dev-python/twisted-lore/ChangeLog b/dev-python/twisted-lore/ChangeLog
index b5be737773d1..14365f003659 100644
--- a/dev-python/twisted-lore/ChangeLog
+++ b/dev-python/twisted-lore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-lore
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.57 2012/03/22 07:04:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.58 2012/09/27 18:16:07 marienz Exp $
+
+*twisted-lore-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-lore-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-lore-12.0.0 (22 Mar 2012)
@@ -233,4 +238,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-lore-0.1.0:
initial import
twisted-lore was part of the main twisted release
-
diff --git a/dev-python/twisted-lore/twisted-lore-12.2.0.ebuild b/dev-python/twisted-lore/twisted-lore-12.2.0.ebuild
new file mode 100644
index 000000000000..9a44972e0371
--- /dev/null
+++ b/dev-python/twisted-lore/twisted-lore-12.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-12.2.0.ebuild,v 1.1 2012/09/27 18:16:07 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Lore"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted documentation system"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ =dev-python/twisted-web-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/lore twisted/plugins"
diff --git a/dev-python/twisted-mail/ChangeLog b/dev-python/twisted-mail/ChangeLog
index c4df20eaabee..ac86b26769ca 100644
--- a/dev-python/twisted-mail/ChangeLog
+++ b/dev-python/twisted-mail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-mail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.68 2012/03/22 07:05:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.69 2012/09/27 18:16:26 marienz Exp $
+
+*twisted-mail-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-mail-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-mail-12.0.0 (22 Mar 2012)
@@ -267,4 +272,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-mail-0.5.0:
initial import
twisted-mail was part of the main twisted release
-
diff --git a/dev-python/twisted-mail/twisted-mail-12.2.0.ebuild b/dev-python/twisted-mail/twisted-mail-12.2.0.ebuild
new file mode 100644
index 000000000000..8a15b18e4d82
--- /dev/null
+++ b/dev-python/twisted-mail/twisted-mail-12.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-12.2.0.ebuild,v 1.1 2012/09/27 18:16:26 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Mail"
+
+inherit twisted versionator
+
+DESCRIPTION="A Twisted Mail library, server and client"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ =dev-python/twisted-names-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/mail twisted/plugins"
diff --git a/dev-python/twisted-names/ChangeLog b/dev-python/twisted-names/ChangeLog
index 71a170f6f7a8..48dad4f9114b 100644
--- a/dev-python/twisted-names/ChangeLog
+++ b/dev-python/twisted-names/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-names
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.66 2012/03/22 07:06:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.67 2012/09/27 18:16:45 marienz Exp $
+
+*twisted-names-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-names-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-names-12.0.0 (22 Mar 2012)
@@ -263,4 +268,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-names-0.1.0:
initial import
twisted-names was part of the main twisted release
-
diff --git a/dev-python/twisted-names/twisted-names-12.2.0.ebuild b/dev-python/twisted-names/twisted-names-12.2.0.ebuild
new file mode 100644
index 000000000000..bd5dfd898203
--- /dev/null
+++ b/dev-python/twisted-names/twisted-names-12.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-12.2.0.ebuild,v 1.1 2012/09/27 18:16:45 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Names"
+
+inherit twisted versionator
+
+DESCRIPTION="A Twisted DNS implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/names twisted/plugins"
diff --git a/dev-python/twisted-news/ChangeLog b/dev-python/twisted-news/ChangeLog
index 30570a1bc614..fb42a82d50a6 100644
--- a/dev-python/twisted-news/ChangeLog
+++ b/dev-python/twisted-news/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-news
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.55 2012/03/22 07:06:57 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.56 2012/09/27 18:17:04 marienz Exp $
+
+*twisted-news-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-news-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-news-12.0.0 (22 Mar 2012)
@@ -217,4 +222,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-news-0.1.0:
initial import
twisted-news was part of the main twisted release
-
diff --git a/dev-python/twisted-news/twisted-news-12.2.0.ebuild b/dev-python/twisted-news/twisted-news-12.2.0.ebuild
new file mode 100644
index 000000000000..8f753ff9b090
--- /dev/null
+++ b/dev-python/twisted-news/twisted-news-12.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-12.2.0.ebuild,v 1.1 2012/09/27 18:17:04 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="News"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted News is an NNTP server and programming library."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ =dev-python/twisted-mail-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/news twisted/plugins"