summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-28 08:20:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-28 08:20:24 +0000
commit1b5862659a584d73d3c7e37faea07b9f593b8df7 (patch)
tree325c69923b0d579b0959d79320de733f62832ed0 /dev-ruby/activerecord
parentVersion bump for Rails 3.0.16, bug 428254. (diff)
downloadhistorical-1b5862659a584d73d3c7e37faea07b9f593b8df7.tar.gz
historical-1b5862659a584d73d3c7e37faea07b9f593b8df7.tar.bz2
historical-1b5862659a584d73d3c7e37faea07b9f593b8df7.zip
Version bump for Rails 3.0.16, bug 428254.
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.16.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 33e34f50e31f..0c475abf2f89 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.191 2012/07/28 07:40:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.192 2012/07/28 08:19:34 graaff Exp $
+
+*activerecord-3.0.16 (28 Jul 2012)
+
+ 28 Jul 2012; Hans de Graaff <graaff@gentoo.org> +activerecord-3.0.16.ebuild:
+ Version bump for Rails 3.0.16, bug 428254.
*activerecord-3.1.7 (28 Jul 2012)
diff --git a/dev-ruby/activerecord/activerecord-3.0.16.ebuild b/dev-ruby/activerecord/activerecord-3.0.16.ebuild
new file mode 100644
index 000000000000..2f8912661d88
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.16.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.16.ebuild,v 1.1 2012/07/28 08:19:34 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.10-r1:2.0
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
+ mysql? ( dev-ruby/mysql2:0.2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.10.5
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+# sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\)/d' ../Gemfile || die
+# sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+# sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e '/\(system_timer\|horo\|faker\|rbench\|ruby-debug\|pg\)/d' ../Gemfile || die
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' ../actionpack/actionpack.gemspec || die
+
+ # Loosen mocha version restriction and skip incompatible tests
+ sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
+ rm test/cases/autosave_association_test.rb || die
+
+ # Avoid tests depending on hash ordering
+ sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}