summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-27 18:19:13 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-27 18:19:13 +0000
commitb252b6fa9d2e6b1dc0e19f76185ae205079994d4 (patch)
tree894f429f5efb50e3fb1f2f87488ba62daa23b42f /dev-ruby/activerecord
parentDrop alpha keywords (diff)
downloadhistorical-b252b6fa9d2e6b1dc0e19f76185ae205079994d4.tar.gz
historical-b252b6fa9d2e6b1dc0e19f76185ae205079994d4.tar.bz2
historical-b252b6fa9d2e6b1dc0e19f76185ae205079994d4.zip
Remove vulnerable versions.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog6
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.16.ebuild74
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.7.ebuild73
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.7.ebuild74
4 files changed, 5 insertions, 222 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index c78965e4cc3f..8424d1eb832f 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.196 2012/08/16 03:50:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.197 2012/08/27 18:16:50 graaff Exp $
+
+ 27 Aug 2012; Hans de Graaff <graaff@gentoo.org> -activerecord-3.0.16.ebuild,
+ -activerecord-3.1.7.ebuild, -activerecord-3.2.7.ebuild:
+ Remove vulnerable versions.
16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
activerecord-2.3.14.ebuild, activerecord-3.0.16.ebuild,
diff --git a/dev-ruby/activerecord/activerecord-3.0.16.ebuild b/dev-ruby/activerecord/activerecord-3.0.16.ebuild
deleted file mode 100644
index 37d4af6115ff..000000000000
--- a/dev-ruby/activerecord/activerecord-3.0.16.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.16.ebuild,v 1.2 2012/08/16 03:50:41 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.0.10-r1:2.0
- >=dev-ruby/tzinfo-0.3.23
- sqlite3? ( >=dev-ruby/sqlite3-1.3.3 )
- mysql? ( dev-ruby/mysql2:0.2 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.3
- >=dev-ruby/mocha-0.10.5
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
-# sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\)/d' ../Gemfile || die
-# sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
-# sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
- sed -i -e '/\(system_timer\|horo\|faker\|rbench\|ruby-debug\|pg\)/d' ../Gemfile || die
-
- # Loosen erubis dependency since this is not slotted.
- sed -i -e 's/~> 2.6.6/>= 2.6.6/' ../actionpack/actionpack.gemspec || die
-
- # Loosen mocha version restriction and skip incompatible tests
- sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
- rm test/cases/autosave_association_test.rb || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.1.7.ebuild b/dev-ruby/activerecord/activerecord-3.1.7.ebuild
deleted file mode 100644
index 871119d4c522..000000000000
--- a/dev-ruby/activerecord/activerecord-3.1.7.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.7.ebuild,v 1.2 2012/08/16 03:50:41 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.2.3:2.1
- >=dev-ruby/tzinfo-0.3.29
- sqlite3? ( >=dev-ruby/sqlite3-1.3.4 )
- mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.3
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\)/d' ../Gemfile || die
- sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
- sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
-
- # Loosen mocha version restriction and skip incompatible tests
- sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
- sed -i -e '/test_a_child_marked_for_destruction_should_not_be_destroyed_twice/,/^ end/ s:^:#:' test/cases/autosave_association_test.rb || die
- sed -i -e '/test_a_parent_marked_for_destruction_should_not_be_destroyed_twice/,/^ end/ s:^:#:' test/cases/autosave_association_test.rb || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.2.7.ebuild b/dev-ruby/activerecord/activerecord-3.2.7.ebuild
deleted file mode 100644
index 8e43e86171b5..000000000000
--- a/dev-ruby/activerecord/activerecord-3.2.7.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.7.ebuild,v 1.2 2012/08/16 03:50:41 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-3.0.2:3.0
- >=dev-ruby/tzinfo-0.3.29
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- >=dev-ruby/mocha-0.12.1
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *rubyee18)
- # Turn on travis support to avoid tripping bugs in ree18.
- TRAVIS=true ${RUBY} -S rake test_sqlite3
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}