summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-26 22:52:32 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-26 22:52:32 +0000
commitd9f5ab40160282d7039cdd77b09cd81c5f336461 (patch)
treeb7508ac7554d43c2786c1a8405585a2614c9b071 /dev-ruby/dbd-pg
parentGiving die a meaningful message, ignoring not installed ruby versions when te... (diff)
downloadhistorical-d9f5ab40160282d7039cdd77b09cd81c5f336461.tar.gz
historical-d9f5ab40160282d7039cdd77b09cd81c5f336461.tar.bz2
historical-d9f5ab40160282d7039cdd77b09cd81c5f336461.zip
Initial import, ebuild by /me.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/dbd-pg')
-rw-r--r--dev-ruby/dbd-pg/ChangeLog10
-rw-r--r--dev-ruby/dbd-pg/Manifest14
-rw-r--r--dev-ruby/dbd-pg/dbd-pg-0.3.8.ebuild38
-rw-r--r--dev-ruby/dbd-pg/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/dbd-pg/ChangeLog b/dev-ruby/dbd-pg/ChangeLog
new file mode 100644
index 000000000000..9ef0f32529b1
--- /dev/null
+++ b/dev-ruby/dbd-pg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/dbd-pg
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-pg/ChangeLog,v 1.1 2009/08/26 22:52:32 a3li Exp $
+
+*dbd-pg-0.3.8 (26 Aug 2009)
+
+ 26 Aug 2009; Alex Legler <a3li@gentoo.org> +dbd-pg-0.3.8.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by /me.
+
diff --git a/dev-ruby/dbd-pg/Manifest b/dev-ruby/dbd-pg/Manifest
new file mode 100644
index 000000000000..52eecc2374d8
--- /dev/null
+++ b/dev-ruby/dbd-pg/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST dbd-pg-0.3.8.tar.gz 64753 RMD160 51e72b6deceee9377451ee53052704da7306be87 SHA1 2e24ee496672078dc1a25a51578c8a8be772ba91 SHA256 720fc92be3191059de3eef85321c80b5d0978c97167ed7612aacebefed02b171
+EBUILD dbd-pg-0.3.8.ebuild 993 RMD160 f77fe41eb5fc99ceb3ea9508738754b1e37dfdae SHA1 7bc8532be0761098681821c059ed35797e85caa6 SHA256 a963e09054878524e70faa5eb604e7842e35af322caf00da4b9b364f9158ab14
+MISC ChangeLog 348 RMD160 d479cd21ddd9b4f0ee871299dab8a25173adc780 SHA1 5745d94d284af829c02bdf93370658fc78bc5960 SHA256 d8b68e1beff9300094efcb143c88c59f7e9f716d52aeb4300b35d8fd1b21a70c
+MISC metadata.xml 158 RMD160 097f8145a9994f98be4971b43b23b9e5e8bccb66 SHA1 7ac646714b1ab83fda98f3ccdd8b48a31c148b27 SHA256 70b396ab3c7a63a81cb895b7728bd9eccdc9770afdb9919f2c54694b685f7032
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkqVvJUACgkQaGsKqSU7eCT7WwCeOd7n994TTLb5l6zdgjiHwcMc
+AHwAoLKSQu1oPWvf1hmHHOuAt8OWAegp
+=HrAw
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/dbd-pg/dbd-pg-0.3.8.ebuild b/dev-ruby/dbd-pg/dbd-pg-0.3.8.ebuild
new file mode 100644
index 000000000000..350881e037ee
--- /dev/null
+++ b/dev-ruby/dbd-pg/dbd-pg-0.3.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-pg/dbd-pg-0.3.8.ebuild,v 1.1 2009/08/26 22:52:32 a3li Exp $
+
+inherit "ruby"
+
+DESCRIPTION="The PostgreSQL database driver (DBD) for Ruby/DBI"
+HOMEPAGE="http://ruby-dbi.rubyforge.org"
+SRC_URI="mirror://rubyforge/ruby-dbi/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="virtual/ruby"
+RDEPEND="${DEPEND}
+ >=dev-ruby/ruby-dbi-0.4.2
+ >=dev-ruby/ruby-postgres-0.7.9.20080128"
+
+# ruby-postgres is not yet ruby19
+USE_RUBY="ruby18"
+
+src_test() {
+ elog "The tests require additional configuration."
+ elog "You will find them in /usr/share/${PN}/test/"
+ elog "Be sure to read the file called DBD_TESTS."
+}
+
+src_install() {
+ ruby setup.rb install \
+ --prefix="${D}" || die "setup.rb install failed"
+
+ if use test; then
+ dodir /usr/share/${PN}
+ cp -pPR test "${D}/usr/share/${PN}" || die "couldn't copy tests"
+ fi
+}
diff --git a/dev-ruby/dbd-pg/metadata.xml b/dev-ruby/dbd-pg/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/dbd-pg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>