summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-07 06:18:29 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-07 06:18:29 +0000
commitbfa620c5ed342a758b34c089f2dc2819541f48ec (patch)
treec53997f851394ff40db8325d445083efee37d32a /dev-ruby/fast_gettext
parentRemove old version. (diff)
downloadhistorical-bfa620c5ed342a758b34c089f2dc2819541f48ec.tar.gz
historical-bfa620c5ed342a758b34c089f2dc2819541f48ec.tar.bz2
historical-bfa620c5ed342a758b34c089f2dc2819541f48ec.zip
Version bump.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/fast_gettext')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.6.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 10cbb72bc079..2fb64e88e241 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.4 2011/10/07 06:10:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.5 2011/10/07 06:13:08 graaff Exp $
+
+*fast_gettext-0.6.0 (07 Oct 2011)
+
+ 07 Oct 2011; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.6.0.ebuild:
+ Version bump.
07 Oct 2011; Hans de Graaff <graaff@gentoo.org> -fast_gettext-0.5.11.ebuild,
-fast_gettext-0.5.12.ebuild:
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.6.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.6.0.ebuild
new file mode 100644
index 000000000000..4217d691bd1a
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.6.0.ebuild,v 1.1 2011/10/07 06:13:07 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/activerecord )"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}