summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
commitd01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42 (patch)
tree3e988ba41efa6a928903a4af57cc30759807180d /dev-ruby/optparse
parentInitial import of Ruby, the OO scripting lang, into the portage tree. (diff)
downloadhistorical-d01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42.tar.gz
historical-d01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42.tar.bz2
historical-d01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42.zip
Initial import of a slew or Ruby modules. This is the base for
generating RD (similar to Perl's POD) files. Hey, we might as well start with the ability to document the code we write. 8) The modules installed are: amstd -- standard libraries for Ruby optparse -- an option parser racc -- lexical parser strscan -- fast string formatter/scanner rdtool -- RD doc formatter
Diffstat (limited to 'dev-ruby/optparse')
-rw-r--r--dev-ruby/optparse/files/digest-optparse-0.7.51
-rw-r--r--dev-ruby/optparse/optparse-0.7.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/optparse/files/digest-optparse-0.7.5 b/dev-ruby/optparse/files/digest-optparse-0.7.5
new file mode 100644
index 000000000000..5f120155511a
--- /dev/null
+++ b/dev-ruby/optparse/files/digest-optparse-0.7.5
@@ -0,0 +1 @@
+MD5 6b4a5e1957f62c030b81d8041dc1f63a optparse-0.7.5.tar.gz
diff --git a/dev-ruby/optparse/optparse-0.7.5.ebuild b/dev-ruby/optparse/optparse-0.7.5.ebuild
new file mode 100644
index 000000000000..345c8ae45073
--- /dev/null
+++ b/dev-ruby/optparse/optparse-0.7.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/optparse/optparse-0.7.5.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Yet another option parser for Ruby"
+SRC_URI=" http://member.nifty.ne.jp/nokada/archive/${A}"
+HOMEPAGE=" http://member.nifty.ne.jp/nokada/ruby.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1"
+
+#src_compile() {
+# cd ${S}
+# try ruby setup.rb config --without=amstd
+# try ruby setup.rb setup
+#}
+
+src_install () {
+ cd ${S}
+ insinto /usr/lib/ruby/site_ruby/1.6
+ doins optparse.rb
+
+ insinto /usr/lib/ruby/site_ruby/1.6/optparse
+ doins optparse/*
+}