summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-11-28 09:34:07 +0000
committerAlex Legler <a3li@gentoo.org>2009-11-28 09:34:07 +0000
commit1462b42941c72e0a0f944e1eaf72f49e66752cbd (patch)
treea486f9942a3794a1b2712b9977cd8b2c87ba7f7c /dev-ruby/rails
parentDrop --impl-headers since the call was dropped from new eselect, and should b... (diff)
downloadhistorical-1462b42941c72e0a0f944e1eaf72f49e66752cbd.tar.gz
historical-1462b42941c72e0a0f944e1eaf72f49e66752cbd.tar.bz2
historical-1462b42941c72e0a0f944e1eaf72f49e66752cbd.zip
Version bump, security bug 294797
Package-Manager: portage-2.2_rc52/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 3a15b39aa1fb..a2b3c9e1c903 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.157 2009/10/22 08:05:19 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.158 2009/11/28 09:34:07 a3li Exp $
+
+*rails-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-1.2.6-r1.ebuild,
-rails-2.0.5-r1.ebuild, -rails-2.1.2-r1.ebuild:
diff --git a/dev-ruby/rails/rails-2.3.5.ebuild b/dev-ruby/rails/rails-2.3.5.ebuild
new file mode 100644
index 000000000000..fe1c06b3a6fc
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5.ebuild,v 1.1 2009/11/28 09:34:07 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.6
+ >=app-admin/eselect-rails-0.15
+ >=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
+ >=dev-ruby/rubygems-1.3.2"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}