summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-03 09:08:58 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-03 09:08:58 +0000
commit8c3b7ab5bbd0bc811752e6a0f14bca0edbb3ed61 (patch)
tree48dd7347fad752b5b2374ae57a97b95cc1f36122 /dev-ruby/rb-inotify
parentMake it gold resistant, #369455 (diff)
downloadhistorical-8c3b7ab5bbd0bc811752e6a0f14bca0edbb3ed61.tar.gz
historical-8c3b7ab5bbd0bc811752e6a0f14bca0edbb3ed61.tar.bz2
historical-8c3b7ab5bbd0bc811752e6a0f14bca0edbb3ed61.zip
Initial import. Optional but usefull dependency for dev-ruby/fssm.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/ChangeLog10
-rw-r--r--dev-ruby/rb-inotify/Manifest14
-rw-r--r--dev-ruby/rb-inotify/metadata.xml8
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild29
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/ChangeLog b/dev-ruby/rb-inotify/ChangeLog
new file mode 100644
index 000000000000..67c4a61c5e04
--- /dev/null
+++ b/dev-ruby/rb-inotify/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rb-inotify
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.1 2011/06/03 09:08:58 graaff Exp $
+
+*rb-inotify-0.8.5 (03 Jun 2011)
+
+ 03 Jun 2011; Hans de Graaff <graaff@gentoo.org> +rb-inotify-0.8.5.ebuild,
+ +metadata.xml:
+ Initial import. Optional but usefull dependency for dev-ruby/fssm.
+
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
new file mode 100644
index 000000000000..b59ce95c283f
--- /dev/null
+++ b/dev-ruby/rb-inotify/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST rb-inotify-0.8.5.gem 12800 RMD160 55ceff41a5b9e904e7a5885a9e793636204dfe46 SHA1 7714461e87367728827e7857363825b499a28fc3 SHA256 a945717213ed3d977b29426c04722c2401af1ebd0c00cc0f43aa6f8c9f00945d
+EBUILD rb-inotify-0.8.5.ebuild 672 RMD160 88b47b256cc11c212f8caac362d9bde59257f92b SHA1 fd88fb90b5d988e95240045e9b51d21d34d20f63 SHA256 2979121312a9c6e3d27f60d6a0a7ff866873d7460b000aa637ff36494a3fbd26
+MISC ChangeLog 407 RMD160 053dbcadd5b0cd68535334ead953365620cfbac1 SHA1 8c6cd789dce1e8e39dbeffc37a754cd7d4e58dea SHA256 bb1740a575ed707ae55a9013c23954142e598e3de99dddb367e8f8da158f0efa
+MISC metadata.xml 219 RMD160 c4f05e85bd9645a64124d3847da25522de568428 SHA1 13b624bb74ad54c50dd466cb811f39ed171fe913 SHA256 670b7642b3830f31d24a317577d842b3499592b6e9a6283312b89c59397a2932
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk3opLAACgkQrnu0mw69JkptwAD/WfX0whEDBfxOSZVGwLcLujEq
+tL9vFtqLVaobxY3XuewA/iaeGA7JDN/sKv8dBg0Ruo8z3sl7oQ3rT261s7ri7/95
+=DfPv
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/rb-inotify/metadata.xml b/dev-ruby/rb-inotify/metadata.xml
new file mode 100644
index 000000000000..0a41bde91c60
--- /dev/null
+++ b/dev-ruby/rb-inotify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+ <email>trapni@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild
new file mode 100644
index 000000000000..7b838a81658f
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild,v 1.1 2011/06/03 09:08:58 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI."
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"